Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NBU java console rrror *no entity found* restore screen

Created: 03 Jan 2013 • Updated: 03 Jan 2013 | 19 comments

I'm trying to make a restore, but when i navigate through folders at restore screen i got a message *no entity found*. When I use Windows Administration Console everything works fine. I found similar threads discussing that error but no solution. Do you have any ideas what it can be ? Running Netbackup 7.5

I wondering it's a java console issue since it doesn't happen on windows administration console.

Comments 19 CommentsJump to latest comment

RamNagalla's picture

its actually issue between the Souce of the Query and the Netbackup data base.

sometimes, netbackup will not authenticate the query to get the information form the Netbackup data base..leads to this error.

most common is Timeout of this request..

 

could you expline does it happening for all the clinets? or specific to any particuler clients?

ldias's picture

It happens with just some clients.
As I told before, it doesn't happen with windows administration console. But since I'm more familiar with NBU java console i would like to solve it. It there any test i can do (console, client, etc) ? Java console is installed on my desktop. I don't have any other issue like communication problems.

RamNagalla's picture

 

Try to find the logs in   Installpath/veritas/netbackup/logs/bpjava-susvc  , when you are getting the error in Java console.

and see if you are finding any clues.

you can post the log as an attachment.

ldias's picture

@Nagalla

I created directory bpjava-susvc under Installpath/veritas/netbackup/logs and tried to reproduce the error but no logs inside it. I'm running java console from my desktop, not from master/media server. Is there something else I can do to enable these logs ?

quebek's picture

Well, I am having the similar issue. At my site its related to national characters in the direcotry name being browsed. I opened a case with SYMC in this regards. Waiting for their resolution. My env is 7.5.0.4...

Are you having also some national characters in the directory you are trying to browse for??

When I am brwosing through the same dir from windows console all is gr8.

Also when browsing from Java conole there is being log created where I found these entires - which told me that JAVA conosle is wrongly translating polish national characters and these wrong ones are being passed to bplist command...

so the bolded word in below dzi? should be passed to bplist as dziś and the JAVA gui translated ś to ? and thus - no entity was found.

(SR)bplist:
    Protocol Code: 224
    Status: 227
    Time Taken: 2659ms
    Error Msg: no entity was found
    Server Locale: en_US
    TO[0]:  -S server_name -C CLIENT_NAME -Listpolicy -l -b -P -W -R 1 -t 13 -E -unix_files -X -s 1355515200 -e 1355875199 -keyword '' '/E/DFSRoot/dzi?/'
    FROM[0]: no entity was found
    Aux data: null

 

My case is still open...

ldias's picture

@quebek

Although logs from Installpath/veritas/netbackup/logs/bpjava-susvc are not being recorded I captured errors from Netbackup background console. When the error happens here's the output: By the way what you did to enable these logs from your machine ?

(SR)bplist:
        Protocol Code: 224
        Status: 227
        Time Taken: 297ms
        Error Msg: no entity was found
        Server Locale: pt_BR
        TO[0]:  -S server_name -C client_name -Listpolicy -l -b -P -W -R 1 -t
13 -E -unix_files -X -s 1356715480 -e 1356715480 -keyword '' '/D/NFS//USUÁRIOS 2012/FORMULÁRIO/'
        FROM[0]: no entity was found
        Aux data: null

Seems same issue you're facing: enconding. From NBU Java console the pathfile shows up fine "USUÁRIOS" instead of "USU├üRIOS" and "FORMULÁRIO" instead of "FORMUL├üRIO". But on backgroung java console i got above message.

Most of my windows netbackup clients are in Portuguese. I've already tried to change java encoding C:\Arquivos de programas\Veritas\Java\setconf.bat

Line SET NBJAVA_FILE_ENCODING=pt_BR

 

quebek's picture

My master server is running on AIX, so what I did is to export DISPLAY variable to my PC, where I am running X-server software and run from that AIX box the jnbSA& command - its all windows were presented on my PC X-server software ;). This command showed me the logs which were created for this java session and there I found these errors. If you wish I can give you my case ID on priv... - as Marianne suggested

 

BTW I was already given with simial workaround to yours by the engineer handling my case, but this did not work at my env as his lab env.. Here is what I was given

1.  Make a copy of the /usr/openv/java/nbj.conf
 
2.  Add the following line to the end of the file: SET D_FILE_ENCODING=UTF-8
3. Restart the java console and see if the issue persists.

AJS's picture

Hello, for me it worked changing in:

C:\Program Files\Veritas\Java\setconf.bat

removed the REM (remark) and changed to UTF-8

SET NBJAVA_FILE_ENCODING=UTF-8

Regards.

Marianne's picture

Please log a call with Symantec Support.

Maybe you and quebek can exchange Case Id's and ask respective Support engineers to also refer to the other Case Id. 
Hopefully it will be fast-tracked to backline....

Keep us updated!

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

C_Moisan's picture

Any progress on this? I have the same issue but support seems slow to respond and hasn't been able to reproduce the issue. Please post if there's anything happening with your cases.

ldias's picture

Haven't progress yet. While there's no solution for the case I'm using NBU Windows console. Hope they fix it soon. I prefer using NBU Java console. It seems to me simpler and lighter.

Keep us update on any progress.

C_Moisan's picture

The tech assigned to my case was able to reproduce the issue and is talking to "Backline" and trying some proposed fixes. I will keep you guys updated.

Vickie's picture

 

I would suggest you cross verify below listed, 
 
1) Client Name (As per the name configured on Master Server)
2) Master Sever Name ( FQDN name of master server, by which it configured)
3) Policy type (Required policy type must be selected)
4) Restore type (Normal restore, in case of normal file system restore or choose appropriate)
5) Date (Valid date should select as on which backed up data exist)
C_Moisan's picture

I'm sorry, but how is this relevant to this problem? It has been established that this is a bug and the support guys were able to reproduce the issue...

Marianne's picture

Have you actually read any of these posts?

See this link for understanding of the problem: https://www-secure.symantec.com/connect/forums/restore-no-entity-found#comment-8168831

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

Not sure if installing one of the Language Packs for NetBackup would help with this?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Vickie's picture

 

Its Alright, but as per error mentioned in your post,
This could occurs due to not in-appropriate restore type selected. 
 
 *no entity found*
 
If this is an Bug, I guess it would get resolved by taking veritas to 7.5.0.4. 
As no such error comes up with this version 7.5.0.4 while doing restore, I am working on same version.
C_Moisan's picture

Sorry, I should have mentionned the other thread I posted to: https://www-secure.symantec.com/connect/forums/restore-no-entity-found

 

You will understand the whole issue by looking at the other thread.