Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

NBU Oracle GUI not there

Created: 07 Feb 2013 • Updated: 03 Apr 2013 | 3 comments
This issue has been solved. See solution.

HI Team,

Problem Statement= i cannot see gui to create template for ORACLE_BACKUP.

In my environment, 

Master/Media Server = Solaris 10 on LDOM--- 7.5.0.4

Storage= DISK

Client = Solaris 10 on LDOM --- 7.5.0.4  

Oracle database version =  11.2.0.2       location = /u01

i just edited the script from client location = /usr/openv/netbackup/ext/db_ext/oracle/samples/rman/hot_database_backup.sh

if i run this script, sh hot_database_backup.sh it runs sucessfully, and i can see in NBU gui that the backup is happening. then again i make i policy and put the path of this script, and re-run the manuall backup, backup was sucessfull.

i am uploading the script, pics of NBU Master Server and Client  focusing the GUI for ORACLE is not there.

 

I am looking responses at earliest. THANKS.

 

Comments 3 CommentsJump to latest comment

Marianne's picture

Does your user Id have sufficient Oracle priveleges?

Extract from NBU for Oracle manual:

 

On UNIX and Linux systems, how you log onto NetBackup depends on how your Oracle authentication is configured:
■ OS authentication for Oracle:
Logon to NetBackup as an Oracle DBA UNIX account that includes sysdbaprivileges.
■ Oracle authentication by password file:
Log on to NetBackup using any UNIX account, including root. You need
to provide additional Oracle logon information later in the backup process.
For the host name, type the name of the client upon which the Oracle database
and NetBackup for Oracle reside. Type your user name and password in the
other fields. You can log on as a regular user.
 
...
See “Creating RMAN templates using the NetBackup for Oracle RMAN template generation wizard”

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Yasuhisa Ishikawa's picture

oratab file exists on the client? Any instance listed in oratab?

If not , NetBackup does not recognize Oracle instance on the client. Create oratab.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION
Shakil Qureshi's picture

issue resolved, copy oratab from the desired location and paste it under /etc. e.g

 

1) do, find / -name oratab   on client machine.

2) it will show as   /u01/app/oracle/product/11.2.0.2/db_1/install/oratab

3) more oratab and cp oratab to /etc

 

and then try with the gui. it will work. make sure lsnrctl & DB are up and running.

 

Regards,

Shakil Qureshi
Technical Consultant