Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

NDMP backups with EMC Celerra DART 6

Created: 27 Dec 2012 • Updated: 24 Feb 2013 | 5 comments
This issue has been solved. See solution.

Hello Everyone,

We recently upgraded from DART 5.x to 6.x on EMC Celerra NS480.  All our NDMP backups are failing.  Any thoughts on changes in this new DART version that are affecting this? We are running NBU 7.0 with Solaris master server and combination of Windows and Solaris media servers.  All NDMP backups fail with error 99.  Very little info on NBU side.

I was getting this error on Celerra:

"1356152802: NDMP: 6: Thread ndmp859 filterDialect could not be set - prereqs not met [pax_cmd_thread::setFilterDialect]

1356152802: NDMP: 3: Thread ndmp859 < Failed to get CIFS names for automaticTempNDMPCkpt914-50-1356152792 >

1356152802: NDMP: 3: Thread ndmp859 Cannot get CIFS names for source(/root_vdm_3/root_vdm_3/opcifs_d2)/ckpt
 
(/root_vdm_3/root_vdm_3/automaticNDMPCkpts/automaticTempNDMPCkpt914-50-1356                          152792).
1356152802: NDMP: 3: Thread ndmp859 Failed to start pax threads
"
 
But now it appears I have regressed and only get this error on Celerra:
 
"2012-12-27 18:55:07: NDMP: 6: Active NDMP backup/restore streams: 1, system configured concurrent streams: 4, maximum concurrent sessions supported: 4.
2012-12-27 18:55:07: NDMP: 3: Session 086 (thread ndmp086) NdmpdMover::connect: connect error: Connection refused
2012-12-27 18:55:07: NDMP: 3: Session 086 (thread ndmp086) Invalid state to stop mover (0).
2012-12-27 18:55:07: NDMP: 6: Cleanup: Active NDMP backup/restore sessions back to: 0, system configured concurrent streams: 4, maximum concurrent sessions allowed: 4.
"
 
Any thoughts or pointing in a direction for help is appreciated.
 
Thank you
 

Comments 5 CommentsJump to latest comment

Marianne's picture

Have you tried to verify connectivity between Media server and Celerra with:

tpautoconf -verify <celerra_host>

Other than that - my only thought is to log a call with EMC...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

gsc-msi's picture

Thanks for the response Marianne.  Here is the output of tpautoconf:

 

 

C:\Program Files\VERITAS\Volmgr\bin>tpautoconf -verify server_2
Connecting to host "server_2" as user "ndmp"...
Waiting for connect notification message...
Opening session--attempting with NDMP protocol version 4...
Opening session--successful with NDMP protocol version 4
  host supports TEXT authentication
  host supports MD5 authentication
Getting MD5 challenge from host...
Logging in using MD5 method...
Host info is:
  host name "server_2"
  os type "DartOS"
  os version "EMC Celerra File Server.T.6.0.61.0"
  host id "abc1997"
Login was successful
Host supports LOCAL backup/restore
Host supports 3-way backup/restore
 
Looks pretty good here.  I was also thinking that after the code upgrade on the EMC, it was restarted.  Maybe that affected the SCSI paths for the tape drives but they don't appear to have changed.  Pat on EMC looks same as what is configured on NBU side.
 
Unfortunately, the customer does not have a valid EMC support contract at the moment.  I'm performing CIFS level backups at the moment until I can sort through this NDMP trouble and the support contract is renewed.
Yasuhisa Ishikawa's picture

By googling, there may be something wrong on Celerra, but it is hard to point out.

You should open a case with EMC or post in EMC forum. They will provide various possible causes.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

SOLUTION
Toni74's picture

 

Please post output of :

C:\Program Files\VERITAS\Volmgr\bin>tpconfig -dnh

C:\Program Files\VERITAS\Volmgr\bin>tpautoconf -probe server_2

C:\Program Files\VERITAS\Netbackup\bin\admincmd\bpstulist -label <NDMP_stu> -U

 

I had Status Code 99 in a NBU 6.5 version and solved it re-creating the NDMP Storage Unit (my customer made the first one that I removed).

quebek's picture

Hello

can you please pass us the output from such commands run on control station on your NS480 device

server_param server_2 -facility NDMP -list

server_param server_2 -facility PAX -list

In my config the bufsz and readWriteBlockSizeInKB are equal, take a look

[nasadmin ~]$ server_param server_2 -facility NDMP -list
server_2 :
param_name                       facility  default     current   configured
maxProtocolVersion                  NDMP          4          4
scsiReserve                         NDMP          0          0
CDBFsinfoBufSizeInKB                NDMP       1024       1024
bufsz                               NDMP        128        256        256
convDialect                         NDMP     8859-1     8859-1
concurrentDataStreams               NDMP          4          4
portRange                           NDMP 1024-65535 1024-65535
includeCkptFs                       NDMP          1          1
md5                                 NDMP          1          1
snapTimeout                         NDMP          5          5
dialect                             NDMP
forceRecursiveForNonDAR             NDMP          0          0
tapeSilveringStr                    NDMP         ts         ts
excludeSvtlFs                       NDMP          1          1
snapsure                            NDMP          0          0
v4OldTapeCompatible                 NDMP          1          1

[nasadmin ~]$ server_param server_2 -facility PAX -list
server_2 :
param_name                       facility  default     current   configured
checkUtf8Filenames                   PAX          1          1
dump                                 PAX          0          0
readWriteBlockSizeInKB               PAX         64        256        256
filter.dialect                       PAX
writeToArch                          PAX          1          1
filter.numDirFilter                  PAX          5          5
filter.caseSensitive                 PAX          1          1
filter.numFileFilter                 PAX          5          5
paxStatBuff                          PAX        128        128
writeToTape                          PAX          1          1
noFileStreams                        PAX          0          0
scanOnRestore                        PAX          1          1
nRestore                             PAX          8          8
allowVLCRestoreToUFS                 PAX          0          0

global_params:
param_name        facility  configured_value
readWriteBlockSizeInKBPAX       256