Video Screencast Help

NDMP Drive Paths

Created: 14 Sep 2012 • Updated: 04 Oct 2012 | 6 comments
This issue has been solved. See solution.

I use a netapp filer as NDMP destination. Now i replaced the filer and the tape drives got new paths. The "Configure storage devices" wizard does somehow not update the drive paths in NBU (6.5.6) to the new destination. During the wizard process i can see that it is detecting the correct paths but it does not update them on the drive configuration after the wizard is finished.

Is there another way to update the paths?


Comments 6 CommentsJump to latest comment

Andy Welburn's picture

Did you delete the existing?

Been a long time since I managed NetApp attached tape drives, but with the installation of a new filer & its associated new paths I would be more inclined to delete & recreate the drives.

Unless you can use tpautoconf :

/usr/openv/volmgr/bin/tpautoconf  -replace_drive  drive_name
     -path drive_path

tgw0815's picture

Thanks Andy, i just deleted the old paths and ran the wizard again. But now i get:

NDMP Backup fails with:14.09.2012 13:19:27 - Error ndmpagent(pid=7168) NDMP_LOG_ERROR 7 DATA: Backup terminated: EVENT: INTERNAL ERROR (for /vol/b2d)

14.09.2012 13:19:27 - Error ndmpagent(pid=7168) NDMP backup failed, path = /vol/b2d

14.09.2012 13:19:27 - Error bptm(pid=6080) none of the NDMP backups for client host04 completed successfully 14.09.2012 13:19:54 - end writing; write time: 00:00:34NDMP backup failure(99)

The directory path does exist. and i can see successful ndmp logins on the filer.

Andy Welburn's picture

Not come across that before, sorry.

I presume you've verified access to the NDMP host (tpautoconf -verify ndmp_hostname) & that NDMP is enabled on the filer.

Anything in the backup log on the filer (/vol0/etc/log/backup I think) or in the syslog messages (etc/messages)

Karthikeyan Sundaram's picture

Is this local NDMP backups or remote NDMP Backups?

Did you try probing drives from netbackup?

tpautoconf -verify FILERNAME

tpautoconf -probe FILERNAME

Also just make sure to check the NDMP sessions on the filer end( ndmpd sesions all) If you found anything, kill them and reset the port from filer end.

Thanks, Karthikeyan Sundaram.

bbahnmiller's picture

I have found that when the NetApp filers bounce, I can lose device path connections. But what seems to happen for me is that the filer creates new device paths, that are effectively duplicates of the old path.

I run several steps to recover the NDMP tape devices:

  1. Kill all ndmp sessions on the filer, if any - "ndmpd killall"
  2. Check if you have any tape drives configured on the filer - "sysconfig -t"
  3. Remove all tape aliases on the filer - "storage unalias -t"
  4. Reset the tape drive adapters. BE VERY CAREFUL HERE! You don't want to reset your disk drive adapter! Make sure you know which adapter is connected to your tape drive. Example, remember to use the correct adapter for your system - "storage disable adapter 1a", then "storage enable adapter 1a".
  5. Reset the tape aliases - "storage alias".
  6. Delete your NDMP tape drives (the GUI works great for this.)
  7. Then rescan your tape drives.

This process has worked every time for us. It's a pain, but it works.

tgw0815's picture

Deleting the old paths solved the issue.