Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

NDMP Restore job failing with Error code 2826

Created: 28 Jun 2013 • Updated: 11 Jul 2013 | 8 comments
This issue has been solved. See solution.


Please help me with a solution to get over of a solution on restore failure code 2826.

6/28/2013 20:59:26 - begin Restore
06/28/2013 20:59:41 - number of images required: 1
06/28/2013 20:59:41 - media needed: B*****
06/28/2013 20:59:41 - media needed: B******
06/28/2013 20:59:46 - restoring from image lbas-n*****_1371844688
06/28/2013 20:59:48 - Info bpbrm (pid=14709) lbas-******* is the host to restore to
06/28/2013 20:59:48 - Info bpbrm (pid=14709) telling media manager to start restore on client
06/28/2013 20:59:49 - Info bpbrm (pid=14709) spawning a brm child process
06/28/2013 20:59:49 - Info bpbrm (pid=14709) child pid: 14715
06/28/2013 20:59:51 - Info bpbrm (pid=14715) start tar on client
06/28/2013 20:59:52 - Info tar (pid=14724) Restore started.
06/28/2013 20:59:54 - requesting resource B*****
06/28/2013 21:01:08 - Waiting for scan drive stop BAS_01_LTO4_F8_R2, Media server: p-*******
06/28/2013 21:01:09 - Info bptm (pid=14714) Waiting for mount of media id B****** (copy 1) on server p-bas-sl-nbmedia08.
06/28/2013 21:01:09 - started process bptm (pid=14714)
06/28/2013 21:01:09 - mounting B*****
06/28/2013 21:01:09 - granted resource  B*****
06/28/2013 21:01:09 - granted resource  BAS_01_LTO4_F8_R2
06/28/2013 21:01:10 - Info bptm (pid=14714) INF - Waiting for mount of media id B***** on server p-bas-sl-nbmedia08 for reading.
06/28/2013 21:01:57 - mounted B*****; mount time: 0:00:48
06/28/2013 21:01:57 - Info bptm (pid=14714) B*****
06/28/2013 21:01:58 - Info bptm (pid=14714) INF - Waiting for positioning of media id B***** on server p-bas-sl-nbmedia08 for reading.
06/28/2013 21:01:58 - positioning B***** to file 69
06/28/2013 21:03:27 - positioned B*****; position time: 0:01:29
06/28/2013 21:03:27 - begin reading
06/28/2013 21:03:28 - Info bpbrm (pid=14709) sending media manager msg: CONTINUE RESTORE
06/28/2013 22:02:05 - Error ndmpagent (pid=14724) NDMP restore failed from path /vol/lbasfiler103_v21/ct_bofarm_emea_prod_sv
06/28/2013 22:02:06 - end reading; read time: 0:58:39
06/28/2013 22:02:06 - Info ndmpagent (pid=14724) done. status: 5: the restore failed to recover the requested files
06/28/2013 22:02:07 - Info bpbrm (pid=14709) media manager for backup id lbas-n*****_1371844688 exited with status 0: the requested operation was successfully completed
06/28/2013 22:02:07 - restored from image lbas-n*****_1371844688; restore time: 1:02:21
06/28/2013 22:02:07 - Info bpbrm (pid=14709) sending media manager msg: TERMINATE
06/28/2013 22:02:09 - end Restore; elapsed time 1:02:43
Failed to get status code information (2826)

Operating Systems:

Comments 8 CommentsJump to latest comment

huanglao2002's picture

NDMP Restore job failing with Error code 2826

Can you tell use more about NDMP backup environment? and restore require?

Brook Humphrey's picture

OK so most of these types of errors have to do with permissions or something similar. 

What type of ndmp filer is it?

You will most likely have to get the logs from the filer to determine what the actual issue is.

Brook Humphrey
Managed Backup Service

Principal Backup Administration Specialist

watsons's picture

Enable ndmpagent log (OID=134) to check, a few possible reasons:

- NDMP credential change, you can rule this out if the backup works though.
- Restore path has not enough space for the backup data
- Restore path write permission

Satyajit Pal's picture


- I tried to change the NDMP credentials, but still the job was failing after running more than 4-5 hrs with the same error.

- Restore path was added with 400 GB volume extra, when the job was failing with the same error. We expected the same, but even after adding extra volume also it didn't solve the issue.

- Previous to this failure, 3 restores wer completed successfully from the same media.

My Assumption is:

- It might be media issue.

Satyajit Pal's picture

The environment was to restore multiple windows folders, each one of them having multiple sub folders. The actual data size was more than 2 TB.

Satyajit Pal's picture

FInally we mounted the snapshot to the user's local desktop and the dat was then imported.

Restore didn't work at all and the issue has not yet been resolved.