Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Need to add the "Open Process Screen" link on Service Desk 7.5 SP1 reports

Created: 08 May 2014 • Updated: 13 May 2014 | 6 comments
QuietLeni's picture
This issue has been solved. See solution.

Dear All,

I needed to create a new report via "Sql Query with Parameters" like the "Incidents by Queue" report and using the same SQL and it works nicely, all except for the fact that the "Open Process Screen" functionality does not work and I cannot click the "Report Process ID" item to open the Incident!

I have compared the two reports and I cannot see where the reports are different (except for the selection criteria).

What have I not done and/or what do I need to do to get this to work?

I will mark the answer.

QuietLeni

Operating Systems:

Comments 6 CommentsJump to latest comment

QuietLeni's picture

Dear All,

It looks like adding the "Include Process Actions" to the report is not possible with a SQL Query report at the moment. As soon as you include a SQL report data source, the "Include Process Actions" item disappears.

I feel an Idea coming on...

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

toomas's picture

Adding the "Include Process Actions" is not possible with SQL Reports.

Idea would be a good thing but I believe there is already an existing idea (or a few) for the same thing to vote on. This was the first one that search turned up:
https://www-secure.symantec.com/connect/idea/service-desk-sql-report-query

michael.george's picture

Sure, it'd be nice to have. As a work around, make a data profile for your report and do a standard process report instead of a SQL report.

If a post solves your issue, please mark it as a solution. It makes these forums better for everyone.

QuietLeni's picture

Guys,

I have found a reasonable workaround. The problem was that I needed to be able to report upon Incidents in two queues, not just one and that was why I did the report. Instead, I have made the workaround of setting up two web parts, each showing the incidents in each queue.

It would have been nice to have the "Include Process Actions", but this now works for us...

Kindest regards,

QuietLeni

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

jbrown's picture

micheal.george is correct, the best practice fix is to write your own sql and then have it show in a report is use the data profile option, under the List and Profiles menu.

As described in this connect post.https://www-secure.symantec.com/connect/articles/using-custom-sql-servicedesk-report-builder-and-still-use-parameters

SOLUTION
QuietLeni's picture

Thanks jbrown.

I marked yours as the solution because you gave me the whole solution!

Again, thanks!

QuietLeni

What is the point of an Asset Management Solution that needs excessive management? Let me help you.