Video Screencast Help

Need to configure backup to use private network

Created: 19 Jul 2013 • Updated: 04 Aug 2013 | 12 comments
Madhusudana's picture
This issue has been solved. See solution.

 

Master Server - Soalris 10 - Name:  master.com  IP: 10.1.10.27
 
Client Server - Linux
 
I have to configure client server backup to use private network but in policy i have to use the server name (not the backup interface name).
 
For ex :
 
Client server details:
 
server name : abc.com  and  ip : 170.2.4.13
 
Private server name: abcb.com and ip: 10.19.3.15
 
 
 
I have created a policy and added a client name : abc.com
 
Also, i have mentioned the backup interface name in REQUIRED_INTERFACE tab (ie abcb.com) in Master server - client host properties.
 
Backup is running fine but my doubt here is, how to find whether client backup running using Public IP or Private IP of client servers.
Please let me know is there anyway to find the backup happening via which client interface
 
 
When i run bptestbpcd in Master server for actual name
 
"# bptestbpcd -client abc.com -verbose
1 1 1
10.1.10.27:56540 -> 170.2.4.13:1556
10.1.10.27:56542 -> 170.2.4.13:1556
PEER_NAME = cpsvp3810.wellsfargo.com
HOST_NAME = abcb.com
CLIENT_NAME = abc.com
VERSION = 0x07100000
PLATFORM = linuxR_x86_2.6
PATCH_VERSION = 7.1.0.3
SERVER_PATCH_VERSION = -1.-1.-1.-1
MASTER_SERVER = master.com
EMM_SERVER = master.com
NB_MACHINE_TYPE = CLIENT
10.1.10.27:56552 -> 170.2.4.13:1556
 
 
When i run bptestbpcd in Master server for Private NIC name
 
 
 
"# bptestbpcd -client abc.com -verbose
1 1 1
10.1.10.27:58827 -> 10.19.3.15:1556
10.1.10.27:58828 -> 10.19.3.15:1556
PEER_NAME = master.com
HOST_NAME = abcb.com
CLIENT_NAME = abc.com
VERSION = 0x07100000
PLATFORM = linuxR_x86_2.6
PATCH_VERSION = 7.1.0.3
SERVER_PATCH_VERSION = -1.-1.-1.-1
MASTER_SERVER = master.com
EMM_SERVER = master.com
NB_MACHINE_TYPE = CLIENT
10.1.10.27:58842 -> 10.19.3.15:1556
Operating Systems:

Comments 12 CommentsJump to latest comment

Nagalla's picture

the command that you used is same but 2 different outputs .. which is not possible..

did you run the command in 2 different machins?

 what is the correct command to get the above outputs?

 

if your requirement is to use the IP 10.19.3.15 to take the backup of the client..

1) make sure this IP is communicating from master and Media servers

2) make sure this IP is rolving the client name

2.1) you can use /etc/hosts file for name resoutions, and the below entiry in master and media server /etc/hosts file to get this done

10.19.3.15    clientname

2.2) you can use DNS for the same

 

Madhusudana's picture

Hi Nagalla,

I got 2 output because once i used servername ie abc.com and 2nd time i used backup interface name i.e abcb.com 

1)Both the IP's are communicating from Master and Media servers

2)We cant edit the hosts file in our environment but we have DNS

 

How can i make sure that backup is happening via backup network (any commands or is there any way) ?

 

Nagalla's picture

use abcb.com in the policy clients tab...

that will do everyting... 

SOLUTION
Madhusudana's picture

There is a process that we should use only server name i.e abc.com in the policy.

Is there any way to configure the backup with below requirement

1)We should mention abc.com in the policy client tab and should not use any hosts file (as we have DNS and we are not suppose to use hosts file entry).

2)I have configured the backup by keeping above criteria and mentioned private interface (abcb.com) in the 

REQUIRED_INTERFACE tab (ie abcb.com) in Master server - client host properties.

Backup is running fine but i doubt backup is not happening via private network as when i run bptestbpcd from master server (bptestbpcd -client abc.com -verbose) communication is happening via public IP.

 

Please let me know is there any way to configure the backup by keeping above criteria or its not at all possible to do it?

Nagalla's picture

as you specified REQUIRED_INTERFACE, it should use abcb.com to send out the data.

the only way that you can confirm is by looking into the logs.

bpcp, bpbkar log from client

bpbrm log from Media server...

look into those logs and see if you are find the Priviate IP for the communications...which will confirm the IP being used to send the data.

Madhusudana's picture

Sorry for the delay in reply.

Thanks Nagalla for your help, backup is happening via normal interface not via 10G interface :(

mph999's picture

REQUIRED_INTERFECAE should NOT be used.

Instead, use PREFERRED_NETWORK - this is the 'replacement' for REQUIRED_INTERFACE.

In fact, on upgrade to 7.x (can't remember the exact version it came in) any REQUIRE_INTERFACE entries are converted to PREFERRED_NETWORK.

Best practices for Preferred Network, usage, and how it affects source and destination
http://www.symantec.com/docs/HOWTO60779
 
Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Madhusudana's picture

Thanks Martin, I tried with preffered network option but again backup goes via prod IP

No idea what i am missing.

mph999's picture

OK, now I've read the post properly (I was just commenting on REQUIRE_INTERFACE before) you need to handle this with hosts file I think, unless you specify the bkup name in the policy which is what you should really do.

Eg.

On master 

abc.com       10.19.3.15

Ie. for the client name you trick it into using the backup address.

I think that will work - perhaps you could at least try it as a test ?

M

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Marianne's picture

As per Nagalla's post:

use abcb.com in the policy clients tab...

You CANNOT expect to use use abc.com in the policy with IP address XXX.XXX.XXX.XXX and expect NBU to know to use YYY.YYY.YYY.YYY IP address. 

NBU uses normal TCP/IP.
If abc.com resolves to XXX.XXX.XXX.XXX then that is the route that comms and data flow will go.
If you want traffic to be routed to YYY.YYY.YYY.YYY IP address, you need to use abcd.com.
REQUIRED_INTERFACE or PREFERRED_NETWORK is only for user/client intiated comms.

A workaround may work if you add hosts entries everywhere to use abc.com hostname with YYY.YYY.YYY.YYY IP address and ensure OS-level lookup will look at hosts file first and then at DNS. But that may affect other application comms as well....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Madhusudana's picture

Thank you all for your inputs. I tried everything and we decided to go with add backup interface name in policy....

Madhusudana's picture

Thanks Nagalla, Martin and  Marianne.

I am marking Nagalla's post as solution as he has given that sugestion first :)