Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

Need to make an unmanaged client into a managed client. This must be done remotely

Created: 29 Apr 2013 • Updated: 29 Apr 2013 | 2 comments
This issue has been solved. See solution.

I asked this earlier, but from what I have seen I have to go on to the PC locally to run SMC - commands which I often can not do. I HAVE to do this over a remote connection. I've tried using the communication update package from SEPM, but I have gotten errors and I could not switch it out. I tested this on my own PC and it said Deployment failed, there was NO explanation as to WHY this failed but it failed.

SEP 12.1.2015 2015

Windows 7 64 Bit Client

Comments 2 CommentsJump to latest comment

SMLatCST's picture

I know you've already tried the wizard inbuilt into RU2 as per your other thread and Biran's suggestions, so you may want to try the sylinkdrop tool instead:

http://www.symantec.com/docs/HOWTO81179 #EDIT# Whoops wrong link #EDIT#

I've always preferred this option as I've generally found it more reliable.  To run it on a remote machine however, I normally end up scripting it and pushing that script out either using GPOs or Altiris.  A common script I use is something like:

If not exist %temp%\newsylinkfile.xml (
Xcopy \\<NetworkLocation>\newsylinkfile.xml %temp%
 “%programfiles%\Symantec\Symantec Endpoint Protection\<ClientVersionNumber>\Bin\ SylinkDrop.exe” –silent %temp%\newsylinkfile.xml)
 
The newsylinkfile.xml should be replaced with the name of the file exported from the new SEPM environment.
The <NetworkLocation> is a share (accessible to SEP clients) hosting the newsylinkfile.xml file.  Read permissions are required to this share and file.
The <ClientVersionNumer> is assumed to be “12.1.2015.2015”, in your case.
The script will require changes if running against a 64-bit machine, replacing %programfiles% with %programfiles(x86)%”.  The differentiation between processor architecture can be included in the script with additional “If” statements, or accommodated via WMI (for GPO distribution)

#EDIT2#

You could also do this with psexec if it's a one-off, but I've not tried it myself

SOLUTION
Riya31's picture

Try  with sylinkreplacer utility.But ensure that tamper protection is disabled on systems.