Video Screencast Help

.NET dll's not scanning

Created: 20 Apr 2010 • Updated: 24 Aug 2010 | 6 comments
This issue has been solved. See solution.

Hi

Since upgrading to Wise Installation Studio 7.4.0.214 I have problems with .NET dlls.

Previously the dll's would populate with Culture, GUID, Name, processorArchitecture, PublicKeyToken, RuntimeVersion and Version (when looking at the Assembly tab of the file properties)

In a project I have replaced a non .NET file and compiled the install however all these properties have been lost and the program is failing where these dll's are called.

Has anyone else experianced this?  Any suggestions of what to try?

Thanks

Amardeep

Comments 6 CommentsJump to latest comment

EdT's picture

Did you record all your configuration settings on your old WIS7 installation before upgrading?

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.

Amardeep01's picture

i didn't i'm afraid, the only problem seemed to be the merge module folder, the certificate information (location) was still present after the upgrade.

i've removed the files and re-added them hoping that would cause them to be rescanned

JohanH's picture

The assembly attribute scanning has changed in 7.0 SP2. There has been a long standing bug that is finally fixed. In previous versions, when both Wildcards and a path variable was used, assembly attributes were never added and the file was added to the hash table. Only by unchecking the add to hash table option for each file made the assembly attributes appear when rescanning. In SP2, I notice that files that have been added with previous versions of Wise, do not pick up the assembly attributes, but I have to remove the file and add it again to make make the assembly attributes appear. It is possible that there is still a bug somewhere. The assembly scanning has always been buggy, since the first versions of Wise that supported .NET.

Did you check the 'Rescan assembly attributes on compile' in Tools, Options, .NET assemblies?

Amardeep01's picture

Thanks for the reply Johan.

The rescan option is ticked, the folder was using wildcards to pick up the dll's.

I removed the files so they would be readded automatically, removed the folder scanning and added the files maually and I have also created a new project with just the dll's being installed into the GAC but the attributes are not picked up.

Adding the properties manually doesn't seem to help either.

I have made sure the machine is patched fully especially all the .NET stuff, the only option seems to be to uninstall and then reinstalling WISE.

Amardeep01's picture

I uninstalled and then reinstalled removing wise and sp2, still the same.

Now back to using sp1 which populated all the attributes as soon as the files were added.

SOLUTION
EdT's picture

This indeed has the appearance of a bug. Unfortunately, the WIS 7 product is being discontinued, so it is somewhat unlikely that there will be any further fixes released.

If your issue has been solved, please use the "Mark as Solution" link on the most relevant thread.