Video Screencast Help

NetApp File Shares Backup With out NDMP BE 2012

Created: 25 Dec 2012 • Updated: 29 Dec 2012 | 16 comments
vamsivaddi's picture
This issue has been solved. See solution.

Hello All,

I wanted to backup NetApp file shares with out using NDMP option.

I was trying to map the shares as network driveson one of the server with RAWS installed but it is not listing in Backup selection.

Can you please let me know the is there any way to Backup NetApp CIFS shares without NDMP option?

Comments 16 CommentsJump to latest comment

Kiran Bandi's picture

Make sure you have "Enable selection of User Shares" option checked from Backup Exec setings --> Network and Security.

Refer to http://www.symantec.com/docs/TECH189560

vamsivaddi's picture

HI KIran,

I have enabled that user shares option.

But still Netapp shares are not listed in backup selections, FYI the netapp shares are mapped as network drives on the windows server with RAWS installed. (Also tried on media agent)

I have also tried to add the netapp filer to Backup exec but still failed with the attached error.

I am using storage root password to add the storage server to BAckup Exec.

 

NetApp CIfs Shares with out NDMP.jpg

Thanks & Regards,

Vamsi Krishna

Kiran Bandi's picture

Have you tried using the IP address instead of server name while adding Netapp CIFS Server?

First try accessing it from Windows Explorer on Backup Server and see if you can access shares. If you can add the cifs server on NetApp to domain then try using Domain Administrator credentials while adding it to BE.

vamsivaddi's picture

HI Kiran,

Tried adding NetApp using FQDN/IP Address and provided the credentials tried both root and domain admin who has sufficient privileges.

 

But still i can see the above message?

Thanks for your time 

 

Thanks & Regards,

Vamsi Krishna

pkh's picture

You cannot backup mapped drives.  Mapped drives are associated with an online session and BE runs as a batch job.  You should add the shares on the NetApp as another server in the BE console and use their UNC path.

vamsivaddi's picture

Hi,

I am adding NetApp to BE console as Fileserver but still i can see the above attached message.

As netapp OS is a flavour of LINUX do you want me to add as a linux server.

Assuming that software will not be pushed while adding linux hosts to BE console.

Thanks 

Thanks & Regards,

Vamsi Krishna

pkh's picture

No. You should not add it as a Linux server.  You should add it as a file server.

If you login to Windows with the BESA account, can you access the share using its UNC path?  If not, then you must add the BESA to the NAS as an administrator with full read/write access.

vamsivaddi's picture

Yes BE System Account also contains Full control permissions, i can access those share from Backup server also.

But i cannot see them in backup selections i can see browse failure message. 

Thanks & Regards,

Vamsi Krishna

pkh's picture

On your NetApp device, did you turn off NDMP?

Ahmed Nmichi Hassani's picture

Hi,

1. upgrade to ontap 8.1.1 as the previous versions have an issue with cifs shares as reported by netapp themselves
2. after the upgrade, you needs to block port 10000 on the backup exec media server (outgoing only)

 

vamsivaddi's picture

Hi All,

Thank you for all your suggestions.

My issue is resolved.

1. Add the NetApp Filer as a file server to BE2012 Console.

2.Use System logon account to authuntecate while adding the filer to BE console also give System  logon account full privileges to all teh shares you are backing up.

3.Change the NDMP port under etc\services in MEdia server to other than 10000.

4. Restart the BE2012 server.

5. i can be able to see all the NetApp file shares in the backup selection list.

6.  Change BE2012 Console>>Configuration & Settings>> Backup Exec Settings>> Network & Security>>  check the filed Enable the selection of User Shares .

Thanks, 

 

Thanks & Regards,

Vamsi Krishna

SOLUTION
KRedd's picture

Hi Vamsi

 I have a question  did you check whether all the other servers are backing up normally after this change

As you changed the NDMP port of the media server  from 10000  the media server would try to contact the other servers with the newly desiginated port  where as all the other servers would try to contact the media server on the same port 10000

So please check with other backups too

This article coud help you correctly

http://www.symantec.com/docs/TECH60554

http://www.symantec.com/docs/TECH24256

Colin Weaver's picture

For info - in recent versions of Backup Exec, if RAWS publishing/advertising is working you do not need the NDMP port to be the same on the remote servers as it is on the media server.

 

vamsivaddi's picture

Hi Kumar,

I have tried to run the backups with out changing the port on RAWS it worked with out any errors or exceptions.

 

I thought i need to change but looks like not required.

 

Thanks & Regards,

Vamsi Krishna

KRedd's picture

Hi Vamsi

That sounds fine .... If its working with out any changes its good

vamsivaddi's picture

HI,

 

Everything is fine but backups are successfull with exceptions ..

 

What about licensing dos it utilizes any licenses asremote agent is not installedn and no ndmp backups are configured.

 

How to avoid those warnnings

 

Backup- NetApp FQDN
V-79-57344-3844 - The Backup Exec server was unable to connect to the Remote Agent on machine NetApp FQDN.

The Backup Exec server will use the local agent to try to complete the operation.

V-79-57344-65277 - Snapshot Technology: Initialization failure on: "\\NetApp Hostname\Finance". Snapshot technology used: No.
 

Remote Agent not detected on netapp storage FQDN 

Thanks & Regards,

Vamsi Krishna