Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NetApp San not able to backup

Created: 13 Feb 2013 • Updated: 14 Feb 2013 | 4 comments
This issue has been solved. See solution.

We replaced our NetApp san with a newer NetApp san.  The backup jobs that were working fine on the old one will not work on the new one.  NDMP is disabled.. enabled wouldnt work either.  I tried to just change the path of already working backups to the new location but that didnt work.. tried to create from scratch.. all attempts yield the same error;

The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent. netapp san

PLEASE HELP!!

Comments 4 CommentsJump to latest comment

Gurvinder Rait's picture

I assume you are backing up CIFS shares with ndmp service stopped. Please ensure system logon account in backup exec is same as the account with which the BE services are running. Also ensure that the correct account is being used which has access on the shares. Ref : http://www.symantec.com/docs/TECH189560

pkh's picture

Try changing the ndmp port to something other than 10000.  See this document

http://www.symantec.com/docs/TECH24256

Colin Weaver's picture

If that change has meant that the version of Ontap has changed and also assuming that CIFS shares are being backed up and not using the NDMP Option) then try this

1) Disable NDMP on the NetApp (as you have already been advised

2) use a software firewall on your media server to block outbound traffic address to the IP address on the NetApp on Port 10000 (Do not block 10000 to  outbound to all IP address on yout network be very careful to only block it to the NetApp)

OR Upgrade to very latest Ontap 8.x version as per http://www.symantec.com/docs/TECH202458

Apparently Netapp made some changes to how the initial NDMP port (or in fact any IP port requests) are answered if the port if not listening.

In the past you would get a timeout or unable to connect type scenario (so no actual answer from the NetApp itself). However some versions of Ontap will apparently respond with soem kiond of Port not open answer - as this is an actual answer even though NDMP is disabled, this fools Backup Exec into believing that a remote agent is present and causes the failure.

At this current time I don't think we have an exact list of Ontap versions that might have this problem although I believe that both the latest 7.x versions and initial versions of 8.x were affected. Based on the technote I just provided it looks like they have fixed it again in the very latest versions of Ontap 8.x

rsmith0531's picture

We did the port changes, turned off NDMP (we dont have a license for it anyway).. Turns out there were updates that had taken place on our BUE server and it needed a reboot.. TOTAL DUH MOMENT!  Thanks for all the advise!

SOLUTION