Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NetApp Snaplock - alter previous settings

Created: 25 Nov 2010 • Updated: 28 Nov 2010 | 5 comments
Sarah.Seftel's picture
This issue has been solved. See solution.

Scenario:

 

Mailbox partitions were defined in the beginning of an archive project as a “NetApp device [Snaplock]” from the EV side.

From what I’ve read in the white papers it says that once you’ve defined the partition as [Snaplock] it cannot be changed.

 

Now i've been asked for the ability to delete items from EV, but deletion is unsuccessful because of the Snaplock.

 

I’ve searched the SQL DB, and found a table called dbo.partitionentry where “writeoncemedia” configured on value of 1 (snaplock).

I’ve created a test partition and gave it the NetApp snaplock as well, which created the value of 1, than – I change it to 0 and refreshed the vault console. And the test partition change from “NetApp Device [Snaplock]” to “NetApp Device” (without the snaplock).

 

Can anyone confirm that by changing the SQL value from 1 to 0 I actually made the vault think that this is no more a snaplock device? And I can continue with assigning delete permission to users?

 

Thanks!

 

Sarah.

Comments 5 CommentsJump to latest comment

AndrewB's picture

hi sarah, not sure if the lack of response is due to the holiday or to the nature of your situation. have you considered opening a case with support and getting their blessing for this?

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

TonySterling's picture

Also, a lot will depend on how your SnapLock is configured.  Will the device allow the delete?

Sarah.Seftel's picture

NetApp devices were moved to a non snaplock environment.

the only place I was still stuck with is from the EV side.

 

I've contacted Symantec and they approved for my to change the writeoncemedia from 1 to 0.

 

It worked smiley

MichelZ's picture

Sarah

This might work on the EV side, but EV will then not be able to delete the "physical" file if the NetApp is really snaplocked.

Best bet would probably be to copy the snaplocked data to a non-snaplocked volume, change paths in Database, and then change the writeoncemedia to 0.

However, I would recommend to get approval from support for this.

Cheers

SOLUTION
Sarah.Seftel's picture

as you can see in my answer to Tony S, I got Symantec's approval for doing this SQL change!

 

thanks smiley