Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup 6.5.5 Media server Problems

Created: 11 Mar 2010 • Updated: 21 May 2010 | 5 comments
This issue has been solved. See solution.

Hi,
I'm facing a very strange problem at the moment with netbackup 6.5.5.  I have a master server running windows 2003, NB 6.5.5, along with this I have created a media server (linux RH 5 u3 ) and zoned it in to the master servers robotic library tape drives (its a fibre attached tape robotic library).  What I want to achieve is for the media server to see the masters shared storage tapes and then backup straight to tape. When I do this I see the following from the vmoprcmd command:

                           HOST STATUS
Host Name                                  Version   Host Status
=========================================  =======   ===========
Master                                    655000    ACTIVE
media                                    655000    ACTIVE
                                PENDING REQUESTS
                                    <NONE>
                                  DRIVE STATUS
Drive Name               Label   Ready  RecMID  ExtMID  Wr.Enbl.  Type
    Host                       DrivePath                            Status
=============================================================================
HP.ULTRIUM4-SCSI.000     No      No                     No        hcart
    Master                   {3,0,0,0}                            ACTIVE
    Media                  /dev/nst0                            TLD

HP.ULTRIUM4-SCSI.001     No      No                     No        hcart
    Master                   {3,0,1,0}                            SCAN-TLD
    Media                   /dev/nst1                            TLD

It shows the master as active and the media as TLD is this normal or is the data going via the network to the master and then to tape,?  I would expect to see the media server as active?? I want the data to go straight to the shared tape drive.   When I configure storage devices from the master  through the wizard it picks ever thing up ok and creates 2 storage units for the masters robotic tape library, one for the master, one for the media. if I untick the on demand option it uses the media servers storage unit (and shows as active) but it fails with a (811) error code, when I check the activity monitor it hangs at the connecting prompt when it fails it announces that it failed to communicate with resource requestor, I have checked the licenses and the media server is using the shared tape option license, I have also checked the PBX connections and this is all ok.  The connections between them are ok as well.

I'm not sure why it keeps failing has anyone else experienced anything like this or can resolve this issue?

Thanks

-Darren

Comments 5 CommentsJump to latest comment

J.H Is gone's picture

you have the SSO license installed on both servers correct?

When I do the command on my unix master
I come back with the Master server as SCAN-TLD and the others as TLD (and I am using SSO on all 4 servers)  Was your first tape drive busy (is that why it showed and active)

and the on demand should NOT be checked.

IBM.ULT3580-TD4.002 No No No hcart

unixmastermedia /dev/rmt0.1 SCAN-TLD

unixmedia /dev/rmt0.1 TLD

WinSanMedia {0,0,2,0} TLD

WinSanMedia {0,0,2,0} TLD

So now the question is why do you have issues...

I have not looked at the compatibility list - I assume that your Linux is supported as a media server?

have you tried rebooting the Linux server or at least bouncing netbackup on it.
that is all I have for you because it looks ok to me.

I don't have to know how to spell....I work on Unix.
NetBackup 7.0.1 - AIX & Windows

Marianne's picture

If FQDN names are used either in DNS or aliased in local hosts files, ensure that FQDN names for master and media servers match in all directions.
I have seen situations where media servers can be backed up as clients, all comms tests complete 100% fine, but backups would fail when used as media server. All NBU config was done using short names, but it seems when FQDN is used anywhere (e.g. alias in hosts file) resource allocation will try to  use the long name.

In one scenario, all config was done using short names, but media server backups kept on failing with 811.

After weeks of troubleshooting, the  FQDN for the Media server was found to be incorrect in the /etc/hosts file on the Master server (extra 'c' in FQDN):
 nnn.nn.n.nn    ipcprod1        ipccprod1.yyyyyy.co.za

On the media server, the entry for itself was correct:
nnn.nn.n.nn    ipcprod1        ipcprod1.yyyyyy.co.za   loghost

Another scenario with status 811 (again, all NBU config was done using short names):
Entry for media server in /etc/hosts on master server:
10.30.3.20      sp-adm01    sp-adm01.xxxxxx.co.za

On the media server itself, it had no knowledge of FQDN for itself. There was no alias for sp-adm01.yyyyyyy.co.za in it's own /etc/hosts file and nslookup could not resolve sp-adm01.xxxxxx.co.za either.
I removed the FQDN alias from /etc/hosts on master server and backups started working.

I hope these examples help you to double-check & troubleshoot your environment.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Darren_Otter's picture

Thankyou Marianne! The issue was that I was using the short names and for some reason the media server was identifying itself as its FQDN of which the master had no idea of this.  I simply added the FQDN to the master server's host file and it all started working!  Much appreciated for all you help.  Thanks again and kind regards Darren.

Nicolai's picture

In additions to Judy and Marianne suggestion.

To make sure the media server always use it own tape drives use must also the the MUST_USE_LOCAL_DRIVES flag in the EMM database.

# nbemmcmd -changesetting  -MUST_USE_LOCAL_DRIVE 1 -machinename {media_server_name}

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.