Video Screencast Help

NetBackup 6.5.x unexpected full backup of multistream policy

Created: 04 Feb 2013 • Updated: 10 Apr 2013 | 6 comments
Glo's picture
This issue has been solved. See solution.

Hello All,

I have NetBackup 6.5.6 on a Solaris 10 Master and Media server and a Windows 2008 client.

The policies for this client allow multistream backups. No other client is included in these policies. All schedules are frequency-based.

Not very long ago, but long enough to forget exactly when it was, I began allowing this client, but no other clients, to have two simultaneous backup jobs, but only one per policy. Now I am getting full backups from at least some of the streams in some of those policies many weeks before I was expecting them. Last night one policy started stepping through all of its streams, so I began looking closely at it while its master job was queued but none of the streams were active.

First I looked at the output of
    nbpemreq -policies screen depth all policy_name
and got dizzy.

Then I cancelled the queued job, renamed that policy's two STREAMS files, and ran
    nbpemreq -updatepolicies
but now that policy has disappeared from the output of commands like
    nbpemreq -predict -date 01/31/2013
    nbpemreq -due -date 01/31/2013

Finally, I deactivated all problematic policies and cancelled their queued jobs. I'll reactivate them when I have a solution.

What should I do now to troubleshoot?

Thanks,

Glo

Comments 6 CommentsJump to latest comment

Glo's picture

Additional information: Immediately after running nbpemreq -updatepolicies, the policy's two STREAMS files were not recreated, although they did appear after maybe ten minutes. After I activate the policy, nbpemreq shows that the scheduler now wants an incremental backup, as it should.

If this has solved my problem, I'll be very happy.

Glo's picture

Darn it, the job is using the full schedule, although nbpemreq predicted an incremental. What now?

Marianne's picture

Any changes to 'Allow multiple data streams', schedules, Backup Selection or Streams file will cause Incrementals to run as Full until a new Full has run.

This has been the case for as long as I've known NBU across all versions.

PS: are you aware of the fact that NBU has reached EOSL in Oct 2012?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Mark_Solutions's picture

The schedule will be what ever is due ... having said that, if you have edited the streams themselves (the specified paths) then NetBackup will consider them to be new and even a incremental will actually back up everything ever time until after the next full backup

There are many things that, when editing a policy, can cause backups to run as full until a Full schedule has run

Best after any changes to schedule or manually run a Full backup before it does anything else

To really know if a different schedule has run we would need to see the policy output (bppllist policyname -U)

But again, if different schedules have the same window and you have edited things then it will be like new and run the Full one first - sounds like you need to sort out your schedules to prevent any overlap

The 10 minute delay you saw if the default time to re-run through the policy updates (set in Master servers host properties - a little like bpsched use to be if you go back that far with NBU)

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Stumpr2's picture

BMR? If you have enabled BMR then check the details page for the job. You may see

WRN - old TIR info file 'E:\tools\veritas\NetBackup\tir_info\C\NetBackup_file_info.BOR-winnt-flatfile' is missing. Backing up everything in 'C:'

WRN - old TIR info file 'E:\tools\veritas\NetBackup\tir_info\E\NetBackup_file_info.BOR-winnt-flatfile' is missing. Backing up everything in 'E:'

etc.....

VERITAS ain't it the truth?

Glo's picture

Thanks, everybody, I see that I've shot myself in the foot again. Yes, I know that I'm EOSL, I remember bpsched, and I have no BMR enabled.