Video Screencast Help

Netbackup 7.1 to 7.5 Upgrade issue when NBAC is enabled

Created: 01 Nov 2012 • Updated: 18 Jan 2013 | 12 comments
This issue has been solved. See solution.


(my first case here)

Master = Server 2008R2

I wonder if someone tried upgrading from to 7.5 and had issues ? In my case the insallation stops and rollback after it tries to to upgrade NBAC.

It also rollback the installation badly and the Master is no longer usable.

The setup log shows this:

11-01-2012,10:02:34 : AT Broker Migration has already taken place. API returned 18: NT Service Control Manager operation failedAuthentication information for requested client or broker migration is already done or not required. AtUtil status: 0.
11-01-2012,10:02:34 : Not proceeding with remaining migration steps.
11-01-2012,10:02:34 : Finished with EmbeddedSecurityOps custom action, deferred phase


Discussion Filed Under:

Comments 12 CommentsJump to latest comment

sazz.'s picture

I had it once and there seems to be an issue to carry the security while upgradeing. Please disable it using below registry and try to upgrade it.


USE_VXSS should be set to PROHIBITED

JC Duguay's picture

Thks sazz. 

I already tried this option and it effectively worked for the upgrade process but the NBAC is no longer working once I'm at even if I revert PROHIBTED to AUTOMATIC and try re-installing it. The AT and AZ services just do not start.

This lead me to try the NBAC removal process documented by SYM for which I discoverd that it was not working either (the removal process works but the AT service does not start after). I tried on 2 different master in our Lab with the same results. Strange enough that no one have had similar issues.

I have no to choice but to keep NBAC for Audit reasons.

Right now this is a no-go to upgrade our production Master until we are able to find out more on this.

I openned a call anyways in the mean time -will post any outcome.

SYMAJ's picture

Is there any progress on this one ?

I have an environment which is all built on W2K3 (1 Master / 3 Media), and was at 7101.  I upgraded the Master Server yesterday and had the issue you describe (Roll-back) during the upgrade.  I changed the Reg Entry to PROHIBITED (was AUTOMATIC) and re-ran the upgrade and all appeared to complete OK - tests all functioned OK and backups all worked OK last night.

I had not set the value back to AUTOMATIC until this morning (I was going to leave it until the Media Servers were upgraded) - but then I did set it as I was seeing an issue with access from a Remote Admin Console.  I noticed that the Authorization Service and the Authentication service were not started - and when I try to start them they just stop again immediately saying they have no work to do (no errors).

As the services aren't started then after I set the reg entry to AUTOMATIC I can no longer log into NBU admin console - so I have it back to PROHIBITED in order to work.

I have not attempted to either re-run the -setupmaster or re-install NBAC (as it is part of 7.x by default now).  I cannot perform a bpnbat -login either as the services are not up.

Any advice ?


JC Duguay's picture


We have a case openned at SYM for this issue relating to NBAC and version 7.5.  I still have no solution but will post any outcome.

You might have to leave the "prohibited" until some resolution is obtained. Also if you find out anything let me know as well. At least your environment is still working. In our case, the rollback left an un-working environment.

SYMAJ's picture

I had a subsequent issue with catalog backup failing status 11 after the upgrade, which is now resolved.  As part of that Support had me follow two technotes to remove NBAC as they thought that was the issue.  It turned out not to be the issue, but now we are following through TECH190214 to cleanup NBAC and then I will re-run the BPNBAZ -setupmaster.

I hope to complete this today - and will post back an update.


watsons's picture

There is a known issue about NBAC not working after an upgrade to 7.5:

Patch to to see if it can resolve.

Not sure if it's what you experienced, if you already have a case, you can try to quote that Etrack # specified in the technote.

CRZ's picture

TECH189336 specifically deals with a 7.5 to upgrade, which is not the case with the OP. | APPLBN | 761LBN

JC Duguay's picture


If you suceed with TECH190214, let me know if you did something particular that would not be in the article. In my environment, I was no successfull.

Concerning my issue, I have been able to build a working environment (7.1 to 7.5) starting from scratch but in my pre-prod, i still have the issue with the AZ service starting and stopping immediatley even with installed.

Getting this error

11/16/2012 8:42:02 AM VxSS-vxazd ERROR V-18-3078 Fatal error encountered. (main.c:851)

in order to run bpnbaz -Setupmaster, the AZ service must start.

So we are still unable to proceed with 7.5.


SYMAJ's picture

We are currently (as we speak) working through trying to finish the technote instructions.  At the point where we are to start the Authorization and Authentication services (after point 10) they won't start.  Troubleshooting item 1 is clean, the output from item 2 just forwarded to Symantec for advice.

I will update you when we resolve this.


SYMAJ's picture

Still working through trying to get the services to start with Symantec (more our delay than theirs).  They are not sure why the services won't start and requested an NBSU output.  Once we get this to them they will continue to troubleshoot.


JC Duguay's picture

Finally fixed !

Somewhere in the update process, the hostname was not properly updated into all files.

 The rule is the following:

The hostname in server.conf, vxdbms.conf and EngineName should ALL BE THE SAME.

The EngineName is a registry key under: HKLM\SOFTWARE\ODBC\ODBC.INI\NBAZDB

The format of the name in the server.conf file is: NB_<hostname>