Video Screencast Help

NetBackup 7.1.x vxlogcfg error

Created: 19 Jul 2012 • Updated: 30 Jul 2012 | 7 comments
Frédéric RIGAL's picture
This issue has been solved. See solution.

Hi all,

We have a Master in 7.1.0.3 with a Media Server (same version) which backup a filer in Remote NDMP.

Backups are doing well but generate logs growing very much (260 Go on a full backup from 14 To) each week.

 

I've tried to run following commands on Master server :

vxlogcfg -a -p 51216 -o 134 -s DebugLevel=0

vxlogcfg -a -p 51216 -o 134 -s DiagnosticLevel=0

vxlogcfg -a -p 51216 -o 134 -s LogRecycle=true

All is OK and I can see the result in the nblog.conf file.

But when I want to do the same thing on the Media Server, I've got the following message :

 v 1-8-0-5 An unknown argument -a was passed

Even if I try with -g instead of -a

I've found the following technote : http://www.symantec.com/docs/TECH157017

but it doesn't resolve anything.

Does someone have an idea?

 

Thank you

 

Comments 7 CommentsJump to latest comment

Mark_Solutions's picture

Interesting that - perhaps NDMP logging relates only to the Master Server - dont see why though off hand

The error not accepting the -a is strange unless it is not permitted on the media server (justtryied one and it did not allow logging to be setup - but different error to yours)

My other thoughts is that it needs a patch to log to (-c) or the correct license installed on the Media Server itself

Otherthan that have you tried using ndmpagent rathe than 134?

Don't know if any of this helps - just ideas that may point somewhere

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

mph999's picture

Odd.  NDMP logging is ok on media, might need a license, not sure.

But it's complaining about te command, not the log

 

 v 1-8-0-5 An unknown argument -a was passed

Can you try the same command but on a different log

vxlogcfg -a -p 51216 -o 222 -s DebugLevel 0

Regards,

martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
watsons's picture

If you do the same command for other Netbackup process, such as -o 200 (nbrmms) or others, does it work?

When running vxlog* type of command, it always check and update this file: nblog.conf

Make sure the following is in nblog.conf:

# 134. NDMP Agent
134.L10nResource=ndmpagent
134.NtEventLogSourceName=ndmpagent
134.OIDNames=ndmpagent
134.LogDirectory=ndmpagent
 

Frédéric RIGAL's picture

Hi all,

 

Here is the Media Server's nblog.conf file contents :

# 134. NDMP Agent
134.L10nResource=ndmpagent
134.NtEventLogSourceName=ndmpagent
134.OIDNames=ndmpagent
134.LogDirectory=ndmpagent
 

I will try with another process to check if I get the same issue.

 

Regards.

ASC Symantec Partner

Marianne's picture

Please compare media server's nblog.conf with the master's file.

I have seen this file getting corrupt and causing all sorts of 'weird and wonderful' issues.

If Master and media is the same OS, just copy master's good copy to the media server.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

SOLUTION
Frédéric RIGAL's picture

Thank you Marianne,

 

I will try this and let you informed.

 

N.B. Licenses are ok on Master and Media

 

Regards

ASC Symantec Partner

Frédéric RIGAL's picture

Thank you Marianne

 

the solution you gave was perfect.

 

However, I would like to know why vxlogcfg command doesnt' work on the media server....

ASC Symantec Partner