Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

NetBackup 7.5 and ACSLS 8.2 on Solaris 10 8/11

Created: 16 Oct 2012 • Updated: 18 Oct 2012 | 11 comments
jpmichelino's picture
This issue has been solved. See solution.

 

I have a server with Solaris 10 8/11 connected to a Fibre Channel SAN. In that SAN I have a tape library StorageTek SL48.
I installed Netbackup but i can't configure the tape from de NetBaqckup.
Anybody knows how I can configure Netbackup to manage the library?
Thanks!
 

Comments 11 CommentsJump to latest comment

mph999's picture

You need to read the device config guide.

http://www.symantec.com/docs/DOC5186

And the system admin guides might be useful also.

http://www.symantec.com/docs/DOC5157

http://www.symantec.com/docs/DOC5158

This is also useful 

 http://www.symantec.com/docs/TECH31526

Esp part 6.1.3 - the rpc info commands MUST respond with "ready and waiting"

If you have multiple interfaces on the media servers this post from Marianne might be useful

https://www-secure.symantec.com/connect/forums/dri...

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Yasuhisa Ishikawa's picture

SL48 is not supported by ACSLS. Just configure your SAN so that the server can access SL48, and follow instructions in Device Configuration Guide.

in brief, run sg.build and sg.install like below, and after that, run device configuration wizard(Configure Storage Devices) in GUI.

# cd /usr/openv/volmgr/bin/driver

# ../sg.build all -mt 6 -ml 1

# rm /kernel/drv/sg.conf

# ./sg.install

# /usr/openv/volmgr/bin/scan

If your robot and drives all are visible in scan command, you can configure devices by wizard.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

jpmichelino's picture

 

Thank Yasuhisa Ishikawa and mph999.
 
I yast could resolv the problem.
 
The last question: What is the meaning of "6" and "1" in the sg.build command? I didn't understand it when I read the Device Configuration Guide.
Marianne's picture

-mt is for max targets
-ml is for max luns

If you post output of 'ls -l /dev/rmt/*cbn' we will help you find correct values for your installation.
7 targets (0 - 6) is enough considering that you probably have no more than 2 tape drives.
2 luns (0 - 1) will cater for robotic device that may have the same target number as one of the tape drives but different lun number.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

mph999's picture

Opps, given the opening question I kinda assumed this was meant to work via ACS ...

We all know what assumtion is ...  - note to self, stop doing that ...

OK, sg build - if you are using san connected drives, the targets / luns are probably not required, as the drives will be configured via WWN no target /lun.

So Mariannes excellent is 100% correct, but if the below is true, we do not need to concern outselves with creating sg 'device' files that will not have devices - it will slow things down.

cfgadm -al  or cfgadm -al -o show_FCP_dev should show if the tapes are using wwn or target lun.  If san connected it should be wwn, so it's easy to just configure things that way, if it doesn't work, then try the other - with the copy/paste commands (below) it's no big deal if you have to re-run.

I might as well give the full details as I've started.  Apart from cfgadm, ls -al on /dev/rmt/ gives the required details (I see Marianne has explained this also).

This is my server, it uses target/lun as the drive is scsi connected.  ls -al on a device file shows

0cbn -> ../../devices/pci@1e,600000/pci@0/pci@9/pci@0,2/pci@1/scsi@2/st@5,0:cbn

The bit at the end ...

@5,0:cbn  shows target 5, lun 0

So to get the max number of target/ lun, ls -al /dev/rmt/ and look for the highest target number and the highest lun number.  These would be the values you put into the sg.build command.

This is my colleagues server, the drives are san connected ...

 3cbn -> ../../devices/pci@1e,600000/SUNW,qlc@3/fp@0,0/st@w2103000d77640cc8,1:cbn

Straight away, we see there is no target/l lun as a WWN is shown.

Simple - if all the drives are WWN (which they are) we only need to use sg.build all (no mt -ml options required)

I would try this way first.  Run the commands exactly as shown, in the order shown.

(If the mv commands fail, don't worry)

 

mv /usr/openv/volmgr/bin/driver/sg.conf  /usr/openv/volmgr/bin/driver/sg.conf.safe
mv /usr/openv/volmgr/bin/driver/sg.links /usr/openv/volmgr/bin/driver/sg.links.safe
modunload -i $(echo $(modinfo |grep "sg (SCSA" |awk '{print $1}'))
cd /usr/openv/volmgr/bin/driver
../sg.build all
mv /kernel/drv/sg.conf /kernel/drv/sg.conf.old
/usr/openv/volmgr/bin/driver/sg.install
 
After this /usr/openv/volmgr/bin/scan should show the devices

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
jpmichelino's picture

 

Thank Mariane and mph999.
 
I followed the  mph999's instructions and I can see the library (with Yasuhisa's instruction also could see the library)
 
Now I have two new questions:
 
1) /usr/openv/volmgr/bin/scan doesn't show me the WWN. (I don't remember if  instructions' Yasuhisa I could see it). That is OK?
 
2) From the console, when I do a "Robot Diagnostic", "Robot Error Checking" fail. Why it's happening? I can solve it?
 
Thank.
Marianne's picture

'scan' command does not report WWN. 
The device Inquiry string is returned by the scan command. WWN is not part of Inquiry string.

If library is fiber-connected, cfgadm commands will show WWN.

Did you manage to configure devices successfully in NBU?

I have never tried to use "Robot Diagnostic" in the GUI.
I prefer using 'robtest' from cmd to test robot functionality after devices have been added to NBU.
See http://www.symantec.com/docs/TECH83129 for robtest usage.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

jpmichelino's picture

 

Yes, NBU auto-detect it.
 
For the time being, our customer haven't cartridge in the library, but I can see the device from NBU.
 
Thank.
Marianne's picture

Now that NBU successfully detected and added the devices, can we agree that your query has been answered?

If so, please select the post that has helped you most and Mark as Solution.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Yasuhisa Ishikawa's picture

scan command does not show WWN although it has WWN column.
I tried Robot Diagnotic though GUI with working robot once(8 years ago or so), but it failed. I'm not sure why it showed as failed, but after that I never used this menu. testing by robtest is more simple and more efficient than diagnotics.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan