Video Screencast Help

Netbackup 7.5 client install on new SuSE Linux 11 SP2

Created: 11 Jul 2013 • Updated: 12 Jul 2013 | 4 comments
This issue has been solved. See solution.

We use a Windows based Netbackup Master and most of the machines we bck up are Windows based. However, we do have a few Linux based machines that we need to back up.  These are all SuSE 11 SP2 machines, and are running on Intel based x86 hardware using the 64bit version of SuSE.

I don't have enough machines to merit any sort of remote install solution as we do have local access to them all.

I have attempted two things:

 

1) I downloaded the three part set of the Server/Client of Unix/Linux installation disks. Combined them using copy /b  method, uncompressed them to a folder and copied them to the linux server.  Run the ./install command from the second level directory creted, and .... nothing ....

2) So, I downloaded just the LinuxS client disk for Suse and followed the same routing after deleting the data from attempt 1 completely. I ran /.install on it and it came up and asked me if I wantted to install, I gave it a Y, and then I get the following:

 

-----------------------
NOTE:
CPI  V-9-0-0 
 
0 No padv object defined for padv SLES12x8664 for system dmc-splunkidx1
 
 
The NetBackup and Media Manager software is built for use on LINUX_SUSE_X86 hardware.
Do you want to install NetBackup and Media Manager files? [y,n] (y) 
 
-----------------------
 
If I choose "N" (simply because I am not sure what it is asking, I get the following note:
 
File /tmp/install_trace.14511 contains a trace of this install.
That file can be deleted after you are sure the install was successful
 
---------------
 
So now what????
 
 
 
If I answer "Y" to the second question, it states:
 
NetBackup and Media Manager are normally installed in /usr/openv.
 
There are 3724244 kbytes of space left in /usr/openv.
You will need about 4758862 kbytes of space to install NetBackup and Media Manager.
You must install in /BASEDIR/openv.
 
Specify BASEDIR in /BASEDIR/openv or q to quit:
 
This machine has oodles of space on it so I not sure about the warning here.
 
 
And..... as you guessed it, I am a totlal Linux Novice, but trying to learn.
 
Can someone help me get ths client installed?
 
I appreciate your help!
 
 
 
 
Operating Systems:

Comments 4 CommentsJump to latest comment

tocals's picture

Hello,

 

You need download from fileconnect this files:

NetBackup_7.5_CLIENTS_tar-gz.1of3

NetBackup_7.5_CLIENTS_tar-gz.2of3

NetBackup_7.5_CLIENTS_tar-gz.3of3

Copy the files do LInux box using winscp or other application with bin file mode active

join the files

cat "NetBackup_7.5_CLIENTS_tar-gz.1of3" "NetBackup_7.5_CLIENTS_tar-gz.2of3"  "NetBackup_7.5_CLIENTS_tar-gz.3of3" > "NetBackup_7.5_CLIENTS.tar.gz"

run the ./install script and follow the instructions

if you don't have space left on /usr, tou can crerate a new volume, mount this new volume and create a symbolic link before initiate the instalation.

Ex.:

if the new volume is mounted at /vrtsnbu

# cd /usr

# ln -x /vrtsnbu openv

Regards

SOLUTION
RLeon's picture

uncompressed them to a folder and copied them to the linux server.

That's the problem right there. Linux files have file permissions that are not recognized in Windows. Such "attributes" will simply be dropped by Windows when encountered in a file.

By extracting the tar.gz file contents in Windows, the script files would have their "execute" permission removed by Windows, which explains...

Run the ./install command from the second level directory creted, and .... nothing ....

... Because the install file is no longer an executable file.

 

 

The correct way to do this is to extract the tar.gz inside Linux. That way, all file and directory permissions will be preserved, and the installation should run.

inn_kam's picture

 

Symantec NetBackup 7.5 Installation Guide for UNIX and Linux
Article:DOC5154  |  Created: 2012-01-11  |  Updated: 2012-02-08  | 

Article URL http://www.symantec.com/docs/DOC5154

 

 

follow the guide simply

bkcarter's picture

tocals > Thanks for the response it helped me find the solution. I gave you the solution, but you have to share it with RLeon.

RLeon > You and tocals gave me the solution together. I wish I could mark you both as the solution, but I gave you +1 for your addition.

inn_kam > Really??? I never thought of following the guide!!! Your answer was really helpful... NOT!

I found that I had problems that the guide actually DIDN'T explain.

1) I didn't have enough space left on my root partition to run the installer. I changed that using YAST partioner. I would not expect the guide to tell me that, but chalk it up to my inexperience with Linux.

2) In the guide it states that you can concatenate the files in two ways. First, it tells you to use the Copy /b command in Windows, and second to use the CAT command under Linux.   NOWHERE does it state anything about the attribute problem that RLeon mentioned!  So, I knew the windows way better and figured it would do the same thing. Then I could copy the resultant file to Linux and use it.  Nope!

3) So, I downloaded the files directly to Linux, ran the CAT command, and ran the install. Worked just like the guide said it would.

 

Thanks guys for the help!