Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup 7.5 + Enterprise vault 9.04 agent backup

Created: 11 Apr 2013 • Updated: 16 May 2013 | 16 comments
This issue has been solved. See solution.

Hi,

1 server NEtbackup 7.5

1 server Enterprise vault 9.04 + 1 SQL server for enterprise vault (2005)

Before : netbackup 6.5 + enterpriee vault 9.04. Agent enterprise vault backup OK. Client 6.5

Now : netbackup 7.5 + enterprise vault 9.04 Agent enterprise vault backup No OK. Client update to 7.5

We dont migrate the netbackup, we had installed a new release on a new server. (old one crash).

We set the policy of enterprise vault. Set up the correct credential. Choose the backup selection we could.

Has I launch my backup,

4 tasks appears in the console of netbackup

1 for the application server name EV with a type "backup" Job running, but nothing move (See below the log) with a little green runner as an icon.

2 for the sql server name SQL-EV with a type "Snapshot", job running, but nothing move.

3 for the sql server, with a type "backup", job are in queued with that " Limit has been reached for request resource"

4 for the sql server, with a type "backup", job are in queued with the same "limit has been...".

And nothing more, no error, no message. I leave it 3 hours like that with nothing more than the job running.

Here the step log of the 1 and 2 job running :

"11/04/2013 11:27:20 - begin Parent Job
11/04/2013 11:27:20 - begin Enterprise Vault Resolver, Start Notify Script
11/04/2013 11:27:20 - Info RUNCMD(pid=1028) started           
11/04/2013 11:27:20 - Info RUNCMD(pid=1028) exiting with status: 0        
Status 0
11/04/2013 11:27:20 - end Enterprise Vault Resolver, Start Notify Script; elapsed time: 00:00:00
11/04/2013 11:27:20 - begin Enterprise Vault Resolver, Step By Condition
Status 0
11/04/2013 11:27:20 - end Enterprise Vault Resolver, Step By Condition; elapsed time: 00:00:00
11/04/2013 11:27:20 - begin Enterprise Vault Resolver, Read File List
Status 0
11/04/2013 11:27:20 - end Enterprise Vault Resolver, Read File List; elapsed time: 00:00:00
11/04/2013 11:27:20 - begin Enterprise Vault Resolver, Resolver Discovery
11/04/2013 11:27:20 - started process bpbrm (5512)
11/04/2013 11:27:25 - Info bpbrm(pid=5512) ev is the host to restore to     
11/04/2013 11:27:25 - Info bpbrm(pid=5512) reading file list from client       
11/04/2013 11:27:28 - Info bpbrm(pid=5512) client_pid=2164           
11/04/2013 11:27:28 - Info bpbrm(pid=5512) from client ev: TRV - BPRESOLVER has executed on server (EV) 
Status 1
11/04/2013 11:27:28 - end Enterprise Vault Resolver, Resolver Discovery; elapsed time: 00:00:08
11/04/2013 11:27:28 - begin Enterprise Vault Resolver, Persist Discovery
Status 0
11/04/2013 11:27:28 - end Enterprise Vault Resolver, Persist Discovery; elapsed time: 00:00:00
11/04/2013 11:27:28 - begin Enterprise Vault Resolver, Policy Execution Manager Preprocessed"

 

and the second

11/04/2013 11:27:29 - end Enterprise Vault Snapshot, Read File List; elapsed time: 00:00:00
11/04/2013 11:27:29 - begin Enterprise Vault Snapshot, Create Snapshot
11/04/2013 11:27:29 - started process bpbrm (6176)
11/04/2013 11:27:29 - started
11/04/2013 11:27:33 - Info bpbrm(pid=6176) sql-ev is the host to backup data from    
11/04/2013 11:27:33 - Info bpbrm(pid=6176) reading file list from client       
11/04/2013 11:27:33 - Info bpbrm(pid=6176) start bpfis on client        
11/04/2013 11:27:33 - Info bpbrm(pid=6176) Starting create snapshot processing        
11/04/2013 11:27:36 - Info bpfis(pid=4660) Backup started          
11/04/2013 11:27:43 - Info bpfis(pid=4660) done. status: 0         
11/04/2013 11:27:43 - end Enterprise Vault Snapshot, Create Snapshot; elapsed time: 00:00:14
11/04/2013 11:27:44 - end writing
Status 0
11/04/2013 11:27:44 - end Parent Job; elapsed time: 00:00:15
11/04/2013 11:27:44 - begin Enterprise Vault Snapshot, Policy Execution Manager Preprocessed

What i'm missing? and why he dont crash and send me an error ?

thanks for your help.

Operating Systems:

Comments 16 CommentsJump to latest comment

CraigV's picture

...moved to the correct forum!

Thanks!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

Dyneshia's picture

1) Confrim you have configured EV according to : http://www.symantec.com/docs/TECH150237

In short :

Recommend configuring 4 separate policies within NetBackup with the following backup selections. The

client for each policy should be any EV server in the environment.

Policy 1: EV_DIR_DB, EV_MONITORING_DB, EV_AUDIT_DB (optional), EV_FSAREPORTING_DB (optional)

 

Policy 2: EV_OPEN_PARTITION=<vault store name>, EV_FINGERPRINT_DB=<vault store group name>

NOTE: These directives can be used multiple times within the policy, each referencing a different vault

store name or vault store group name. Also, the Vault Store Database associated with the Vault Store is

always backed up along with the open partitions.

 

Policy 3: EV_CLOSED_PARTITIONS=<vault store name>, EV_READY_PARTITIONS=<vault store name>

NOTE: the customer may or may not have any closed or ready partitions configured within EV, so this

policy and these directives are only needed depending upon the Enterprise Vault configuration. These

directives can also be used multiple times within the policy, each specifying a different vault store name.

 

Policy 4: EV_INDEX_LOCATION=<EV site name>

Add the Enterprise Vault Administrator credentials to the EV server(s) and SQL server(s) host properties

in the NBU Admin Console:

NBU Admin Console > NetBackup Management > Host Properties > Client > right-click the EV Server and

select Properties. Expand Windows Client > Enterprise Vault.

Enter the user name in the following format: domain\username

When finished, do the same thing for the SQL server(s). It may be necessary to click Actions > Configure

client if any of the SQL servers (or cluster nodes) do not show up in the Client Host Properties list.

Finally, it is recommended to change the NetBackup Client Service on the EV and SQL servers to run

under the Enterprise Vault Admin account credentials.

 

Policy 5: When using EMC, EMC backups the open partion and therefore you only need to backup the database.

 

EV_VAULTSTORE_DB=<VAULT_STORE_NAME>

EV_FINGERPRINT_DB=<VAULT_STORE_GROUP_NAME>

 

When looking at xml file, start with Vault Store Group first.

 

2) Confrim vss wirters are stable on the frontend and SQL server

From command line : vssadmin list writers

3) check the application event viewer on the EV and SQL Server for any VSS or ESE errors.

4) Confrim Master, EV and SQL Server are all on the same version of NBU (7.5 )

5) If you are on the base install of 7.5, you should patch to 7.5.0.5 ( master , media, EV and SQL Server )

http://www.symantec.com/docs/TECH199269

 

DelphineFR's picture

Hi, thanks for your replie.

According to your post, I made 4 policy. I follow the order of the doc tech.

1 policy for open partition and fingerprint

1 policy for dir db, monitoring, audit and fsareporting.

1 for index location

1 for clode and ready partition.

Double check the credential to connect (like I say below since years now, we backuped fine. But since we change net backup 6.5 to 7.5, it dont work. But as the old server crash, I really dont know how the policy was set up.)

Just now, I made a manual backup on the policy number one.

2 job are ine the activity monitor :

one "backup" for EV server.

File list :

EV_OPEN_PARTITION=MailboxesArchives
EV_FINGERPRINT_DB=MailboxesArchives

Nothing happeneds.

second in queued.

File list (witch confirm that he read the server)

Enterprise Vault Resources:\EV Site (mycompanie (sql-ev.))\EV Vault Store Group (VaultGroup1)\EV Vault Store (MailboxesArchives)\All Partitions\Open Partition\MailboxesArchives Ptn1 (//EV/F$/MBA-Partition1)\
Enterprise Vault Resources:\EV Site (mycompagnie (sql-ev))\EV Vault Store Group (VaultGroup1)\EV Vault Store (MailboxesArchives)\Vault Store DB (sql-ev/EVMailboxesArchives)\

Any idea? I double check the eventviewer, but before the new net backup, all work's fine, no error message about vss or else. I'm pretty sure if I backup a single file ms-windows, it will work fine.

 

 

Dyneshia's picture

Please upload

1) bprbm from the media server 

2) bpresolver, bpbkar and bpfis from the EV server

3) bpbkar and bpfis from the SQL server

Dyneshia's picture

The items above are logs.

They are located in the veritas\netbackup\logs directory

EX:

veritas\netbackup\logs\bpbrm

veritas\netbackup\logs\bpresolver

veritas\netbackup\logs\bpbkar

veritas\netbackup\logs\bpfis

DelphineFR's picture

On ev Server, veritas\netbackup\logs, no log "bpresolver, bpbkar and bpfis"

We update the client, maybe it clear, and as there was no backup now, no log file ?

On Sql server, same issu, no log file as you describe.

On media server a lot of subfolder, but no bprbm ?

Just in case of, we do a lot of backup every night (exchange2010 for exemple, it's working fine)

 

Dyneshia's picture

Please create the folders mentioned above, kick off a backup, let is fail and upload the logs.

DelphineFR's picture

Ok,

now I have one log on the EV server, in BPresolver. There is a lot of information, some error also, but the file have many information, so what I'm suppose to search?

Key word "error" :

15:04:43.406 [8412.7512] <2> DebugLog(): INF - BEC_SetSpsContOnDBCCError(0)

15:04:43.640 [8412.7512] <2> DebugLog(): INF - Input Error (       0) for Type: (43)

15:04:43.671 [8412.7512] <2> DebugLog(): INF - PDDEWriterFind::IsPresent() - LastError=2

15:04:43.671 [8412.7512] <2> DebugLog(): INF - {ERROR} DFSR::WMI::Initialize() return=[0x8004100e UNKNOWN ERROR]

15:04:43.718 [8412.7512] <2> DebugLog(): INF - CAcceleratorInterface::SetAcceleratorDetails - Error in opening Complaince Accelerator version registry key. May not be present

15:04:43.718 [8412.7512] <2> DebugLog(): INF - WARNING: Failed to acquire critical resource interface (0x00000000).  Critical device bits will not be set. in 'CritSysProt::CritSysProt:37'

 

15:04:43.499 [8412.7512] <2> DebugLog(): INF - VirtApi DLL WAS NOT LOADED, from VirtApi.dll!!
15:04:43.499 [8412.7512] <2> DebugLog(): INF - LoadLibraryEx FAILED!  RC = 126 (0x7e) - The specified module could not be found.!!!

 

etc etc ?

No log on SQL server, no log on media server. But I launch only the first policy for open partition and fingerprint.

Thanks for you help.

 

 

 

DelphineFR's picture

I made a lot of test since my last post.

Nothing more, nothing less. The job running with 0 write. 0 error on the console.

Is it possible to do a step by step toguehter, or shall I open a ticket support (I have acces to both of support, EV or Netbackup.)

I think it's more a netbackup issu, as my EV wont change since years ago now.

But does the netbackup support are aware with the enterprise vault agent ?

Thanks.

Dyneshia's picture

Yes open a ticket with Netbackup as they have a database group which troublshoots using the EV agent.

Be sure to include :

1) System information

MAster Server Name:   
OS :
NBU Version:

Media Server Name:
OS:
NBU Version :

EV Server Name:
OS:
NBU Version:
EV version:

SQL Sever Name :
OS :
SQL version :
NBU version :

2) Can you elaborate more on the issue.  Has this ever worked before ?  If so what has changed ?

3) Create the following  folders  in the veritas\netbackup\logs directory :
    
                Master server
                --------------
                bpdbm

                Media server
                -------------
                bpbrm
                bptm
                bpdm
                nbjm

               EV server
               -----------------
               bpbkar
               bpfis
               bpcd
               bpresolver
               vnetd

               SQL Server
               ------------
               bpfis
               bpbkar
               bpcd
               vnetd

4) Increase the verbosity

Master server- Host properties -> master server -> double click on the master server -> logging -> set to 5

Media server- Host properties -> media server -> double click on the media server -> logging -> set to 5

Client- Go to the client directly.  Open up the Backup Archive Restore GUI -> file - > client properties -> troubleshooting ->set general to 2 ,  verbosity to 5, and database to 9 .  You will need to restart the client service.

5) Kick off the backup and once completed with error, turn verbosity back to 0.

6)  Upload log and the following :
-  Detail status from the failed job ( be sure to note the date, time and job ID and PID )
- %ev install path%\Reports\EVBackup.xml

7) Policy info :  netbackup\bin\admincmd\bppllist <policy name> -L
 

DelphineFR's picture

OK thanks, As I have the issu of my probleme, I will come here with the answer.

DelphineFR's picture

Some fresh news,

I open a ticket for now not all is resolved, but if it's could help.

3 policy, one with the Database, one with the index, one with open partition.

Now database, and openpartition working well.

What we did? Client on ev and sql-ev was 7.5. The support ask me to put the latest 7.5.5 client.

And also, the master was set to one job per client, we set up to 4 per client.

Nothing more, and working. But still the index job in error. As I have the last step, I will close the tread.

The index job backup failed very quickly with the error "socket write failed (24)"

 

 

DelphineFR's picture

Ok issu is done.

let's resume. EV version 9.xx + netbackup 7.5

3 policy :

1- EV_DIR_DB + EV_MONITORING_DB

2-EV-INDEX_LOCATION= "name of my index"

3- EV_OPEN_Partition="name of my part" + EV_FINGERPrint_DB="name of the fingerdb"

(all the information require are set in "evbackup.xml")

We upgrade the client netbackup 7.5 to 7.5.5

We put by  policy 4 job in the same time.

And we for the last error, it was a network problem that we resolve quickly.

So the more difficult in fact was for me to retrive the correct information after all "=" in the netbackup policy. Now I know that all is set in the xml file.

Have a nice day.

Delphine.

 

SOLUTION
DelphineFR's picture

Maybe I speack and close the case to fast.

 

this morning, I have this message "There are 7244 savesets that have not yet been backed up or replicated for Vault Store 'MailboxesArchives'"

 

yersterday Before live my office, I copy and past in my vault store 7200 email from my exchange account, to check what's happends this morning.

 

What is wrong now? My backup are fine, all backup fine... Maybe I have to be more patient ?

 

thanks,

 

 

DelphineFR's picture

With the schedule of all backup and the task of EV, this error disapears.

Case resolve.