Video Screencast Help

Netbackup 7.5 policy issue

Created: 28 Dec 2013 • Updated: 29 Dec 2013 | 6 comments
This issue has been solved. See solution.

Hello ,

We have oracle RAC 11g installed on oracle linux 5.9 and netbackup 7.5.0.6 installed on Oracle linux 5.9.

we have 2 databases and it's configuration is below :

1- "oradb1" database :

    - Policy :Main-ODA-DB

    - Storage unit : main_oda_db_STU

    - Retention period :2 months

2- "catalog" database :

     - Policy :Main-rman-catalog

     - storage unit : main_rman_catalog

     - Retention period : 2 months

we link rman to netbackup and creating rman script so each database is backed up using Netbackup corresponding policy .

- backing up "oradb1" database manually  using MAIN-ODA-DB policy is performed properly without any problems and send it to main_oda_db_STU

- backing up "catalog" database manually using Main-rman-catalog policy is performed properly and send it to main_rman_catalog but when MAIN-ODA-DB policy is deactivated .

The problem here , when i manully backing up catalog database using Main-rman-catalog policy and policy MAIN-ODA-DB is activated , the backup is taken but under job policy MAIN-ODA-DB not  Main-rman-catalog and is sent to main_oda_db_STU not main_rman_catalog !!!!!

i attach rman scripts and screenshots from policy configuration .

Thanks ,

Deyaa

Operating Systems:

Comments 6 CommentsJump to latest comment

RamNagalla's picture

1) did you copy the Policy Main-rman-catalog from MAIN-ODA-DB?

2) Script hot_rman_catalog.sh does not have any NB_ORA_POLICY variable set.. but the script script hot_database_backup.sh has that variable set.

so for the script hot_rman_catalog.sh , set the variable for NB_ORA_POLICY as Main-rman-catalog and try the backup agian.

Deyaa's picture

Hi Nagalla,

i added NB_ORA_POLICY  to hot_rman_catalog.sh but the same result appears .

regarding to copying the Main-rman-catalog from MAIN-ODA-DB , i delete the Main-rman-catalog  and create new one and also the same result appears.

Thanks,

Deyaa

RamNagalla's picture

Okay..

lets try this too..

update the script hot_rman_catalog.sh as below at line 224 and see how it goes..

backup all archive logs
ALLOCATE CHANNEL ch00 TYPE 'SBT_TAPE';
ALLOCATE CHANNEL ch01 TYPE 'SBT_TAPE';
send ’NB_ORA_POLICY=Main-rman-catalog’;
BACKUP
   filesperset 20
 
 
if this does not help, we need to see the bprd logs and dbclient logs with VERBOSE 5
Deyaa's picture

Hi Nagalla ,

i accessed to database catalog and i ran the following commands in Rman prompt :

run {
ALLOCATE CHANNEL ch00 TYPE 'SBT_TAPE';
ALLOCATE CHANNEL ch01 TYPE 'SBT_TAPE';
SEND 'NB_ORA_SERV= backupserver,NB_ORA_POLICY=Main-rman-catalog,NB_ORA_SCHED= Default-Application-Backup';
BACKUP INCREMENTAL LEVEL=0    
FORMAT 'orabk_%d_%T_%s_%p_%t'
DATABASE    
INCLUDE CURRENT CONTROLFILE;
sql "alter system archive log current";
BACKUP
FORMAT 'orabk_arc_%d_%T_%s_%p_%t'
ARCHIVELOG ALL;
CROSSCHECK BACKUP;
DELETE NOPROMPT EXPIRED BACKUP;
CROSSCHECK ARCHIVELOG ALL;
DELETE NOPROMPT EXPIRED ARCHIVELOG ALL;
DELETE NOPROMPT ARCHIVELOG ALL BACKED UP 1 TIMES TO DEVICE TYPE sbt COMPLETED BEFORE 'sysdate-7';
RELEASE CHANNEL ch00;
RELEASE CHANNEL ch01;
}

and it succeeded , so the problem here in the script . i try to put the above command in script but it fail , could you please guide me to make script for the above commands .

appreciate your help

thanks ,

deyaa

RamNagalla's picture

ALLOCATE CHANNEL ch00 TYPE 'SBT_TAPE';

ALLOCATE CHANNEL ch01 TYPE 'SBT_TAPE';

SEND 'NB_ORA_SERV= backupserver,NB_ORA_POLICY=Main-rman-catalog,NB_ORA_SCHED= Default-Application-Backup';

it loosk fine to me..and need to be at line 224 at your script... 

what is the error your are reciving when you update the script with this...

SOLUTION
Deyaa's picture

Hi Nagalla ,

Thanks so much for your help , i put the following line at it work fine.

SEND 'NB_ORA_SERV= backupserver,NB_ORA_POLICY=Main-rman-catalog,NB_ORA_SCHED= Default-Application-Backup';

Really appreciated your help.

Thanks,

Deyaa