Video Screencast Help

NetBackup 7.5 seeing barcode properly, not Media ID

Created: 01 Nov 2013 • Updated: 01 Nov 2013 | 6 comments
This issue has been solved. See solution.

Morning all,

Got a problem with Barcode and Media ID's.

We've had some new barcodes created to avoid duplicates as we have a master and media server setup but both sites had the same barcodes! Doh!

Anyway, When I put the new tapes in and ask the robot to do an inventory it always see's digits 3 to 8 in the Media ID

so for example the full barcode would be UK0005L4, and it see's the full barcode but the Media ID the will always be 0005L4.  I don;t want the L4 bit at the end, but in Media ID Generation rules, i've tried 1:2:3:4:5:6 and 3:4:5:6:7:8 and the results come out exactly the same, as below:

Logically add new media 0005L4 (barcode UK0005L4) to robot slot 6.

What am i doing wrong here?

Mike

Operating Systems:

Comments 6 CommentsJump to latest comment

Marianne's picture

You will need to delete the unwanted media-id's first.

Media ID Generation rule 1:2:3:4:5:6 will only apply to new media.

If you are using a Windows Admin Console, add the Media ID Generation rule in vm.conf of Admin Console as well.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

MikeBuck's picture

Hi Marianne,

 

the vm.conf has

MM_SERVER_NAME = <Servername>
MEDIA_ID_BARCODE_CHARS = 1 8 1:2:3:4:5:6

So that should be OK,

When you say I'll have to delete the old media ID's first are you saying that all Media ID's have to be deleted including my backups for this week? I have but the new barcodes on previously unused tapes.

Mike

Mark_Solutions's picture

Any of the new media that show the wrong media id need to be deleted so that they can be re-added correctly

If some have already been used you will have to wait on those

If you are using a Windows Admin console to do the inventory then they can be server and user specific so you need to ensure that the media id generation rule is used for each user accoring to the console used (doesnt seem to always get stored in EMM)

Also note that media id rules are per robot number so make sure that only one exists for the robot in question and that the correct robot number has been specified - do this from the Inventory robot - advanced options - Media ID Generation tab

In your vm.conf it applies only to robot number 1 - your first robot is usually robot 0 so that could be your issue?

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

SOLUTION
Marianne's picture

MEDIA_ID_BARCODE_CHARS = 1 8 1:2:3:4:5:6

 

Do you have more than one robot? TLD(0) and TLD(1)?

Above rule is for robot 1 -  TLD(1).

Check that vm.conf entry is on the robot control host as well as Admin Console.
Restart Media Manager service if vm.conf on robot control host is updated.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

MikeBuck's picture

I never even saw that!  Thanks to Mark and Marrianne, I deleted the old Media ID rule created a new one ensuring it was using robot 0 and it worked! thanks guys!

I'm a newbie, I'm used to Networker, please don't judge me!

Mike

mph999's picture

I think you are doing very well judging on how you explained the issue.

You explained the issue perfectly
You gave examples
You have done some 'research' and offered your understanding of the issue

... that's a damm sight more than a lot of people can manage who have been using NBU for years

As you now know, the first number in the media id rule is the robot number, the second number is how many characters are in the barcode in total, and the last part as you know is the number position of what will make up the rule.

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805