Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NetBackup 7.5 - Unable to backup SharePoint 2010 (DR or GRT)

Created: 25 Oct 2012 • Updated: 26 Oct 2012 | 2 comments
This issue has been solved. See solution.

Hi,

We can backup our SharePoint 2007 environment (GRT and DR); but when I try backing up our SharePoint 2010 farm I cannot.

In the 2010 farm, I have NFS setup on the SQL backend server and configured the Master server "distributed applicaton restore mapping" so that "application host" is the SharePoint Apps server and its componet is the "SQL backend server".

it's weird, it should work but I just get a error code of "2".

Any ideas?

Thanks,

Comments 2 CommentsJump to latest comment

Dyneshia's picture

A status 2 is a very generic message.  We would need a compelte set of logs to further diagnose the issue.  With that being said please review the following configuration check list as sharepoint 2010 has a lot of requirment and about 80% of the time it is the configuration that cuases the issue.  I have included information for GRT as well.

SharePoint Configuration Check List

1.  NetBackup Client version should be the same as the Master Server, and should be installed on all servers in the SharePoint farm, even SQL backend.   For SharePoint 2010 SP 1 or GRT you must be on 7.1.0.4 or higher.

2.  The NetBackup Client service should be started by a Domain Account.  (MUST be in format“domain\user”)
      (additional services are needed for GRT, please see GRT Section)

3.  The domain account in Step 2 must have the following privileges and permissions:
  a.  "Replace a process level token" and "Debug Programs" (Administrator Tools - Local Security Policy - Local Policies - User Rights Assignment) for all servers in the SharePoint farm, backend SQL included.
  b.  Local Administrator rights on all servers in the SharePoint farm.
  c.  Within SharePoint Central Administrator, the Domain Account is specified as a SharePoint Farm
Administrator
  d.  The System Administrator role on the SQL Server for the SharePoint databases.

4.  At a minimum, you must have at least .NET Framework 3.5 installed on all servers in the SharePoint Farm.

5.  Under Host Properties - Clients on the Master server, under the Windows Client - SharePoint section, make sure that the Domain Account from step 2 is specified there, with the syntax as follows:  DOMAIN\Username  (not just the Username).  Do this for every client/server member of the SharePoint farm.

6.  In the first policy (non-granular), the client selection is a Front End Web server for the SharePoint portal.  The backup selection for your first policy should be: "Microsoft SharePoint Resources:\"

7.  Create a "beds" directory under <install path>\NetBackup\logs\ on each of the SharePoint farm servers (SQL included)

8. Under Host Properties - Master Server, there is a Distributed Applications section.  For the first field, put in the name of the Front end server in the SharePoint policy, and in the 2nd field, the name of the SQL server hosting the SharePoint databases.

9.  From the Front End web server specified in the policy, Right click on the NetBackup Backup, Archive, and Restore (BAR) GUI and  select "Run as Administrator" .  You should be able to see Microsoft SharePoint Resources objects there. If you do not see objects, check the farm topology and make sure you have not missed any of the steps on that server.

For the first policy (non-GRT), make sure you do not have the "Enable Granular Recovery" box checked.

10.  You may now test you SharePoint Backup.

Addition steps for SharePoint  GRT
------------------------------------------------------------
For setting up GRT backups of SharePoint, the Media server (if it is a Windows box) and the SQL server need to be running Windows 2003 R2 (or greater) with the following hotfix applied: http://support.microsoft.com/kb/947186.

- In addition The Media server doing the backup/restore operations MUST have NFS Server components installed and running, as outlined in the SharePoint Administration Guide for NetBackup.

- The Frontend and Backend  servers must have Client for NFS

See Tech Note for details on NFS - http://www.symantec.com/docs/TECH76684.

-The backups can only be Full backups, and must be taken to a disk storage unit, not tape.  Be sure that the policy reflects this as well as having the "Enable Granular Recovery" box checked.  Please see the following tech note which lists what type of disk storage types are support for GRT - http://www.symantec.com/docs/TECH187917  

-  Since GRT only supports Disk, backups can be staged off to tape media at a later time, but the initial backup must be to disk.  If you stage the backup image to tape, you must duplicate the image back to disk before a restore can be attempted.  For best performance, Symantec recommends that the disk storage unit being used as a target for GRT backups be located locally on the media server as direct SCSI or SAN attached disks. The use of disk storage units that write to network based file systems ( NFS or CIFS ) is not recommended. Performance degradation or read errors may result when the media server presents the backup image via NFS to the client or proxy client if the NFS exported image itself is residing on a network file system ( NFS or CIFS ).

 - In addition to the Netbackup Client service, the Netbackup Legacy  Client Service  and Legacy Network services should be service should be started by a Domain Account.  Please refer to #2 and #3 above.

 - For GRT Restores, you must run the BAR from the Front end server.

SOLUTION
Kwinter's picture

Pefect ... it's working.

Problem was that I left out step 5

"Under Host Properties - Clients on the Master server, under the Windows Client - SharePoint section, make sure that the Domain Account from step 2 is specified there, with the syntax as follows:  DOMAIN\Username  (not just the Username).  Do this for every client/server member of the SharePoint farm."

added this to all the servers in the farm and it worked great

Thanks Dyneshia !!