Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

Netbackup 7.5.0.4 in need of more space in /tmp

Created: 08 Nov 2012 • Updated: 12 Nov 2012 | 8 comments
Andre_Torres's picture
This issue has been solved. See solution.

Hi everyone,

 

I have an NetBackup 7.5 and trying to upgrade to 7.5.0.4 (HPUX ia64). During the installation it says me I have about 1.2 GB of free space in /tmp and NetBackup needs about 2.4 GB in /tmp.

 

The problem is, my /tmp is a fixed size, about 1.4GB in total. Can I redirect where NetBackup can extract the files to another directory with more disk space?

Comments 8 CommentsJump to latest comment

revaroo's picture

Yes you need to edit the installation script and point your TMP or TMPDIR variable (can't remember exactly what it is off the top of my head) to another location.

Nicolai's picture

I have written a small blog about that subject here:

http://www.mass.dk/netbackup/quick-hints/69-altern...

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

CRZ's picture

Yikes!  Don't edit the script; set your NB_TMPDIR environment variable prior to starting the script:

# NB_TMPDIR=/verylargepartition/tmp; export NB_TMPDIR

(I will be corrected, hopefully, if that's not the "HP" version of how to set that environment variable)

The error you've received is actually an improvement over how it USED to be, with the install filling up the disk and failing, leading to unexpected results.  For example:

On Solaris, when applying 7.5.0.1, if insufficient space exists in /tmp, the patch process will abort leaving a master or media server with only the client binaries installed.
 http://symantec.com/docs/TECH189085

 


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
revaroo's picture

CRZ,

I've not looked at the install script for a while, do they pull the shell variable settings into the script or is the variable reset within the script?

CRZ's picture

I believe the latest iteration of the script looks for NB_TMPDIR, then looks for TMPDIR, and if neither is already set, it will set TMPDIR to /tmp and move on.  When NB_TMPDIR exists, it will override TMPDIR as the script will set TMPDIR using the value of NB_TMPDIR. 

DISCLAIMER: I'm not actually looking at the script right now either, so there is a chance I'm not 100% correct...but I feel sure enough to hit "Save"


bit.ly/76LBN | APPLBN | 75LBN

Andre_Torres's picture

It worked.

 

But how do I undo the changes in NB_TMPDIR and "unexport" the directory? Or do I leave that way.

CRZ's picture

Probably wouldn't hurt to leave it that way, but you can unset the variable by either setting it again to NULL (or "") or by unsetting by using the appropriate shell command (unset or unsetenv or ...?)  Again, it really depends which shell you're using.


bit.ly/76LBN | APPLBN | 75LBN

jim dalton's picture

As an aside, 1.4G of tmp is miniscule from my viewpoint but then this is HPUx, so its rules may differ.

If tmp is sized according to memory, then this could be another issue (tho I doubt it). 

Sure its not just full of someone elses junk? I read by default /tmp isnt cleared on reboot.

Jim