Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

NetBackup 7.5.0.4 Support for HP MSL4048 Tape Library

Created: 18 Jan 2013 | 7 comments

Hi,

 

I am having issue with the NetBackup 7.5.0.4 which is running on Windows 2008 R2 and the Tape Library which we have is HP MSL4048 LTO-5 Two Drives. The problem which we are facing is, intermittently the drives are getting disconnected and in NBU Master/Media Servers shows the drives are down, but in OS it shows drives are still connected and Up. In fact we have upgraded the Drive and the Library firmware to the latest but still the same problem persist. I was going through the Netbackup 7.x compatibility Guide, where it says "Supported with the MSL Library Extender". I am not sure, if this is mandatory to have the Library Extender, as we have another setup with NBU 6.5.5 which runs fine without any Library Extender. Can anyone suggest here what could be the problem. Below are some details about setup for more information 

 

NetBackup Master Server - 7.5.0.4

OS - Windows 2008 R2 x64 

Tape Library - MSL4048 FC LTO-5 Two Drives 

SAN Switch - Brocade 

 

Regards

 

Shreream Rane 

 

 

 

 

 

  

Comments 7 CommentsJump to latest comment

sazz.'s picture

Library extender is just to increase the capacity and this could be some other reason. If drives are keep going down look if tapes are getting stuck in the library.

Add verbose in vm.conf on all media server and restart the ltid. Check the sytem event veiwer for events 7,11,15 for any drive or hardware error. YOu could also run the hardware diagnostic to get to the root cause.

sriramrane's picture

Hi Sazz,

Thanks for the quick reply. 

Drives are not going down or any tape getting struck within the drives. Also have modified the vm.conf file restarted the Device Services, and it is not logging any event of tape drives connection failure or any other sort of error related to tape library. I have also run the HP Diagnostic utility to get deep in to the problem solving exercise, there as well its not detecting any errors too. I was wondering what could be the possible problem for such an awkward behaviour. Even I have tried changing the Fiber cables, changing SCSI/LUN ID within the tape library, but no luck. As a last option, I have tried Windows native backup from one of the Windows 2003, which also act as NBU Media Server, but Windows backup when I have tested it went fine, as well to check inconsistency run backup in different intervals, havent found any issues.

Look like it is not connection issue, or zoning issue, or any sort of device driver issue. May be when NBU initiate a backup through a device driver which somewhere has incompatiblity. 

Lets me know if any sort remedies which I can try to isolate the issue.

 

Regards

 

Shreeram Rane 

 

sazz.'s picture

If NBU thinks there is any issue writing to tape within certain period of time it makes the drive down and it should log the error messages. when it goes down. Make sure you look for the error message when the drives goes down. How long this been working fine or it is a new setup? What type of tapes you are using?

you sure you made the entry
VERBOSE to vm.conf on each media server and restarted the devicce manager service.

bptm log on all media servers

Create below as well

/usr/open/volmgr/debug/tpcommand

/usr/openv/volmgr/DRIVE_DEBUG

Also how many media server you are using. Are these drives shared? When they go down they should be reporting errors in the logs, make sure you restart the device manager service.

sriramrane's picture

Hi Sazz,

 

Its a new setup. In fact we have NBU 6.5.5 in another setup, those are for other set up servers and different project. This setup is new, and there are few servers in this backup domain. Initially we also had a problem with configuration too, as while configuring the Device, sometime the NBU used to detect One drive with One Robot, sometime only two tape drives without robot and sometime it used to show Two robots and 4 drives. It was all awkward behaviour. But one fine day it started showing correct number of drives and robot. At that time we have configured the Master/Media Server and one Meida Server which running on Windows 2003. We have logged a case with HP and they have done diagnosis and they gave report as tape library is healthy and perfect without any problem. We are using LTO-5 tape drives wiht LTO-5 tapes. 

I have only done the changes on Master/Media server to test the backup, other one we have only one media server apart from Master Server. Drives are shared between the Media Servers.

We dont have UNIX/Linux servers in this backup domain, its purely Windows. 

 

Reagrds

 

Shreeram Rane 

 

 

Stuart Green's picture

You are using Shared Storage Option for the drives between Master and Media? You have a license for this?

Can you show  a screendump of your Device Monitor displaying drives and paths please.

Can you show us also a screendump of the tape library web management page of the library and drive setup eg.Command View? 

HP can verify there is nothing wrong with the library. So how are you presenting the library into the OS across fabric. Thats where I would start.

Check speed/config settings on the FC switch ports to match the tape drives gbics. 

Are there errors logging on the FC switch port counters? Reset them and run backups etc.

Firmware on FC HBA cards up to date etc.?

 

For example here is Command View MSL from my library.

Tip: Get overview/document your NBU environment. Run 'nbsu' and review the output.

• If this provides help, please vote or mark appropriate solution.

Mark_Solutions's picture

Have you set the AutoRun 0 key in the registry and disabled the Removable Storage Service (if the service was added as 2008 component)?

Follow this link to check how to do the AutoRun key - it applies to all Windows versions:

http://support.microsoft.com/kb/842411

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

sriramrane's picture

Hi Stuart,

We have all the required license. Also there are no logs reported within the SAN switches and other devices, storage and services which are connected working fine without any problem. And related to the Tape Library firmware (both Library and Drives) is  up-to-date. Also the Fiber HBA, SAN Switch and the Tape Drive is in 8 Gbps speed. 

Will try to disable to enable the ports or Reset them to test it. I will keep you posted on this.

 

Hi Mark,

We have Master Server which is Windows 2008 R2 which act as Master/Media Server apart from one Windows 2003 Media Server. We have this behaviour on both Windows 2003 and Windows 2008 Media Servers. We have diabled the Removable Storage services in all servers. Regarding the AutoRun Key, which I need to check for Windows 2003. I dont think that could be a problem, as we have sometime taken a backup from Windows 2003 as a Media Server and which worked fine for few days.

 

 

Regards

 

Shreeram Rane