Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

NetBackup 7.5.0.5, AUTO_UPDATE_ROBOT not working

Created: 18 Mar 2013 • Updated: 05 Apr 2013 | 7 comments
This issue has been solved. See solution.

NetBackup 7.5.0.5, running on Red Hat Linux

Since we upgraded NetBackup to 7.5.0.5, tapes being placed in the I/O door on our TLD-type library are not being automatically inventoried into NetBackup anymore.  I have confirmed that both possible robot control hosts still have AUTO_UPDATE_ROBOT in the /usr/openv/volmgr/vm.conf.

This same thing happened when we upgraded to 7.1 and required an EEB to fix it.  I wanted to see if anyone else has noticed the same problem before I open another case with Symantec.

Operating Systems:

Comments 7 CommentsJump to latest comment

Mark_Solutions's picture

There was also a 7.5 bug so maybe this has followed through into 7.5.0.5:

http://www.symantec.com/docs/TECH198155

Worth logging a call to see if they have a 7.5.0.5 EEB version

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

mph999's picture

 

I had a look in the eTracks and cannot see any reported issues at 7.5.0.5
 
I'm presuming here that no firmware updates have been made on your library at the time you upgraded, because for 100% certain, firmware updates have been known to 'break' this feature.
 
tldcd is the process that checks for 'unit attention'  but the event should be seen in the robots log.
 
I recommend the following:
 
The robot log would be here, create the directory and file below, add VERBOSE to vm.conf, if necessary, and restart ltid (stopltid, then ltid -v) 
 
Create dir /usr/openv/volmgr/debug/robots
 
I would also create this empty file : 
 
/usr/openv/volmgr/ROBOT_DEBUG 
 
add VERBOSE to 
 
<install path>\veritas\volmgr\vm.conf 
 
Restart the media manager services.
 
Next, add some tapes to the CAR, or just open/ close and look in the robots log ...  (or maybe the system log, can't remember for sure).
 
You are looking for a line that looks someting like this :
 
15:11:36.224 [20677] <6> tld_main: detected a unit attention, run vmupdate (1 || 1) 
 
As per your description, I suspect it will be missing ...
 
To escalate a call, you will need the above information, + nbsu -c -t from the robot control host.
 
I would also, delete and recreate the vm,conf file.  There is a small possibility that the file has become corrupt and the AUTO_UPDATE_ROBOT line is not being 'detected'.
 
martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
RonCaplinger's picture

Thanks for the suggestions!

All still set up since the last time this happened, so I just had to copy the existing log file to another name and let NBU create a clean new one.  I also reconstructed the vm.conf file, then put some tapes in the library door.  Still no go.

I've already opened a case, run nbsu -c -t, and attached the output and the robots log file to the case.  Just waiting for a response from Symantec.

mph999's picture

Typically Mark posted an answer as I was typing mine out ...

I saw that eTrack on my travels, there is no version for 7.5.0.5

You will need to raise a case I'm afaid, a case is needed to get an update of an existing EEB.

Although it is possible it is the the same issue, I recommend you  still be gather the logs from you system.

Martin

 

 

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
jp-nbuadmin's picture

I recently migrated our backups from a 7.0.1 environment that had the AUTO_UPDATE_ROBOT feature working to a environment on seperated hardware running 7.5.0.3 and the AUTO_UPDATE_ROBOT feature is not working. Both environment are still online but the 7.0.1 systems are no longer zoned to the tape library so they can't control the robot.

Do you know if there is an EBB for 7.5.0.3 or if one is in the works for 7.5.0.5? If we can get a solution now I would stay at the current version, otherwise I would upgrade if it gets us to a resolution faster on 7.5.0.5.

Not having this feature makes life very difficult when you are working with a colo data center on the other side of the globe in different time zones.

Thanks for the help.

Jerico

 

RonCaplinger's picture

There is an EEb for 7.5.0.5.  The installer I have is named "eebinstaller.3138156.1.linuxR_x86".

RonCaplinger's picture

I contacted Symantec and just received and installed the EEB yesterday, and it works.