Video Screencast Help
Protect Your POS Environment Against Retail Data Breaches. Learn More.

NetBackup 7.5.0.5, cannot restore to different path

Created: 06 Mar 2013 • Updated: 18 Mar 2013 | 8 comments
This issue has been solved. See solution.

Master servers - NBU 7.5.0.5, Solaris 10

Clients - NBU 7.5.0.4, Windows 2003/2008/various releases

Desktop - NBU Java GUI 7.5.0.5, Win XP

 

Upgraded the NBU master last week to 7.5.0.5 and have not been able to restore files to an alternate path.  Cannot restore any files to any alternate path or client.  A small "Path Problem" window pops up, "Invalid Destination pathname."  I've tried the C:\temp directory, alternate clients, etc. The Java GUI will only allow me to restore to the original pathname, so I have to log into the client and rename the existing file there before I can restore the old version.

I can use the Windows GUI to restore to other directories on the original server, so this appears to be specific to the Java GUI.

Anybody else notice this? 

Operating Systems:

Comments 8 CommentsJump to latest comment

Marianne's picture

Have not upgraded to 7.5.0.5 yet. Best if you take screenshots and open a Support call ASAP.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Yasuhisa Ishikawa's picture

I saw same problem last week. I manage it by connecting to client on java GUI. Requesting restore from client works with alternate path.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Bertil's picture

Yes, seen that here as well.  Upgraded from 7.0 to 7.5.0.5 and now a push restore from the Master or media server(s) does not allow restoring to a different directory. 

We restore users folder to s sub-folder called RESTORED, and let them figure out what file(s) they want.  We are so used to just clicking on the second button and adding RESTORED so we found this *very* quickly, screen-snip attached. 

*However*, using UNIX-like string for the taget path i.e.

 /F/mnt/staff/staff-home-1/eng/mm/mmpo/RESTORED *did* work.

Basically, Netbackup 7.5.0.5 may have "fixed" this syntax, but for us Windows users, a retrograde step. 

Outline of what kit we have:

SUN/Oracle-based master/media servers, most of our clients are VMWare ones so we use 4, VM-based "clients" to backup snampshotes. 

The snip shown is the Java GUI running on the Master server (Solaris-based, Netbackup 7.5.0.5), requesting a Windows client (W2003, netbackup 7.5.0.5) ) to restore to another Windows 2003 server (clinet 6.0MP4?)

 

Capture.JPG
CRZ's picture

Hi Ron,

I believe you're already working a case with us around this issue? 

For anyone else who comes across this thread who may be experiencing this issue, I would like to point out the two excellent workarounds already discovered by both Ron and Bertil above, either of which will avoid the error popup:

  • Use the Windows Remote Administration Console instead of the Java console.
  • Change your "Windows" file path to a "UNIX" one by removing the colon from the drive name, prepending with a forward slash ("/") and changing all backslash ("\") characters in the path to forward ones - for example, "Z:\RESTORED" would become "/Z/RESTORED" instead.

This is another of those issues where it's more aggravating than disastrous - but "aggravating" isn't much consolation, and we'll work hard on resolving this (what we're pretty sure is a) defect.


bit.ly/76LBN | APPLBN | 75LBN

CRZ's picture

I have some new news on THIS issue as well!

An EEB is now available for this defect - please open a support case and reference Etrack 3113092.  TechNote to come, I hope!


bit.ly/76LBN | APPLBN | 75LBN

SOLUTION
HEMANPR's picture

Try to set the Destination ith the Network Path

\\SERVERNAME\DRIVE(Or Share c$)\DESTINATION\DIRECTORY

Be sure the destination directory exist.

Please MARK AS SOLUTION If my Post Help You. I use the following Symantec Products: Veritas Netbackup 7.5 On Windows Enterprise 2003 SP2 - / - Symantec EndPoint 12.1.100.157 RU1 On Windows Standard 2003 SP2 - / - Symantec&nb

RonCaplinger's picture

2nd attempt at updating this post, the first one doesn't seem to have been saved.

Chris is correct, there is an EEB now available, see his post above. 

Note that the EEB installer is looking for the version.txt file to determine if you have the correct version for this EEB.  If you do not have the full NetBackup client or server installed on the computer from which you are running the Java GUI, the EEB installer will fail because it is looking for the version.txt file which is not part of the Java GUI install.

You will have to extract the files from the EEB using a "-extractonly" switch and manually replace the .jar file in your Java GUI install directory. 

CRZ's picture

Here's a quick update on this issue:

We have attached a hotfix to this TechNote:

When running the NetBackup 7.5.0.5 Java admin console and restoring windows clients to alternate directories, an "invalid destination pathname" error is displayed.
 http://symantec.com/docs/TECH203806

If you don't want to use the workaround of converting your Windows path to a "UNIX style" path, download and install the nbjP.jar file attached to this TechNote and restart your Java GUI.

This'll be fixed in 7.5.0.6 as well, for sure.


bit.ly/76LBN | APPLBN | 75LBN