Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup backup is still running but the java gui doesn't show active backup

Created: 29 Jan 2013 | 9 comments

Hi All,

I am having a problem. even though some backup is still running (active) but I cannot see on the Java GUI. The Java GUI itself can connect to the server but on "Activty Monitor" I cannot see the "Active" backup job but I can see "Done" jobs or "Incomplete" jobs etc.

If I see on the Master server using bpps I can still see lots of active backup, e.g:

ebs1-bck@/> bpps -a | grep bpbackup
    root 14998 14995  0 09:00:12 ?         0:00 bpbackup -i -p LT01_FS_OS -s Daily_Incre -h lt01-bck -w 0
    root 27712 27711  0 09:30:06 ?         0:00 bpbackup -i -p M104S_FS_TL_MEDIATOR -s Daily_Incre -h m104s-bck
    root  2427  2425  0 10:00:08 ?         0:00 bpbackup -i -p TPADMIN01_FS_OS -s Daily_Incre -h tpadmin01-bck
    root 15614 15612  0 09:00:18 ?         0:00 bpbackup -i -p TPADMIN01_FS_APPS_3 -s Daily_Incre -h tpadmin01-
    root 14895 14893  0 09:00:12 ?         0:00 bpbackup -i -p REMEDYDB1_DAL_B2BP -s Daily_Full -h b2bp-bck -w
    root  2514  2513  0 10:00:08 ?         0:00 bpbackup -i -p DMS02_AL_DMSYSP -s Daily_Full -h dmsdb-bck -w 0
    root  2293  2290  0 10:00:07 ?         0:00 bpbackup -i -p JAP4_FS_OS -s Daily_Full -h jap4-bck -t 13 -w 0
    root  2525  2520  0 10:00:09 ?         0:00 bpbackup -i -p DBSVR26_AL_CMSP -s Daily_Full -h cms-bck -w 0
    root 15384 15368  0 09:00:16 ?         0:00 bpbackup -i -p DEV07_FS_OS -s Daily_Incre -h dev07-bck -w 0
    root  5061  5059  0 08:30:02 ?         0:00 bpbackup -i -p DR03_FS_OS -s Daily_Incre -h dr03-bck -w 0
    root 14509 14498  0 09:00:08 ?         0:00 bpbackup -i -p TPADMIN01_FS_APPS_2 -s Daily_Incre -h tpadmin01-
    root 15539 15532  0 09:00:17 ?         0:00 bpbackup -i -p DR04_FS_OS -s Daily_Incre -h dr04-bck -w 0
    root 15490 15487  0 09:00:17 ?         0:00 bpbackup -i -p ETL02D01_FS_APPS -s Daily_Incre -h etl02d01-bck
    root 14666 14662  0 09:00:09 ?         0:00 bpbackup -i -p TPADMIN01_FS_APPS_1 -s Daily_Incre -h tpadmin01-
    root  2414  2411  0 10:00:07 ?         0:00 bpbackup -i -p ODS02_AL_ODSP -s Daily_Full -h odsp-bck -w 0
    root 15237 15228  0 09:00:15 ?         0:00 bpbackup -i -p DBSVR21_DAL_CCP -s Daily_Full -h ccp-bck -w 0
    root 15292 15289  0 09:00:15 ?         0:00 bpbackup -i -p ICTMD_DAL_MZP -s Daily_Full -h ictmd-bck -w 0
    root 14908 14906  0 09:00:12 ?         0:00 bpbackup -i -p DEV09_FS_OS -s Daily_Incre -h dev09-bck -w 0
    root 27662 27654  0 09:30:05 ?         0:00 bpbackup -i -p FMS01_FS_EL6APPS -s Daily_Incre -h elpapps-bck -
    root 15413 15405  0 09:00:16 ?         0:00 bpbackup -i -p REMEDYDB1_DAL_TTSP -s Daily_Full -h ttsp-bck -w
 

3 days ago this thing also happened, then I had no choice to restart the Netbackup on the master server, and after that it seemed OK. but I cannot always restart the netbackup.

Anyone know the solution?

Thank you,

Iwan Tamimi

Comments 9 CommentsJump to latest comment

sazz.'s picture

What version of NBU you are using and what version of Java you are using? Make sure you the same version of java as per the version of NBU. Which OS are you on?

Make sure there is no filter active on the active session. Try to close the java console and launch it again. If you can, try using windows admin console.

Iwan Tamimi's picture

Hi Sazz,

Thank you. It is version 6.5.6 ( I know it is not supported anymore).

The processes I saw actives actually hang becasue from the server there is no progress on the backup. Looks like is not the Java GUI problem. It could be something else. I

Anyone has a similar experience?

Regards,

Iwan

RamNagalla's picture

"The processes I saw actives actually hang becasue from the server there is no progress on the backup."

to make sure this please take a test backup of small file in master server  and see if that comes in to the activity moniter and compleats it

let us know how the below command looks like

bpps -a | grep -i bpjobd

bpdbjobs -summary

bpdbjobs -report

Yasuhisa Ishikawa's picture

Odd thing. it is possible:

  • network connection between bpbackup and bprd were established, but bprd could not process requests and by some reason.
  • Jobs were stuck  in Queued state(must be displayed in Activity Monitor as it is)
  • jobs started, but nerver ended. AND activity monitor did not display them by some reason

if you have enabled dubug logs, you should go through them - especially bprd, bpbackup(or admin), nbpem, nbrb, bpbrm, bptm, bpbkar.

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

Mark_Solutions's picture

To be sure of what is happening and to rule out the Jave issue - how about installing a Windows Admin Console somewhere (unless you already have a Windows Media Server?) and see if they are visible from there

My first thought was a filter as mentioned earlier in this thread - but to be sure add a PC to the Masters Host Properties - Servers list (or bp.conf) and look at things from a fresh Windows Admin Console

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

watsons's picture

If you have a quiet time (when no jobs is running), try with just one or two backup jobs and see if that shows up in Java GUI. Sometimes it could be due to the large amount of jobs that the GUI "takes time" to receive and handle, especially active jobs contain more variable data.

Use direct admin console, as Mark suggested, is a great method to narrow down the cause. 

Iwan Tamimi's picture

Hi All,

Thank you for the supports.

I know the process hang because some backup usually running only 10 minutes, didn't finish even after 1 hour and we were using job scheduler (not from netbackup) those processes didn't return if it had finished.

Like always, after I restarted the netbackup, everything back to normal

(Currently our system is being upgraded to another platform, if it succeed the old platform we won't use it again. I will let yo know)

Regards,

Iwan Tamimi

Marianne's picture

How are you kicking off backups? These jobs do not look like automatically scheduled backups.
Are they kicked off manually? Or started by some external scheduler? If external scheduler, add '-L </path/logfile>' to the scripted commands.

Next, check bprd log file on master to see if manual backup is received and passed to nbpem. If so, use vxlogview to examine nbpem logs.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

Have to agree with Marianne here ...

Looks like you use your own scheduler to kick off jobs and hence the processes start, but i would imagine thaty there is something wrong with you scripts so they are either waiting for something or sending their information to totally the wrong place ... so you get the processes but the jobs never start (at least not as far as your Master is concerned)

We would need to see your scripts that run this but the -L would at least pipe out to a log file so that you could what it was doing or waiting for to give a clue

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.