Video Screencast Help

Netbackup cannot change to other Volume Pool

Created: 22 Jul 2008 • Updated: 22 May 2010 | 4 comments

Hi All

 

I had a problem trying to relocate a media from one volume pool to another. It shows the message saying:

 

Change Pool of <media label> failed(91)

 

I had tried to take the media out and in and ran the "Inventory Robot --> update volume configuration, but it still not allow me to change this media to another volume pool.

 

Did you guys have similar problem before?

 

Thanks

 

Jack

Comments 4 CommentsJump to latest comment

Dion's picture

Check whether the media you are trying to change has any data on it or is assigned - you can only change the volume pool of media when it is unassigned (does not contain any data on it).

Nedcor42002's picture

Hi Dion

 

You are right, the tape had been assigned before and there are data in the media. In this case, is there anything i can do to reassign such media to other Volume Pool without overwrite the data inside the media? What i want to do is, just re-assign this media to other pool and use it to carry on backup other data.

 

Thanks

 

Jack

Dion's picture

Jack

As far as I can remember, there was a technote about it but it is definitely not recommended as you can land up with database inconsistencies (not good!).  So unless there is a new way that I don't know about, I would guess that the best is to duplicate from the existing media to new media in the pool you want and then expire the copies on the original media.  This will allow you to free them up and put them back into a scratch pool (or new pool).

Just a note about expiring images on the unwanted pool (if you choose this route), just make sure that you only expire the unwanted copy of you backups and not all of them.  e.g Copy 1 is on the media you don't want and Copy 2 will be the new, duplicated, backup images.

 

Maybe someone else know about an easier way?

 

Cheers

bakitup's picture

Ditto to Dion's comments.  Safest and supported method.