Video Screencast Help

Netbackup client communication error

Created: 03 May 2011 | 3 comments

hi

we have a netbackup 7 installed on  windows master and media server, i have installed the same version to the one of the client(windows), the installation got completed successfully,but when i try to check the connectivity from the master server (Host properties ->clients) it fails with cannot connect on socket,

i tried to telnet from client to master and master to client for Vnetd and bpcd ports it is successfull, suspecting  a DNS issue have tried to run bpclntcmd -ip and bpclntcmd -hn it is resolving properly,

 

i am able to see the following bpcd log under client, please suggest me on the issue.

 

17:02:05.402 [15760.15980] <2> setup_debug_log: switched debug log file for BPCD
17:02:05.402 [15760.15980] <2> bpcd main: VERBOSE = 0
17:02:05.402 [15760.15980] <2> logparams: C:\Veritas\NetBackup\bin\BPCD.EXE
17:02:05.402 [15760.15980] <2> bpcd main: Got socket for input -2
17:02:05.402 [15760.15980] <2> process_requests: offset to GMT 0
17:02:05.418 [15760.15980] <2> logconnections: getsockname(-2) failed: 10038
17:02:05.418 [15760.15980] <16> bpcd setup_sockopts: setsockopt 2 failed: h_errno 10038
17:02:05.418 [15760.15980] <2> process_requests: setup_sockopts complete
17:02:05.418 [15760.15980] <16> bpcd peer_hostname: getpeername: An operation was attempted on something that is not a socket.
17:02:05.418 [15760.15980] <16> process_requests: Couldn't get peer hostname
 

Comments 3 CommentsJump to latest comment

Marianne's picture

Error in the bpcd log:

bpcd setup_sockopts: setsockopt 2 failed: h_errno 10038

The TCP error code 10038 indicates a problem at TCP/IP level which prevents socket setup on the client. There are a number of TechNotes that list some possible reasons for this problem and ways to troubleshoot:

http://www.symantec.com/docs/TECH71925
http://www.symantec.com/docs/TECH88628
http://www.symantec.com/docs/TECH48318
http://www.symantec.com/docs/TECH141839

Please review all of these T/N carefully to pinpoint the problem and find a solution....

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

watsons's picture

Did you turn off Windows Firewall?

Try with it disabled first, if it works and you need the Firewall, add those ports into your FIrewall rules.

If this has been checked. run a:

bptestbpcd -client <clientname> -debug 

from master or media, see what you get.

sharan's picture

hi Watsons \marianne

thanks for that quick turn around, actually we have a TCP filter tool installed on the server, so i have requested the Server team to disbale the tool, once it is done , i will check with the communcation and get back to you.

Once again thanks for that support. smiley