Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup cmd is not responding

Created: 31 Aug 2012 | 3 comments

Hi,

Got a query on a issue I am facing.

I am trying to fetch client data from master server using  "/usr/openv/netbackup/bin/admincmd/bppllist -U -byclient", but one of the master server is not responding to this cmd. can any one tell me hoe to remediate this.

Thanks,

Abaig.

Comments 3 CommentsJump to latest comment

revaroo's picture

I assume you are running bppllist from a different server than the Master.

does the command run ok on that Master server directly?

Is the command hanging or does it fail on the remote host?

What is logged in the admin log from the server you run bppllist, you should see this or similar. Notice the EXIT status = 0 at the end. That means it was successful.

12:27:27.125 [23277] <2> bppllist: INITIATING: version NetBackup 7.1 created: 2012031711
12:27:27.125 [23277] <2> logparams: -U -byclient testclient
12:27:27.128 [23277] <2> vnet_pcache_init_table: ../../libvlibs/vnet_private.c.232: 0: starting cache size: 200 0x000000c8
12:27:27.128 [23277] <2> vnet_cached_getaddrinfo_and_update: ../../libvlibs/vnet_addrinfo.c.1516: 0: found in file cache name: testclient
12:27:27.128 [23277] <2> vnet_cached_getaddrinfo_and_update: ../../libvlibs/vnet_addrinfo.c.1517: 0: found in file cache service: NULL
12:27:27.128 [23277] <2> Default Retention: No user retention file
12:27:27.128 [23277] <2> retrieveLocalPatchVersion: Reading from /usr/openv/netbackup/version
12:27:27.128 [23277] <2> parsePatchVersionString: parsing = >7.1.0.4
<
12:27:27.128 [23277] <2> parsePatchVersionString: theRest = ><
12:27:27.129 [23277] <2> LOCAL CLASS_ATT_DEFS: Product ID = 6
12:27:27.101 [23277] <2> listallclasses: search_type = 0, search_string = testclient
12:27:27.102 [23277] <2> bppllist: EXIT status = 0
 
Marianne's picture

Does any other bppllist option work?

What happens if you isue bppllist command without any options?

If nothing works, have a look at file size of bppllist.

If someone has done the following :
# cd /usr/openv/netbackup/bin/admincmd
# bppllist -'some-options'  > bppllist
it would overwrite bppllist binary and replace with empty file (size 0).

This can be fixed by copying binary from another server of the same OS and NBU version.
 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Mark_Solutions's picture

A couple of things ...

1. If not running on the Master does the server you are running it from appear in the media server or additional server list on the Master so that it has rights to make the request.

2. have you tried my adding the -M masterservername to the end of the command?

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.