Video Screencast Help

Netbackup error 6 for sap online backup

Created: 10 Jan 2013 | 5 comments

 

Master server : windows 2008

Media server : Window 2008

Netbackup version on both Master and Media is : 7.1.0.4

Client: AIX 6.1

We are taking sapbackup using BRtools and storage is DD890.

this sapbackup fails in the first attempt but completing successfully in the 2nd attempt.

i dont find the any different in the both logs i.e. failed and successful one.

even in the failed backup, has backedup all the files successfully.

We dont have clue to find it.

Please help, let me know if you require any logs.

detail status:

 

01/09/2013 20:00:00 - Info nbjm (pid=3616) starting backup job (jobid=1167828) for client XXXXXXXXX, policy YYYYY, schedule Full_Online
01/09/2013 20:00:00 - Info nbjm (pid=3616) requesting MEDIA_SERVER_WITH_ATTRIBUTES resources from RB for backup job (jobid=1167828, request id:{DF80FA32-1766-42B3-96D9-0924BB667E7C})
01/09/2013 20:00:00 - requesting resource ZZZ_Aggregate_STU
01/09/2013 20:00:00 - requesting resource AAA.NBU_CLIENT.MAXJOBS.XXXXXXXXX
01/09/2013 20:00:00 - requesting resource AAA.NBU_POLICY.MAXJOBS.YYYYY
01/09/2013 20:00:00 - granted resource  AAA.NBU_CLIENT.MAXJOBS.XXXXXXXXX
01/09/2013 20:00:00 - granted resource  AAA.NBU_POLICY.MAXJOBS.YYYYY
01/09/2013 20:00:00 - granted resource  ZZZ_Aggregate_STU
01/09/2013 20:00:06 - estimated 0 kbytes needed
01/09/2013 20:00:06 - Info nbjm (pid=3616) started backup job for client XXXXXXXXX, policy YYYYY, schedule Full_Online on storage unit ZZZ_Aggregate_STU
01/09/2013 20:00:15 - started process bpbrm (pid=3884)
01/09/2013 20:00:18 - Info bpbrm (pid=3884) XXXXXXXXX is the host to backup data from
01/09/2013 20:00:18 - Info bpbrm (pid=3884) reading file list from client
01/09/2013 20:00:18 - connecting
01/09/2013 20:00:24 - Info bpbrm (pid=3884) starting bphdb on client
01/09/2013 20:00:24 - Info bphdb (pid=16580618) Backup started
01/09/2013 20:00:24 - Info bphdb (pid=16580618) Processing /usr/openv/netbackup/scripts/sap_online_backup.sh
01/09/2013 20:00:24 - Info bphdb (pid=16580618) Waiting for the child status
01/09/2013 20:00:24 - connected; connect time: 0:00:00
01/09/2013 20:52:00 - Error bpbrm (pid=3884) from client XXXXXXXXX: ERR - Script exited with status = 1 <the requested operation was partially successful>
01/09/2013 20:52:00 - Error bpbrm (pid=3884) from client XXXXXXXXX: ERR - bphdb exit status = 6: the backup failed to back up the requested files
01/09/2013 20:52:03 - end writing
Failed to get status code information (6)
 

Regards,

Chan.

Comments 5 CommentsJump to latest comment

Nagalla's picture

 

01/09/2013 20:52:00 - Error bpbrm (pid=3884) from client XXXXXXXXX: ERR - Script exited with status = 1 <the requested operation was partially successful>
01/09/2013 20:52:00 - Error bpbrm (pid=3884) from client XXXXXXXXX: ERR - bphdb exit status = 6: the backup failed to back up the requested files
 
You would need to check the bphdb logs  and the SAP script. may be also error log from the Data base logs..

 

Will Restore's picture

Error 6 is generic 'database backup failed'

Look into the bphdb and bpclient logs on the client for the real source of the trouble

 

Will Restore -- where there is a Will there is a way

Chan_backup's picture

Hi 

 

i have attached the bphdb logs and logs from /oracle/xxx/sapbackup.

please comeback with you findings

Thanks,

Chan

AttachmentSize
failed.txt 14.79 KB
success.txt 14.79 KB
sap_stdout.010913.txt 46.62 KB
Will Restore's picture

don't see any failure here

BR0052I BRBACKUP completed successfully

BR0052I BRBACKUP completed successfully
 

 

this however might be a problem

BR0013W No offline redolog files found for processing

 

please post dbclient log from failed backup 

Will Restore -- where there is a Will there is a way

Nagalla's picture

 

BR0004I BRARCHIVE completed successfully with warnings

it looks like above one might be the reason for script exit with status 1

 ERR - Script exited with status = 1 <the requested operation was partially successful>

it looks like its permissions issue..

please check with your DBA once..