Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

NetBackup + Hyper-V Cluster

Created: 01 Mar 2013 • Updated: 04 Mar 2013 | 5 comments
kml's picture
This issue has been solved. See solution.

Hi all,

i'm facing some trouble backuping Hyper-v machines on CSV cluster with NetBackup 7.5.0.4.

I have an Hyper-V cluster with 4 nodes. When i look into Failover cluster manager ==> Cluster Shared Volumes i can see VM on state "Redirected Access"
or "Backup in progress, redirected access" even if no backups are running...

When a backup starts on this cluster jobs can stay on "Begin Snapshot" status for weeks if we don't cancel it. Several bpfis process can be seen on the Hyper-v host.

When i look into DOS command ==> DISKSHADOW> list shadows all i can see 7 old shadow copies from August 2012. It seems that some old backups failed and snapshots
weren't deleted, so VM's stuck in "redirected access" mode.

Is it safe to delete those old shadow copies and retry a backup ?

Thanks in advance

Operating Systems:

Comments 5 CommentsJump to latest comment

Mark_Solutions's picture

I though the issue was fixed in 7.1.0.3 but maybe you were on an earlier version back then

I cannot see an issue with getting rid of them but do check all nodes

Use the Delete Shadows command to do it

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

Fabrice P.'s picture

Yes, you can remove them:

- diskshadow

- list shadows all

- delete shadows all

Personnally, I never implemented Hyper-V host backup because of this ugly CSV redirected mode which can have a HUGE impact on your virtualization infrastructure (I had CSV crash in the past, using that mode). This is entirely Microsoft's fault because they did not provided a good backup API for Hyper-V R2 (even DPM is working this way).

Now, let's see what will be the vm backup implementation with Hyper-V R3...  ;)

Authorised Symantec Customer ;)

kml's picture

Thanks guys. You're right Fabrice, this is a complete nighmare !

I did the following actions yesterday :

- make sure no hyper-v backups were running

- restart netbackup services on all cluster nodes

- kill all bpfis process on all nodes

- delete all shadow copies on all nodes with delete shadows all command

- restart "Virtual Machine Management service" on each node because the Microsoft Hyper-V VSS writer was on "retryable error" state. This action has no effect on running VM

After all that backups seems to run fine. I'll give you an update on monday !

SOLUTION
captain jack sparrow's picture

Can you sync up with Support to see if there is EEB for this issue. 

Also can you just verify integration services are installed correctly (i believe it is required within Guest VM, unlike vmware tools)

Try reinstalling it,

Was it working well before?

Try lowering NBU client level and see if it helps

Just an update 7.5.0.5 has released. You may try that as well 

 Cheers !!!

CJS

kml's picture

Hi all

Hyper-V backups ran fine this week-end.

I think the old shadows cleanup + clean multiple bpfis processes was the key

Thanks for your help !