Video Screencast Help

netbackup remote admin console, inventory robot screen do not show up

Created: 08 Jul 2013 | 36 comments

Dear community. i cannot find anywhere if this has been seen already, but i am having a problem with my remote admin console.

when i try to inventory robot from my console, the windows never come on. i tried with the java gui it works fine.

it used to work in the past. so for me now, my only solution is to open a remote desktop to the master server or any of the media servers.

anyone has a clue why ? someone could tell me if there is some trace i can put on my workstation to see what is going on ?

i tried to uninstall and reinstall, does not fix the problem.

any help would be appreciated!

best regards.

-FD

Operating Systems:

Comments 36 CommentsJump to latest comment

Dyneshia's picture

Is the remote admin console running on a windows 2008 workstation ?   If so, be sure to right click on the admin console and run as administrator.  Are you able to access any of the other items in the remove admin console ? ( activity monitor , device monitor etc )  Are you getting an error when you try to inventory the robot ?  create the following folders under the netbackup\logs directory :

admin

nbconsole

upload for review

FrankDe's picture

Thank you for the reply. i will enable these folders.

the remote admin run on a windows 7. i do start it as administrator. yes, so far all other features, the screens are working as it should. so far, that is the only windows that do not open. i am not getting any errors on the screen. it simply do nothing! used to work in the past. i can do the inventory from other workstation and servers. the problem is located on my work computer only.

i will create logs folder and advise! thanks.

FrankDe's picture

the admin folder did not produced any logs. nbconsole did.

what i did was, start NB remote admin, tried to do a robot inventory. closed NB.

AttachmentSize
070813.txt 40.71 KB
FrankDe's picture

i saw some security stuff, i will add full control on the files/folders to see if it makes a difference.

FrankDe's picture

did not changed anything. windows is still not opening up. the admin log is still empty. the nbconsole is different (less errors) but still, no window opening up.

i am running out of idea!

AttachmentSize
nbconsole_070813_2.txt 31.96 KB
watsons's picture

Saw this in your nbconsole log:

  NBAuthenticate: VxSS is Prohibited...

Did you enable NBAC in this environment? What if you disable it to test if it works?

Another thing to check, is the NBConsole.exe in task manager taking a lot of resources (CPU or memory)? 

FrankDe's picture

no, nbac is not enabled as for nbconsole.exe ressources, on startup, it consume 44,240K and cpu is idle.

if i start a "inventory robot", cpu goes to 2 %, and memory is now 70,888K. if i try again, it stays at that level.

Marianne's picture

Can we check if the underlying commands are working?

Please disable UAC first of all (1st thing I do when I get a new laptop).

Open cmd and cd to <install-path>\veritas\volmgr\bin

vmcheckxxx -rt <robot_type> -rn <robot_number> -rh <robot_host> -h <EMM_server>
e.g:
vmcheckxxx -rt tld -rn 0 -rh <master> -h <master>
 
Let us know if output is produced or perhaps error message.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

FrankDe's picture

Hi, the underlying command works perfectly.

sample snipet of the output bellow, it see all 306 slots.

C:\Program Files\Veritas\Volmgr\bin>vmcheckxxx.exe -rt tld -rn 23 -rh mtl1bkma03b.dnet.domtar -h mtl
1bkms01.dnet.domtar

        Robot Contents          Volume Configuration

Slot    Tape  Barcode           Media ID Barcode        Mismatch Detected
====    ====  =============     ======== =============  =================
   1     Yes  FM0484L3          FM0484   FM0484L3
   2     Yes  DR1457L3          DR1457   DR1457L3
   3     Yes  DR1253L3          DR1253   DR1253L3
   4     Yes  FM0008L3          FM0008   FM0008L3
   5     Yes  MT1619L3          MT1619   MT1619L3
   6     Yes  DR0132L3          DR0132   DR0132L3
   7     Yes  MT1385L3          MT1385   MT1385L3
   8     Yes  MT1746L3          MT1746   MT1746L3
   9     Yes  OR0034L3          OR0034   OR0034L3
  10     Yes  DR1535L3          DR1535   DR1535L3
  11     Yes  MT0160L3          MT0160   MT0160L3
  12     Yes  OR0016L3          OR0016   OR0016L3
  13     Yes  DR1455L3          DR1455   DR1455L3
  14     Yes  DR0055L3          DR0055   DR0055L3
  15     Yes  DR0051L3          DR0051   DR0051L3
  16     Yes  MT0769L3          MT0769   MT0769L3
  17     Yes  DR0150L3          DR0150   DR0150L3

Mark_Solutions's picture

In additional to the other excellent posts .. as well as the possibility of NBAC and UAC you do need to be a local administrator on your PC to get full functionality from the console

Also ensure your firewall is turned off and that your PC resolves the Master correctly and vice versa to ensure you get proper communications between your laptop and the Master Server

Finally for now .. is your Admin Console running exactly the same version and patch level of NetBackup as the Master?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

FrankDe's picture

yes, my domain user id is a local administrator of my laptop. yes also, the nslookup goes perfeclty back and forth. and yes, also, we have 7.5.0.5 installed on our master server as well as the same version on my laptop.

i also want to say that the java gui on my laptop i can perform inventory robot.

Marianne's picture

Please check vm.conf entries on the Master server, robot control host (if different) and admin console.

I have seen in the past that list of server names that can manage devices is sometimes added to vm.conf.

The default is to only have this entry in vm.conf: MM_SERVER_NAME 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

FrankDe's picture

my master server contains the following
MM_SERVER_NAME = mtl1bkms01.dnet.domtar
MEDIA_ID_BARCODE_CHARS = 0 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 1 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 2 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 3 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 8 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 9 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 10 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 14 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 13 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 11 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 12 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 18 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 6 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 17 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 16 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 5 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 15 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 4 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 7 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 19 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 20 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 21 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 22 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 23 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 24 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 25 8 1:2:3:4:5:6
MEDIA_ID_BARCODE_CHARS = 26 8 1:2:3:4:5:6
 

my robot control host has the following
MM_SERVER_NAME = mtl1bkma03.dnet.domtar

my laptop do not contain any vm.conf file under c:\program files\veritas\volmgr\

Marianne's picture

WOW!! You have THAT many robots in your environment?! Presumably not all the same robot control host?

If more than one robot control host, check SERVER entries on your Admin Console as well as alll robot control hosts - ensure all of them contain SERVER entries for your Admin Console and that port connectivity and hostname lookup works in all directions.

Other than this, I'm officially out of ideas.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

FrankDe's picture

we have more datadomains than backup robot. ;-)

yes, everything is fine. all connectivity works, my co-worker that sit beside me can do inventory robot. this is something really pointing to my laptop local here. my workstation only. this is so strange.

i am too runing out of ideas.

thanks for the help tho! appreciated a lot!

Dyneshia's picture

Are you sure you are running the 7.5.0.5 version of the remote admin console ? 

Can you upload the screen shot of help-> about

When you use the remote admin console, its like using a mini server.

Do you have a netbackup\bin\admincmd directory ?

Where did you obtain the install for windows 7 remore admin console ?

 

FrankDe's picture

yes i am pretty sure, attached are the version from screen shots.

yes i do have that folder on my machine, other screen shots.

obtained the install from the links here;

release 7.5
through my account at fileconnect at symantec, third screen shot

patch 7.5.0.5
http://www.symantec.com/business/support/index?page=content&id=TECH199269

SNAG-0000.jpg SNAG-0001.jpg SNAG-0002.jpg
Dyneshia's picture

Check the registry

 Located at : HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\NetBackup\CurrentVersion\Config

 - double click on server and confirm the master server is listed first and then all media servers.
- Confirm the client, browser are set to the workstation

- if you have a EMM_SERVER key make sure that is set to the master server.
 

FrankDe's picture

ok, server key is ok. master is the first line, followed by all the others media server and contains my workstation.

browser and clients are set up to my workstation as well. i have no emm server.

Marianne's picture

I also have Windows Admin Console installed on my laptop (7.5.0.4) - no EMM server entry in registry.

I am still thinking that there is a possible timeout to one of the robot control hosts (assuming the DD VTLs all have robots configured on various media servers).

When you have time - please test the vmcheckxxx command with each of the robots.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

FrankDe's picture

i will remove and re-install from scratch. but still, after removed the apps. there is still services and files + reg keys created. i will manualy delete everything.

after, i will reinstall again from scratch and test the inventory robot.

Mark_Solutions's picture

I have seen similar issues when it was actually the users profile that caused the issue

When you are back up and running if you still have the same issue try logging on as someone elese on your laptop to see if it then works

If it does then delete your local profile from yoru PC (back things up if it is not roaming!!) then login again to re-create it and try again

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

FrankDe's picture

ok i will try as a different user.

in the meantime, i uninstalled all netbackup product. but surprinsingly, services are still running, and files are still existing. so now im stuck, i can not reinstall or uninstall from the DVD. so i have to clean remove everything from the registry. for a weird reaosn, NB DVD thinks it is still installed. but there is no more file. the repair function fails, the install fails!

ill try to fix this, then use another user.

best regards. -FD

Mark_Solutions's picture

mmmm - sure you really have full local admin rights on that PC?

Try a repair when logged in as another user / domain admin

You can right click on the Symantec NetBackup.msi on the DVD and select Repair to try and force it that way

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

FrankDe's picture

my profile account, used for every tasks, is not local admin. i use another account, domain, which is local admin. when i start install program or when i want to run program as admin, i use my administrator account.

for instance, my outlook, and other regular apps, i have to use my fdesfosses account, and i have an account on the domain controler which is called admfdesfosses, that has local admin rights.

ill continue to try to fix this stuff!

Mark_Solutions's picture

Sometimes when you go to control panel and select to uninstall NBU it just removes the patch (say 7.5.0.5) and rolls you back to 7.5GA - but doesn't leave it in control panel

Try running the repair using the original 7.5 media first and then re-apply the appropriate patch

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

FrankDe's picture

in the control pannel there is no more NB products. yes indeed, yesterday, it went from 7.5.0.5 to 7.5.0.4 to 7.5 ... removed them all from the CP.

tried to repair from the DVD. do nt works either. im still playing arround!

ill fix my install problem then come back with the inventory robot!

thanks you all so far! be back later

Marianne's picture

To cleanup after failed uninstall of NBU, delete all of these registry keys:

<HKEY_LOCAL_MACHINE>\Software\Veritas\Netbackup.  

If there are any services that are hanging around, you can clear these out from the registry as well.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\

The services that would need to be gone if they exist are as follows:

All NetBackup named services

VRTSpbx

 

Hope this helps!

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

FrankDe's picture

all right, managed to make unsinstall and reinstall ok., basicly, i did a rollback (system restore) to past week, then uninstalled again the NB softs. that time, it uninstalled ok! so re-installed 7.5 then 7.5.0.5 perfectly, but still back to

cannot inventory robot on this single computer.
oh well... condemed to use the java gui just for inventory robot! aparently...

someone have an idea !?

i have also did ad suggested, tried the vmcheckxxx for all robot we have, all commands worked perfectly.

Mark_Solutions's picture

So is your PC listed as an additional server for the Master and the Robotic control host?

Have you tried logging onto your PC as another user and running it?

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

FrankDe's picture

my PC is listed as "aditional server" under the master NB propertiess;
my PC is not listed as a robot controler
no i hav not yet tried another user as logged on. ill try that now!

FrankDe's picture

tried to log on as a local administrator of the laptop, and still cannot open the inventory robot.

i deleted the local admin profile and let the computer rebuilt it from scratch, same results.

i can see, that when i try to inventory robot, i see the child windows opening up and closing pretty fast by itself. i do not see the window being draw, but i see the icon on the task bar quickly created and closing. fast enough that i cannot read or see the content of the icon.

mph999's picture

Can I suggest looking in the logs.

I would start with the following:

...veritas\netbackup\logs\nbconsole

wingui unified log -o 263

Recommend turning the verbose up to verbose 5/ general 2 fr nbconsole and DebugLevel 6 for wingui

Regards,

Martin

 

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
FrankDe's picture

ok sounds good to me, but that might sounds weird, i know where to look for server logs and clients log... but what about remote console !? where i can change the loggin of my own laptop as remote admin console !?

probably editing nblog.conf ? or do i have inside remoet console a logging option ?