Video Screencast Help

Netbackup restore getting hang.

Created: 26 Nov 2012 • Updated: 30 Nov 2012 | 6 comments
This issue has been solved. See solution.

Netbackup version 7.5

Master Operation system : Solaris 10

Client Operation system : Solaris 10

Policy type : standard

The backup was taken n DC. we want to restore it in DR.

I have imported the tape in DR and tried restoration of the backup on Nov 19. It completed successfully without any issue.

I have taken the same backup on Nov 26 and imported the tape in DR. But the restore is getting hang at a particular directory(/oracle/RP1/sapdata1) . I have tried to restore /oracle/RP1/mirrorlogA from the same backup image and it completed successfully.

If I cancel the restore job, the bpbrm and bptm in the master server is still running and in cliet side te TAR process is running. I trid to kill the TAR process but unable to stop it.

What can be the issue? Why the TAR jobs are still running afer cancelling the restore jobs?

Comments 6 CommentsJump to latest comment

Marianne's picture

You need to enable logs in order to troubleshoot.

Logs needed:

On master: bprd (restart NBU after creating log folder)

On media server: bptm and bpbrm

On client: tar

Please rename logs to reflect process name (e.g. tar.txt) and post as File attachments.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Sivaranjani's picture

Hi Marianne,

Thanks for your reply...

We are facing some OS issue in the client machine. I will upload the required logs asap.

Marianne's picture

Do not attempt any more restores until OS issues have been resolved.
These 'issues' are probably causing the restores to go into a hang state.

Anything useful in /var/adm/messages?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Joseph_TKLee's picture

Hang migth be finished after around 15 minutes with some error messages as I had similiar experience.

Did you wait enough time?

Sivaranjani's picture

Hi Joseph,

The CLIENT_READ_TIMEOUT = 1500. I have waited for more than 30 mins. and multiple tar processes were hang in the destination host.

Now the issue is resolved..

We have remounted the file system and restarted the restore. The restoration completed successfully.

Joseph_TKLee's picture

Good.. thanks for sharing your solution Sivaranjani. I like it.