Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup Tape Drive is unusable

Created: 28 Apr 2010 • Updated: 08 Jun 2010 | 13 comments
This issue has been solved. See solution.

Hi,

Netbackup is not enabling the tape drive. when i try to add the device during the initial startup configuration.
The Netbackup wizard is showing the device but showing it to be unusable

I have done some troubleshooting and it says that ur license may have expired.

Comments 13 CommentsJump to latest comment

Marianne's picture

You did not mention you NBU or O/S versions.
Have you checked hardware compatibility lists?
The 6.5 Device Matrix also provides links to the latest device mappings.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

hamzafayyaz1983's picture

Hi,

The NBU is 6.5. and the operating system is solaris 10. and the host operating system has been patched upto september 2006.

I have been taking successful backups of nas shares of filer using ndmp when my library was directly connected to the filer using scsi cable through nbu 6.5.
but after that i removed the scsi cable from the filer and connect it to the nbu server machine and to the library.

The Library is connected to the solaris host server through scsi cable.
but its not getting the drive showing the error to be as unusable.

Thanx,
Hamza

Karthikeyan Sundaram's picture

It may be becasue of incorrect driver.. I found this link from googling.. may help.. because am not a UNIX Admin to assist.

Thanks, Karthikeyan Sundaram.

Marianne's picture

Verify that the Solaris st driver supports the tape drive (Sept 2006 is VERY old...):
# cd /kernel/drv/sparcv9
# strings st |grep -i ultrium
HP Ultrium LTO 3
HP      Ultrium 3*
XFPHP Ultrium LTO 2
HP      Ultrium 2*
XFPHP Ultrium LTO
HP      Ultrium 1*
Seagate Ultrium LTO
SEAGATE ULTRIUM06242-XX
IBM Ultrium Gen 3 LTO
IBM     ULTRIUM-TD3
IBM Ultrium Gen 3 LTO
IBM Ultrium Gen 2 LTO
IBM     ULTRIUM-TD2
IBM Ultrium Gen 2 LTO
IBM Ultrium LTO
IBM     ULTRIUM-TD1
IBM Ultrium LTO

Next, verify that you have installed the latest device mappings (see links in previous posts).

Next, verify that sgscan can see all the devices. If not, follow steps in Device Config Guide to rebuild (sg.build) and install (sg.install) the sg driver.
You will find a text version of the device config guide in /usr/openv/volmgr.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Nicolai's picture

You get the limitation in the "device configuration wizard" when Netbackup doesn't have the pass thru driver in place. You may consider to install the driver manual. See the device configuration guide for advice.

Assumption is the mother of all mess ups.

If this post answered your'e qustion -  Please mark as a soloution.

Will Restore's picture

Before you start

Observe the following points when you configure the operating system:

■ Verify that NetBackup supports your server platform and devices. The Symantec support Web site contains server platform compatibility information. For the compatibility information, see the Compatibility List for NetBackup Server or NetBackup Enterprise Server. The following is the URL:

http://entsupport.symantec.com

■ For SCSI controlled libraries, NetBackup issues SCSI commands to the robotic devices. For NetBackup to function correctly, the properly named device files must exits, as follows:

■ NetBackup installs its own pass-through driver, the sg driver SCSI generic. You must configure this driver properly to create device files for any device NetBackup uses.

■ The Solaris tape and disk driver interfaces also create a device file for each tape or optical disk drive device. These device files must exist for all read or write I/O capability. For more information, see:

■ "Configuring robotic controls" on page 82,

■ "Configuring optical disk drives" on page 87

■ Verify that the Solaris st driver is installed.

■ Verify that the devices are configured correctly. To do so, use the Solaris mt command and the NetBackup /usr/openv/volmgr/bin/sgscan utility. For the NetBackup shared storage options, ensure that the SAN and storage devices are configured correctly.

■ When you configure devices, you should attach all peripherals and reboot the system with the reconfigure option (boot-ror reboot---r).

■ If you remove or replace adapter cards, remove all device files associated with that adapter card.

■ If you use the Automated Cartridge System (ACS) robotic software, you must ensure that the SunOS BSD Source Compatibility Package is installed. The package is required so that the ACS software can use the shared libraries in /usr/ucblib.

■ Sun systems with parallel SCSI host bus adapters do not support 16-byte SCSI commands on any devices that are attached to these HBAs. Therefore, those HBAs do not support WORM media. To override this limitation, create a touch file as follows:

touch /usr/openv/volmgr/database/SIXTEEN_BYTE_CDB

Will Restore -- where there is a Will there is a way

Marianne's picture

Seems you've been battling for about a month now:
https://www-secure.symantec.com/connect/forums/rob...

We've tried to help you back then but you never got back to us.
Please tell us what happened in the meantime - can the O/S now see the devices? Have you confirmed that drives are usable at O/S level?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

hamzafayyaz1983's picture

Yes i ve been battling.

I have done the probe-scsi-all after reset-all at the ok prompt after init 0 the solaris sparc host machine.

There is a fatal instruction error on the scsi.

nd then it just moves on to the ok prompt again.

but its not showing me the tape library nor the drive on the probe-scsi-all command output.

The compatibility matrix is showing the compatability with solaris 10 with nbu 6.5.

I have tried the sg.install, sg.build. scripts and have removed the scsi driver and reinstalled em again.

regenerated the sg.conf file and it is generating the luns fine.

but still no entry in /dev/rmt/

Regards,
HAMZA

Marianne's picture

You need to involve your hardware and O/S support team.
NBU can only build sg entries once the O/S can see /dev/rmt entries.
When you are at the ok prompt, you need to do a reset-all before doing probe-scsi-all.
ONLY when probe-scsi-all sees the devices, do a boot -r.
If probe-scsi-all does not see the devices, call your hardware support team - there is something wrong with the physical connection. You might be trying to connect a  Low voltage Differential SCSI device to a Single-ended HBA. The connectors look the same, but there will be now comms. It might even cause damage to the device and/or HBA.
It might be as simple as SCSI termination...

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

hamzafayyaz1983's picture


I have reset-all and then i have probe-scsi-all but the probe-scsi-all is not showing the library and the drive.

This might be the problem but i have used the same scsi cable from the library to the san filer and it was working fine with NDMp.

and now it seems to connect perfectly fine from the library to the solaris host scsi port

hamzafayyaz1983's picture

Thank you marianne , wrobbins , nicolai , quebek and others for your support and help.

The problem has been solved. The hardware scsi card was fault. recheck from the system engineers.

Regards,
Hamza

SOLUTION