Video Screencast Help

Netbackup VMWARE backups failing with snapshot error 156

Created: 07 Mar 2013 • Updated: 18 Mar 2013 | 6 comments
SLIM786's picture
This issue has been solved. See solution.

Hi All,

Please can someone urgently assist, I currently setup a brand new Netbackup Environment,

-Netbackup 7.5.0.4.

-Clustered Solaris Master Server

-Windows 2008 R2 Backup Host

-Vcenter 5.1

VM Datastores have been presented to the Backup Host, Diskpart automount disable and automount scrub have been run on the Backup Host,

Credentials for the Vcenter Server have been entered and vailidated successfully, The Vmware policy can browse for The Vm's, Transport type set to SAN and using Display name.

Once a backup kicks off it fails with a 156 error,

The bpfis log shows the below message

 

“VMware_freeze: Unable to locate VM CFO_VDR

Thanks,

Operating Systems:

Comments 6 CommentsJump to latest comment

HEMANPR's picture

Edit your VM policy to search clients on Snapshot Options --> Client Name Selection -- VM Display Name, Then Browse your ESX Host for the client what you want to do the backup.

Add using this method and try again. Pls check if you don't have a Snapshot created on the VM client.

Let me know If this help you. Good Luck

Please MARK AS SOLUTION If my Post Help You. I use the following Symantec Products: Veritas Netbackup 7.5 On Windows Enterprise 2003 SP2 - / - Symantec EndPoint 12.1.100.157 RU1 On Windows Standard 2003 SP2 - / - Symantec&nb

SLIM786's picture

Hi, I have tried that allready, no luck, same error.

 

HEMANPR's picture

Othe option what I use when Receive this king of error is:

1. Within the NetBackup Administration Console, expand Host Properties in the hand pane

2. Within Host Properties, click Master Server and then the double-click the name of the Master Server in the right pane

3. Click on the Client Attributes section

4. If the client in question is listed here, click on the client name. If it is not listed, add and click on the client name.

5. Click the Windows Open File Backup tab

6. Ensure that Enable Windows Open File Backups for this client is not selected if open file backups are not required

 

Try this, if not please upload the Details Job

Questions:

The error 156 appear faster?

Do you see the Snapshot created on the VM Console when You send the backup job?

Let me know Thanks

Please MARK AS SOLUTION If my Post Help You. I use the following Symantec Products: Veritas Netbackup 7.5 On Windows Enterprise 2003 SP2 - / - Symantec EndPoint 12.1.100.157 RU1 On Windows Standard 2003 SP2 - / - Symantec&nb

HEMANPR's picture

Logs:

Please upload the Details Job and the BPFIS log

Thanks

Please MARK AS SOLUTION If my Post Help You. I use the following Symantec Products: Veritas Netbackup 7.5 On Windows Enterprise 2003 SP2 - / - Symantec EndPoint 12.1.100.157 RU1 On Windows Standard 2003 SP2 - / - Symantec&nb

SLIM786's picture

Windows Open File Backups is not selected, Below is the details status from the activity monitor, I have increased the vmcloglevel in the registry of the backup host to 6 so the bpfis is quite large. Please find the bpfis log file attached.

Nothing gets created on the VM Console yet, the backup fails before it evens reaches that point.

 

03/07/2013 12:49:19 - Info nbjm (pid=25225) starting backup job (jobid=46) for client CFO_VDR, policy VMware_Policy, schedule Test
03/07/2013 12:49:19 - Info nbjm (pid=25225) requesting STANDARD_RESOURCE resources from RB for backup job (jobid=46, request id:{AA2B7846-8714-11E2-B2F8-0017A477201A})
03/07/2013 12:49:19 - requesting resource Temp_Disk_Backup
03/07/2013 12:49:19 - requesting resource ctf-bck-master.NBU_CLIENT.MAXJOBS.CFO_VDR
03/07/2013 12:49:19 - requesting resource ctf-bck-master.NBU_POLICY.MAXJOBS.VMware_Policy
03/07/2013 12:49:20 - Info bpbrm (pid=2708) CFO_VDR is the host to backup data from
03/07/2013 12:49:20 - Info bpbrm (pid=2708) reading file list from client
03/07/2013 12:49:20 - Info bpbrm (pid=2708) start bpfis on client
03/07/2013 12:49:20 - Info bpbrm (pid=2708) Starting create snapshot processing
03/07/2013 12:49:20 - granted resource  ctf-bck-master.NBU_CLIENT.MAXJOBS.CFO_VDR
03/07/2013 12:49:20 - granted resource  ctf-bck-master.NBU_POLICY.MAXJOBS.VMware_Policy
03/07/2013 12:49:20 - granted resource  MediaID=@aaaab;Path=D:\test_backups;MediaServer=ctf-bck-vmhost01
03/07/2013 12:49:20 - granted resource  Temp_Disk_Backup
03/07/2013 12:49:20 - estimated 0 kbytes needed
03/07/2013 12:49:20 - begin Parent Job
03/07/2013 12:49:20 - begin VMware: Start Notify Script
03/07/2013 12:49:20 - Info RUNCMD (pid=29081) started
03/07/2013 12:49:20 - Info RUNCMD (pid=29081) exiting with status: 0
Operation Status: 0
03/07/2013 12:49:20 - end VMware: Start Notify Script; elapsed time 0:00:00
03/07/2013 12:49:20 - begin VMware: Step By Condition
Operation Status: 0
03/07/2013 12:49:20 - end VMware: Step By Condition; elapsed time 0:00:00
03/07/2013 12:49:20 - begin VMware: Read File List
Operation Status: 0
03/07/2013 12:49:20 - end VMware: Read File List; elapsed time 0:00:00
03/07/2013 12:49:20 - begin VMware: Create Snapshot
03/07/2013 12:49:21 - started process bpbrm (pid=2708)
03/07/2013 12:49:22 - Info bpfis (pid=4568) Backup started
03/07/2013 12:49:23 - snapshot backup of client CFO_VDR using method VMware_v2
03/07/2013 12:49:29 - end writing
Operation Status: 156
03/07/2013 12:49:29 - end VMware: Create Snapshot; elapsed time 0:00:09
03/07/2013 12:49:29 - begin VMware: Stop On Error
Operation Status: 0
03/07/2013 12:49:29 - end VMware: Stop On Error; elapsed time 0:00:00
03/07/2013 12:49:29 - begin VMware: Delete Snapshot
03/07/2013 12:49:30 - Info bpbrm (pid=4792) Starting delete snapshot processing
03/07/2013 12:49:30 - Info bpfis (pid=0) Snapshot will not be deleted
03/07/2013 12:49:30 - started process bpbrm (pid=4792)
03/07/2013 12:49:35 - end writing
Operation Status: 1542
03/07/2013 12:49:35 - end VMware: Delete Snapshot; elapsed time 0:00:06
Operation Status: 156
03/07/2013 12:49:35 - end Parent Job; elapsed time 0:00:15
snapshot error encountered  (156)
 
AttachmentSize
bpfis.docx 26.51 KB
SLIM786's picture

Hi, Issue has been resolved, There was nothing wrong on Netbackups side, however I have upgraded to Netbackup 7.5.0.5 just as an additional step.

Vcneter Credentials had all the required Priviledges, however the specific netbackup role that was created for us by the VM admins was not added to the very top hierarchy level in Vcenter which is the Vcenter node,

Once this was changed backups completed perfectly fine,

Regards,

SOLUTION