Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup Windows Remote Administration console timeouts

Created: 12 Dec 2012 • Updated: 04 Mar 2013 | 4 comments
This issue has been solved. See solution.

I have Netbackup Windows Remote Administration Console installed on my workstation.

I'm facing problems with windows console. It's running very slow. I'm getting timeouts.

For example if I start a restore, it waits a long time for requesting the media and then I got a timeout message saying socket was closed.

When using Java Administration console everything works fine.

Have you experienced something like that ?

I have a dedicated backup network between clients + masters servers + media servers.

From my workstation I'm communicating with master server on a different network (administration network). Again, it works fine using Java Console, just happens with Windows Remote Admin Console.

 

I have other question: Is that possible to use NBAC +  Java Console ?

I'm only trying Netbackup Windows Remote Administration Console because I have heard somewhere NBAC only works with Windows Admin Console.

Is that true ?

Comments 4 CommentsJump to latest comment

Douglas_A's picture

Hi Idias,

 

It sounds like the timeouts are possibly due to either the size of the restore you are trying or maybe that the workstation you are on might have multiple networks and its trying to use one of the other networks to commnicate with the master. You might try to add a route statment on your machine if it does in fact have multiple networks. If not do you have any firewalls on your admin network? or is the windows firewall on your master enabled? these can slow things down quite a bit.

 

AS for NBAC and java, yes they are compatible, if you enable NBAC it does work across all consoles and is enforced the samn on each.

Best of Luck,

Doug

 

 

Please remember to mark the most valuable answer to your issue as the solution.

SOLUTION
ldias's picture

Well, I have only one interface on my workstation. There's no firewall between my workstation and master server.

In case I decide to stay with java console. My master server is a linux. Can I add this linux master server to domain (active directory) ?

I didn't understand exactly requirements for running NBAC. Do I need a windows netbackup server ?

Dyneshia's picture

If you do not seem the same issue with the java console as you see in the remote admin console , do the following :

ost admin console performance issues are caused by having a decommissioned server entry OR an incorrect server entry in one of the 3 following places :

1) The registry :
 Located at : HKEY_LOCAL_MACHINE\SOFTWARE\Veritas\NetBackup\CurrentVersion\Config

- double click on server and confirm the master server is listed first and all other servers listed exist.
- Confirm the client, browser and EMM_SERVER key are the master server.

2) Host file/bp.conf
- Review both and confirm there are no decommissioned servers listed and confirm IP addresses and host names are correct.

3) Emm database.

From the bin\admincmd directory run nbemmcmd -listhosts.

If there is a server that no longer exists listed, run :
nbemmcmd -deletehost -machinename <machine name> -machinetype <type of machine, media, ndmp etc>

If there is a server that is missing from the environment :
nbemmcmd -addhost -machinename <media server name> -machinetype <type: master, media etc> -netbackupversion <complete NBU version with patchset> -operatingsystem <OS>

Please review these 3 places and verify everything is correct.
 

You did not mention what version of NBU you are running.  There was an issue back in 7.0.1
(ET2112063)  Windows Remote Admin Console is unable to connect to a master server or may exhibit slow performance.  
 http://www.symantec.com/docs/TECH137565
 

As far as Java console and NBAC, I would not reccomended it.  It is certified to work togther, however I have seen a ton of  etracks regarding this.

 

ldias's picture

I have solved the problem. It was a firewall issue, some netbackup ports was blocked. With Java Administration Console I didn't have this problem.

One of my posts I had posted there was no firewall between master and my workstation but actually there was, although I could communicate with master server.

Thanks