Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

Netbackup7 & vStorage

Created: 01 Sep 2010 • Updated: 08 Oct 2010 | 9 comments
This issue has been solved. See solution.

Hi

I have setup a policy to backup vm running on esx host and noticed that when using vstorage api, only vmdk file is backed up. On 6.5.5, vcb backup was actually backing up other vm related files together with vmdk files. I have even tried different backup options but only vmdk gets backed up.

Have I configured something incorrectly? How to fix this issue?
Thanks

Comments 9 CommentsJump to latest comment

Deepak W's picture

Can you just brief about your vmware backup policy??

If you are using VCB or vstorage API, whatever it be, with that backup you can restore entire VM as well as GRT.

and vstorage API is far superior to VCB in terms of simplicity...

and hope you have followed all steps as listed in NBU for VMware guide

-- Deepak W (Kindly close the thread if your query is resolved)

MohitK's picture

Yes i have followed the guide. I am using vstorage to back up the vm, using transfer type as SAN etc

Tim Hansen's picture

For what purpose would you need the extraneous files? Getting the vmdk backed up is the goal, right?

MohitK's picture

How would you restore a whole VM with just vmdk file. Need .vmx and other files to add a machine back to vm inventory etc

Giroevolver's picture

This is normal.

When you restore the VM you will now only see the VMDK file when you choose to do a restore from virtual machine backup if you used the vStorage API. If you look in the VMware admin guide there is a picture on it showing you only the VMDK for the restore proceedure. You are also unable to select the VMDK as you have to select the client on the left as it performs a full recovery not just the VMDK file. Netbackup no longer requires the VMX as it pulls the infomation out once the backup starts and stores it with the Image but not as a VMX because its using the new API.

If you selct the VM in question and the attempt to do a restore it will give you numerous options to change the location of the VM and it also shows the location and resource pool the VM was in during the backup. I have restored using this many times and it knows the config.

Here is a technote on it. http://seer.entsupport.symantec.com/docs/347299.htm I beleive this is for version 7.0 but it should apply to the latst version of 6.5 as i beleive that can use the vStorage API

Hope this helps!

SOLUTION
MohitK's picture
 
Giroevolver
Thanks for the link, it does answer some of my questions. So backing up full vm is not a problem and is working fine. However everytime I try to do a restore, it fails.
7/09/2010 12:12:57 p.m. - begin Restore
7/09/2010 12:12:59 p.m. - restoring image testvm.domain.co.nz_1283811322
7/09/2010 12:13:01 p.m. - started process bpdm (9076)
7/09/2010 12:13:01 p.m. - started process bpdm (6828)
7/09/2010 12:13:01 p.m. - begin reading
7/09/2010 12:13:01 p.m. - end reading; read time: 00:00:00
7/09/2010 12:13:32 p.m. - end Restore; elapsed time: 00:00:35
the restore failed to recover the requested files(5)

I get the above error when trying to do a restore. Pre restore tests are all passed but still doesnt do a restore. I am NBU7 on win2k8 r2 std

Thanks

MohitK's picture

This has been resolved. Both vm backup and restores are working. The service account needs to have enough access on esx to do restores.
Thanks for helping out everyone

Marianne's picture

Give credit where it's due...
I have moved the solution to the post that actually provided the answer to the initial question.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links