Video Screencast Help

Network Error IOException - Connection Refused when converting from Sysbase to SQL 2000 SP4

Created: 07 Dec 2007 • Updated: 21 May 2010 | 4 comments
I am trying to convert your Endpoint Manager installation from the Sybase database to SQL 2000 SP4. When I run the Management Server Configuration Wizard and select SQL Server, followed by the server name, port, database name, username, pass and client folder - I click NEXT and receive the following error....
 
Network Error  IOException - Conection Refused: connect
 
There is already an existing database on this SQL server for CAD software licensing.  It is running. I noticed that I cannot connect to it remotely using SQL Manager Lite, so this may have something to do with it.
 
install_log.err log file reads the following:
java.sql.SQLException: Network error IOException: Connection refused: connect
 at net.sourceforge.jtds.jdbc.ConnectionJDBC2.<init>(ConnectionJDBC2.java:371)
 at net.sourceforge.jtds.jdbc.ConnectionJDBC3.<init>(ConnectionJDBC3.java:50)
 at net.sourceforge.jtds.jdbc.Driver.connect(Driver.java:188)
 at java.sql.DriverManager.getConnection(DriverManager.java:525)
 at java.sql.DriverManager.getConnection(DriverManager.java:140)
 at com.sygate.scm.install.ui.MainFrame.prepareDatabase(MainFrame.java:2771)
 at com.sygate.scm.install.ui.MainFrame.configureDB(MainFrame.java:477)
 at com.sygate.scm.install.ui.MainFrame.nextBtnActionPerformed(MainFrame.java:422)
 at com.sygate.scm.install.ui.MainFrame.access$200(MainFrame.java:57)
 at com.sygate.scm.install.ui.MainFrame$3$1.construct(MainFrame.java:239)
 at com.sygate.scm.install.util.SwingWorker$2.run(SwingWorker.java:118)
 at java.lang.Thread.run(Thread.java:595)
Caused by: java.net.ConnectException: Connection refused: connect
 at java.net.PlainSocketImpl.socketConnect(Native Method)
 at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
 at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
 at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
 at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:366)
 at java.net.Socket.connect(Socket.java:519)
 at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
 at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
 at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
 at java.lang.reflect.Method.invoke(Method.java:585)
 at net.sourceforge.jtds.jdbc.SharedSocket.<init>(SharedSocket.java:275)
 at net.sourceforge.jtds.jdbc.ConnectionJDBC2.<init>(ConnectionJDBC2.java:300)
 ... 11 more
 
 
 
Specs on server:
 
Windows 2000 Server
Microsoft SQL Server 2000 SP4
 
Any suggestions?
 



Message Edited by eadsIT on 12-07-2007 06:57 AM

Comments 4 CommentsJump to latest comment

ooisk888's picture
This may be a stupid question but I will ask anyway. Did you make sure that MS SQLServer is running TCP/IP at default port for MS SQLServer?
 
 
SK
eadsIT's picture

I did need to turn on TCPIP but it made not difference. Still got the error message.

Symantec Support directed me to the "Migrating database to SQL Server" section in the installation documentation. I had to backup the database, uninstall symantec management server and reinstall it.

The uninstall hung at the CSCRIPT.exe window with a message about W3SRV (wwweb publishing service) and it messed up my IIS service. I then had to manually uninstall management server. Reinstall IIS. Then reinstall  of management server went fine and setup on SQL server.

Not smooth to say the least.


Harl;ey_XL1200's picture
Hello,
 
Make sure you have a MS SQL data connection between the Management server and the SQL server.  If you don't, there is no way you will be able to connect to the SQL database. It is real easy to setup,and test to make sure you are getting to the right DB.
 
regards,
mark
 



Message Edited by Harl;ey_XL1200 on 12-10-2007 08:47 AM

eadsIT's picture

Management server and SQL server are on the same server. The connection wasn't the issue.

I have everything working now after the reinstall.