Video Screencast Help
Symantec Appoints Michael A. Brown CEO. Learn more.

Network Inventory returns errors when running on my printers

Created: 23 Nov 2012 • Updated: 05 Dec 2012 | 1 comment
QuietLeni's picture
This issue has been solved. See solution.

Dear All,

I have discovered a large number of printers in my company using Network Discovery and I have defined a Data Class for the serial numbers of my printers.

Then I used the Wizard to create an Agentless Inventory of JUST the discovered printers in the infrastructure.

The Task goes VERY quick and says that it has finished within 30 seconds.

However, when I check the Altiris Log, I see the following error:

"23/11/2012 14:59:54","Message: Error while retrieving run information for task 7728a204-2388-4f9f-b706-deea59b44123
Details:    at Altiris.NetworkInventoryTask.Debugging.LoggingFactory.GetMessageDetails(Int32 index)
   at Altiris.NetworkInventoryTask.Debugging.NSEventLogger.LogErrorBody(String message, String category)
   at Altiris.NetworkInventoryTask.Debugging.BaseLogger.LogError(String message, String category, TraceLevel level)
   at Altiris.NetworkInventoryTask.Web.BusinessItems.TaskAdministration.GetTaskRunInformation(ITasksDataAccess dataAccessInterface, TaskInstanceData[] instances)
   at Altiris.NetworkInventoryTask.Web.PortalPages.Task.TasksRun.PopulateDataTable(DataTable table)
   at Altiris.NetworkInventoryTask.Web.PortalPages.Task.TaskDataPage.LoadData()
   at Altiris.WebControls.GridControl.Grid_BeforeCallback(Object sender, EventArgs e)
   at ComponentArt.Web.UI.Grid.OnLoad(EventArgs oArgs)
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Control.LoadRecursive()
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
   at System.Web.UI.Page.ProcessRequest()
   at System.Web.UI.Page.ProcessRequest(HttpContext context)
   at ASP.portalpages_task_tasksrun_aspx.ProcessRequest(HttpContext context)
   at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)
   at System.Web.HttpApplication.ApplicationStepManager.ResumeSteps(Exception error)
   at System.Web.HttpApplication.System.Web.IHttpAsyncHandler.BeginProcessRequest(HttpContext context, AsyncCallback cb, Object extraData)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)
   at System.Web.HttpRuntime.ProcessRequestNoDemand(HttpWorkerRequest wr)
   at System.Web.Hosting.ISAPIRuntime.ProcessRequest(IntPtr ecb, Int32 iWRType)

**CEDUrlStart** :http://entced.symantec.com/entt?product=SMP&version=7.1.8280.0&language=en&module=AoeO2LKL+B6iE4a/GWkhdajPH+lJ0l8+2LHs8XPbZUQ=&error=-1704948971&build=**CEDUrlEnd**
","Altiris.NetworkInventoryTask","w3wp","306"

I did set up the discovery with the right SNMP settings, however.

The only thing that I can say is that if I run the Task just on one machine, it works, like this thread:

https://www-secure.symantec.com/connect/forums/agentless-inventory-network-printers-0

Apologies for opening another thread, but IE seems not to be able to post an answer to that post.

Kindest regards,

QuietLeni 

Comments 1 CommentJump to latest comment

QuietLeni's picture

Dear All,

This has now been fixed. The problem was that there is an issue with a DLL in Network Inventory and the fix is described here:

http://www.symantec.com/business/support/index?page=content&id=TECH171740

Interestingly, this took Support nearly two weeks to find this and to present it as a fix and the fix is still considered to be untested.

From this, I can only guess that this has been on the Internal KBs for a long time and only been released now.

Oh well.

Kindest regards,

QuietLeni

What is the point of an Asset Management Solution that needs excessive management? Let me help you.

SOLUTION