Video Screencast Help

New 7.5 setup but Inventory keeps failing

Created: 10 Jan 2014 | 15 comments

We have a fresh install of CMS 7.5 on a Win 2008 R2 server.  I have successfully imported our workstations from AD and pushed the agent to a Win7 SP1 (64-bit) test machine.  But I have not been able to successfully run an initial 'Full Inventory'.  It's been very confusing to troubleshoot, too.  I couldn't find any reports under Jobs/Tasks on the server nor did I see any new Tasks in the workstation agent.  Finally I realized this inventory 'task' was listed under Policies on the server, and that I needed to change the View setting to 'Task Runs'.  This shows multiple failures.  If I view the details for any of them it shows:

Status: Failed
Return code: -2147221005
An unknown exception was thrown. 
CAtrsException exception, error = "Failed to execute task", OS error = 2147746291, at line 388

I googled this error and found this discussion forum!  One of the posts said to look in the C:\ProgramData\Symantec\Symantec Agent\Logs folder and I found a lot of good info there.  The log files show repeated loss of connection to the server.  As a test I disabled the firewall on the server; it's a dedicated box and not Internet accessible.  Also, I keep testing the policy by updating it to run again 20 minutes later.

Unfortunately the connection problems continue:

<event date='01/10/2014 12:51:05.5070000 -08:00' severity='4' hostName='test-workstation-here' source='ScheduleEngine' module='AgentScheduler.dll' process='AeXNSAgent.exe' pid='5360' thread='1420' tickCount='362945935' >
  <![CDATA[A monitored event has occurred, check all schedules]]>
<event date='01/10/2014 12:51:13.6910000 -08:00' severity='4' hostName='test-workstation-here' source='NetworkMonitor' module='AeXNetMon.dll' process='AeXNSAgent.exe' pid='5360' thread='3808' tickCount='362954110' >
  <![CDATA[IPv4 address change detected]]>
<event date='01/10/2014 12:51:13.7330000 -08:00' severity='4' hostName='test-workstation-here' source='NetworkMonitor' module='AeXNetMon.dll' process='AeXNSAgent.exe' pid='5360' thread='3808' tickCount='362954156' >
  <![CDATA[Server down [0x00000000]: https://internal-server-addr-here:443:{B81D1ABF-D418-4561-B9A5-BB71CEA8AE84}]]>

My suspicion is that our self-signed SSL cert fails intermittently but I don't know how to prove that.  It works at least some of the time as the workstation is reporting 'basic info' as well as receiving task updates; also I can manually open the HTTPS URL in a browser.

Any suggestions?  I greatly appreciate it!

Operating Systems:

Comments 15 CommentsJump to latest comment

tony-gh's picture

I'm also seeing this error though I don't think it's related to my full-inventory task?

<event date='01/10/2014 15:06:00.6440000 -08:00' severity='4' hostName=''test-workstation-here' source='Client Task Agent' module='client task agent.dll' process='AeXNSAgent.exe' pid='5360' thread='756' tickCount='371040531' >
  <![CDATA[Task started. Instance: [99bbaca0-4d4b-4c36-a13a-19a9c969f94b], Type: [ls].]]>
<event date='01/10/2014 15:06:00.6460000 -08:00' severity='1' hostName='test-workstation-here' source='CAtrsException' module='client task agent.dll' process='AeXNSAgent.exe' pid='5360' thread='756' tickCount='371040531' >
  <![CDATA[CClientTaskInstance::Execute(): CAtrsException exception, error = "Unable to find class ID", OS error = 2147746291, at line 69
re-throw at CAtrsComPtr::CoCreateInstance
re-throw at CAtrsComPtr::CoCreateInstance(BSTR)
re-throw at CClientTaskInstanceWin32::_CreateTaskHandler
re-throw at CClientTaskInstanceBase::_CreateTaskHandler
re-throw at CClientTaskInstanceBase::_Execute]]>
<event date='01/10/2014 15:06:00.6470000 -08:00' severity='4' hostName='test-workstation-here' source='Client Task Agent' module='client task agent.dll' process='AeXNSAgent.exe' pid='5360' thread='756' tickCount='371040531' >
  <![CDATA[Task finished. Instance: [99bbaca0-4d4b-4c36-a13a-19a9c969f94b], Result code: [-2147221005], Succeeded: [FALSE], Type: [ls], In Progress: [FALSE], Interrupted: [FALSE].]]>
tony-gh's picture

Also, also, the full-inventory policy is failing on the server itself.  So does prove it's a server or db issue, not a client/agent issue?

Klim_Belchev's picture

Just upgraded to 7.5 and getting the same exception but on a Boot to Production task:

CAtrsException exception, error = "Failed to execute task", OS error = 2147746291, at line 388

Did a repair and a reboot but still getting the same...

This is very strange - not sure but looks like issue with Task rather than DB

I wonder if anyone has had any luck with this?

Brandon's picture

After my upgrade to 7.5 HF5 I get this on the Boot to Production job as well.

CAtrsException exception, error = "Failed to execute task", OS error = 2147746291, at line 387

I let the SMA install itself at the end up the SOI job and the error is returned once the install is complete and the agent registers itself for the first time with the SMP. Did you ever narrow it down?

SK's picture

To eliminate inventory from the problem, add the inventory task to a managed software delivery policy and see if it runs that way.

Connect Etiquette: "Mark as Solution" those posts which resolve your problem, and give a thumbs up to useful comments, articles and downloads.

Klim_Belchev's picture

I think the reason could be the version of the agent.

Try to deploy an image with SMA 7.1 in it. Do you get the same error?

Also have you rebuild your PreBoot environments?

We resolved this by rebuilding the golden image to include SMA v7.5 - HF2 at the time.

I am still puzzled why it was failing on scripted OS installs as well...

Igor Perevozchikov's picture
  • Please check Client Task Agent status on your managed endpoint. CTA is registered?
  • Also try to "Reset Agent" and check what SMA throws in log on client C:\ProgramData\Symantec\SMA\Logs\


  • There is no problem with License usage node amount for "Inventory Solution"? Isn't exceeded?

Open SIM ⇒ Check License usage state

Open SMP Console ⇒ Home ⇒ First Time Setup



  1. Don't forget that, first you can find an answer for your question in Knowledge base
  2. If answer solves your question, then please mark as solution to close a thread
Brandon's picture

I don't have the problem with 7.1 but I haven't tried a different version of 7.5 besides HF5. I have re-created the bootdisk with no change.

The registration of the task server works fine for the client. My "Inventory Pack for Servers" is 100% used, but my "Inventory Solution" has free licenses.

Brandon's picture

The job seems to fail, then the Agent logs start. I attached screenshots.

job history2.png agent logs.png
sergei Z's picture

Both errors you're seeing in the logs are the same error:

0x800401f3 (-2147221005) - Invalid class string
0x800401f3 (2147746291) - Invalid class string

I think that means that some DLL that's supposed to actually execute the task is not properly registered. They are COM component so probably REGSVR32 could help here, I'm just not sure which DLLs need to be registered, I would say this should be some of inventory agent DLLs. You may want to find the folder where INVAGENT.DLL is located and try running REGSVR32 for each DLL there. Not every DLL is a COM DLL so REGSVR32 will show an error for some of them.

Don't worry about events below

  <![CDATA[A monitored event has occurred, check all schedules]]>

  <![CDATA[IPv4 address change detected]]>
  <![CDATA[Server down [0x00000000]: https://internal-server-addr-here:443:{B81D1ABF-D418-4561-B9A5-BB71CEA8AE84}]]>
they have nothing to do with the task failure, in your case Client Task Agent received all the task information from the server, it just cannot start the task.

sergei zjaikin, senior principal software engineer, symantec

david_sttz's picture

Hy guys,

is there already a solution for this post? I also have the problem, taht we upgraded to Version 7.5 and since that I get a ReturnCode -2147221005 when I want to do an Inventory of the computer.

BR, David's picture

I belive that the -2147221005 points to the failure of actually seeing the directory that you are trying to access on the local drive of the device in question.

I found this forum while looking for answers on why a task works fine on physical workstations but fails on virtual workstations. To cover the basic questions regarding the virtual workstation:

  • agent has all the plug ins
  • licenses are in order
  • If I deploy software through policy or Quick deliver, software installs just fine

As it seems, only the tasks that require destination path to the local drive are affected. That is how I came to conclusion that the issue has to be how Altiris sees the local path. This obviously isn't a thread that will address my problem but it my post might give you some insight on why it's failing.

Good luck 

tony-gh's picture

Honestly, I don't remember how I fixed this.  In general I have resorted to treating our 'local' Altiris install as a managed solution, i.e., I call Symantec Tech Support and let them figure it out.  For a supposedly mature product, I think Altiris still leaves a lot to be desired.  Just about everything I've tried to implement myself has failed -- and I've carefully followed the instructions (both here, in other blogs and in the official docs).  Symantec Tech Support always seems to know an additional missing step to make things work again.

Brandon's picture

Has anyone found a workaround to this yet or moved to a newer version and had it go away?

Alex Bizjajev's picture


In 99% of cases log error "OS error = 2147746291 at line 388" means some task targeted to the agent but agent does not have corresponding plugin to run the task. For example, if gather full inventory launched on a computer without inventory plugin then you will see such error.

Thank you,