Video Screencast Help
Scheduled Maintenance: Symantec Connect is scheduled to be down Saturday, April 19 from 10am to 2pm Pacific Standard Time (GMT: 5pm to 9pm) for server migration and upgrades.
Please accept our apologies in advance for any inconvenience this might cause.

New Retention Category Not Working

Created: 01 Sep 2012 • Updated: 03 Sep 2012 | 14 comments
AKL's picture
This issue has been solved. See solution.

Hello

I've been trying to make a custom retention category such that any items in Inbox & Sent items are expired after 12 months, using EVPM. Details were covered at below forum:

https://www-secure.symantec.com/connect/forums/retention-policy-compliance

However, I am not able to make this work on new items (old or already archived items is altogether different story).

For example, I apply the new policy - Store new items to archive manually - and check the vault information for selected items. The hidden message shows the updated retention category ID however the item itself has old retention category ID stamped to it and is not expired in EV.

Anything I could be doing wrong in above?

Thanks in advance !

Comments 14 CommentsJump to latest comment

TonySterling's picture

So are you basing Expiry on Modified Date or Archived Date?

I am a bit confused, you say Vault Information shows the correct retention category for the item, how are you determining it isn't right?  Are you using the Search.asp?

AKL's picture

Thanks for response Tony.

  1. Running expiry based on Archived date for now. (Might change it later to run based on modified date)
  2. Hidden item property for Inbox in the vault information shows correct retention category but selected item property shows old.
  3. Checked the retention category applied to Saveset in SQL.
  4. Used archive explorer to verify that item is still present and accessible.

 

Thank You

AKL

TonySterling's picture

So the items that have already been archived will not inherit the new retention category, only newly archived items will.

If you create a new folder with a new retention category and move items into it then it will inherit the new retention category if you are updating moved items.

TonySterling's picture

Sorry, I may have misunderstood.  Are you saying that newly archived items are still inheriting the old retention category?

AKL's picture

Correct. Just for review:

  1. Created new retention category that expires item after 12 months based on archive date.
  2. Applied the retention category to test archives using EVPM script (attached/mentioned with original forum) such that items only in Inbox & Sent items are impacted/expired based on category.
  3. Synchronized archive manually.
  4. Waited few days before testing.
  5. Made sure EV hidden message shows new retention category ID.
  6. Arcihved some new emails from test mailbox's Inbox.
  7. The newly archived items still inherited the old retention category.

I know currently EV doesn't "directly" supports stamping old or already archived items so we can keep them separate.

However, the newly archived items/savesets should inherit the applied retention category.

Thank You

AKL

TonySterling's picture

When you ran your evpm did you include OverrideArchiveLocks = true ?

SOLUTION
AKL's picture

No, I didn't use that (trying to recall why not now.)

I will use it now and test it today. Will update asap.

Thank You

AKL

AKL's picture

IGNORE BELOW: Got it working by putting parameter in Folder section. (Noob me)

_________________________________________________________________________

After running EVPM with Override, Now I recall why I didn't use it. ;-)

The EVPM script generates error when putting OverrideArchiveLocks = true in [Filter] section:

Line Number in error: 13

Section in error: Filter

Attribute in error: OverrideArchiveLocks

Value in error: true

The file is saved in unicode and runs fine without OverrideArchiveLocks parameter.

Thank You

AKL

TonySterling's picture

Does it error if you put it in the folder section?

AKL's picture

No it doesn't, I updated the ini file accourdingly (puting Override in both folder section, for Inbox & SentItems)

I see the newly archived item stamped with new retention category now. :-). Waiting for expiry to run to ensure it gets removed accordingly.

Will post results further results tomorrow (running retention & inactivity duration of 1 day so should've good result by tomm same time)

Thanks again !

Thank You

AKL

TonySterling's picture

No worries, I think that will do it for you.  

AKL's picture

Hi

So the override worked perfectly, the item expired as expected.

However new iems didn't archive based on "Inactivity" duration of 1 day mentioned with EVPM (portion pasted below). Default mailbox policy archive based on 30 days, and I was planning to use same in EVPM script as well, but can't say that it's tested because 1 day thing didn't work so far:

 

[Filter]
name = 12 Months Deletions
CreateShortcut = true
DeleteOriginal = true
unreadMAIL = true
UseInactivityPeriod = true
InactivityUnits = days
InactivityPeriod = 1

In folder Hidden message, I can see same setting, however the test email didnt got pick up by auto archive yet. Any modification needed in above?

Thank You

AKL

TonySterling's picture

So you manually archived items and they got expired correctly but scheduled archiving didn't archive anything?

Are these brand new items or were they restored at some time?

Can you do a run now against the mailbox for all items, just to be sure there was enough time for the mailbox to be processed?

AKL's picture

Worked like a charm ! :D

Thanks a lot ! As always :-)

Thank You

AKL