Video Screencast Help
Give us your opinion and win with Symantec! Please help us by taking this survey to tell us about your experience with Symantec Connect, so that we can continue to grow and improve.  Take the survey.

New Robot

Created: 29 Nov 2012 • Updated: 15 Jan 2013 | 12 comments
This issue has been solved. See solution.

Hello Everybody

My SL24 library has broken and I changed it for a new one.

How can I add this new robot in the Netbackup ?

I can see the new WWN at /dev/rmt, but it doesn´t appear at /dev/sg.

Do I have to manually edit the sg.conf and add the new entry or there is some command line to do it?

My NB 6.5.6 server runs at a Solaris 10.

Thanks for all...

Alexandre Andrich

Comments 12 CommentsJump to latest comment

Marianne's picture

Hope you have deleted old devices and restart Media manager processes?

Seems you need to rebuild sg drivers (no need to manually edit any files):

# cd /usr/openv/volmgr/bin/driver
# /usr/openv/volmgr/bin/sg.build all 

Install the new sg driver configuration:

# /usr/bin/rm -f /kernel/drv/sg.conf
# /usr/openv/volmgr/bin/driver/sg.install

Check/verify config:

# /usr/openv/volmgr/bin/sgscan

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

andrich's picture

Marianne

About your comment "Hope you have deleted old devices and restart Media manager processes..."

Is it only necessary delete the old robot in my Netbakup console ?

Do I have to proceed any deletion at Solaris or just follow the steps mentioned in your post above?

I have more two online robots operating in my Netbackup. This changes would affect them ?

Thanks

Alexandre Andrich

Marianne's picture

Just delete the old, discontinued devices from the GUI. This will require Media Manager restart.

If this is not done, new robot will be assigned a new robot number when you run the Device wizard. This will config a new STU and will need update of all policies using the STU.

This will not affect other devices.

Best to also run 'devfsadm -C -c tape' to ensure OS device names are cleaned up while adding new ones. Hopefully you have verified that Persistent Binding is in place?

Steps to rebuild sg driver will in no way affect existing devices - just add new ones.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

andrich's picture

Happy Xmas for all

I fired the commands you mentioned

sg.build all ;   rm /kernel/drv/sg.conf ;   sg.install ;   sgscan;

My SL24 robot still doesn´t appear on /dev/sg.

It is OK on /dev/rmt.

Take a look..

-bash-3.00# pwd
/dev/rmt
-bash-3.00# ls -l *6cbn*
lrwxrwxrwx   1 root     root          73 Dec 20 15:18 6cbn -> ../../devices/pci@8,700000/SUNW,emlxs@3/fp@0,0/st@w50014380032a27a2,0:cbn

-bash-3.00# pwd
/dev/sg
-bash-3.00# ls
c0tw2002000e1111677dl0  c0tw2008000e1111677dl0  c0tw210000008740f0b9l0  c0tw500104f000597446l0  c0tw500104f00059744cl0  c0tw500104f000597455l0
c0tw2002000e1111677dl1  c0tw210000008740ef7fl0  c0tw500104f000597437l0  c0tw500104f000597449l0  c0tw500104f00059744fl0

How can I add my SL24 robot ?

Thanks

mph999's picture

Ediited, as I had only posted the same as Marianne ...

OK, if the changer is not showing in scan after the sg driver has been rebuilt using Mariannes method, then check that the WWN of the changer is listed in the files :

/usr/openv/volmgr/bin/driver/sg.conf and sg.links.

If it is not, the it was not added by sg.build for some reason:

1.  Check the OS can see the library - cfgadm -al -o show_FCP_dev (or maybe just cfgadm -al will work)

2.  If it is not listed, you have a comms issues betwteen the OS and the hardware

If it is listed, try adding the lines to the files manually (as shown in a post below this), then re-run the lines in Mariannes post, but skip the sg.build all part.

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
Marianne's picture

Your SL24 is SCSI attached, right?

What does 'probe-scsi-all' see at 'ok' prompt?

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

andrich's picture

Marianne

My SL24 is SAN attached .

mph999's picture

So what does this command show:

cfgadm -al -o show_FCP_dev

(or 'probe-scsi-all' see at 'ok' prompt ... from Mariannes post).

You need to be sure to carry out all the things we ask ....  we can't progress at all until you do.

Martin

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
andrich's picture

-bash-3.00# cfgadm -al -o show_FCP_dev
Ap_Id                          Type         Receptacle   Occupant     Condition
c1                             fc-private   connected    configured   unknown
c1::210000008740ef7f,0         disk         connected    configured   unknown
c1::210000008740f0b9,0         disk         connected    configured   unknown
c3                             fc           connected    unconfigured unknown
c5                             fc-fabric    connected    configured   unknown
c5::2002000e1111677d,0         tape         connected    configured   unknown
c5::2002000e1111677d,1         med-changer  connected    configured   unknown
c5::2008000e1111677d,0         tape         connected    configured   unknown
c5::50014380032a27a2,0         tape         connected    configured   unknown
c5::50014380032a27a2,1         med-changer  connected    configured   unknown

c6                             fc-fabric    connected    configured   unknown
c6::500104f000597437,0         med-changer  connected    configured   unknown
c6::500104f000597446,0         tape         connected    configured   unknown
c6::500104f000597449,0         tape         connected    configured   unknown
c6::500104f00059744c,0         tape         connected    configured   unknown
c6::500104f00059744f,0         tape         connected    configured   unknown
c6::500104f000597455,0         tape         connected    configured   unknown
 

mph999's picture

Right, so we see the changer.

Do these command exactly as listed

cd /usr/openv/volmgr/bin/driver

mv sg.conf sg.conf.old

mv sg.links sg.links.old

../sg.build -all

Post up here the new sg.links / sg.conf file from /usr/openv/volmgr/bin/driver

Regards,  Martin
 
Setting Logs in NetBackup:
http://www.symantec.com/docs/TECH75805
 
SOLUTION
Yasuhisa Ishikawa's picture

Then, try this:

# cd /usr/openv/volmgr/bin/driver

# vi /usr/openv/volmgr/bin/driver/sg.conf
Add folowing lines into sg.conf.
<pre>
name="sg" parent="fp" target=0 lun=0 fc-port-wwn="w50014380032a27a2";
name="sg" parent="fp" target=0 lun=1 fc-port-wwn="w50014380032a27a2";
</pre>

# vi /usr/openv/volmgr/bin/driver/sg.link
Add folowing lines into sg.link.
<pre>
type=ddi_pseudo;name=sg;addr=w50014380032a27a2,0;       sg/c\N0t\A1l0
type=ddi_pseudo;name=sg;addr=w50014380032a27a2,1;       sg/c\N0t\A1l1
</pre>

# rm /kernel/drv/sg.conf

# ./sg.install

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

ankmah's picture

It seems problem with your SG drivers...one more thing first check on Library Console whether Robot is visible or not if yes...

Then very first delete all device by Netbackup Console or you can use 

nbrbutil -deletalalldevice -machinetype MASTER/MEDIA -machinename HOSTNAME

cd /

cfgadm -al

EDITING HERE--- Need to check changer is visible or not on OS also..

Now time to build drivers.

 copy sg and st.conf file 

cd /usr/openv/volmgr/bin/drivers

cp sg.conf sg.conf.old

cp sg.links sg.links.old

cp st.conf st.conf.old

-Move kernal sg

mv /kernel/drv/sg.conf /kernel/drv/sg.conf.old

-remove 

rm /usr/openv/volmgr/bin/driver/sg.conf

rm /usr/openv/volmgr/bin/driver/st.conf

rm /usr/openv/volmgr/bin/driver/sg.links

 Go to /usr/openv/volmgr/bin

sg.build all

Install

/usr/openv/volmgr/bin/driver/sg.install

Robot will be visible.....

Ankit Maheshwari