Video Screencast Help

No data returned from RMS Console for RHEL server

Created: 23 Jan 2012 • Updated: 31 Jan 2012 | 12 comments
pholaris's picture

After agent installation, I can't retrieve data from RHEL server 6.0, does not matter what kind of query, 

There are no errors through installation, the bvcontrold daemon is running and port 1236 is opened and I can see the RHEL server on the bv-control tree for UNIX into RMS Console.

I haven't had any kind of troubles for registering the snap-in unix with the Information Server (IS).

If I try to collect some data I get the message: "There are no items to show in this view"

Resource name and password is Ok, by other hand, intentionally I set a wrong password waiting for a authentication error but I receive the same message:"There are no items to show in this view"

any ideas?

Comments 12 CommentsJump to latest comment

Syed Hussain -Compliance Devil's picture

Hi,

I have seen exactly same issue on SUSE wherein shared libraries were missing from the
SUSE server which were required by our bv-Control for UNIX agent.

Request you to verify the following and make changes:

1.) Choose a problem target RHEL server and cd to:

/opt/BindView/bvcontrol/Linux/bin/

2.) Next, run the "ldd" program against the binaries
in the ../bin subdirectory. Eg:

# /path/bin/> ldd CredentialVerifier

3.) The ldd program will reveal all of the shared libraries
for the given binary. If any are missing, it will state: file
not found.

4.) Make a note of all shared libraries that are missing
from ldd.

5.) Next, locate the path where these shared libraries
are missing & install them.

6.) After installing missing shared libraries, rerun ldd
to verify that the binaries are found.

7.) On the same RHEL server, cd to:

/opt/BindView/bvcontrol/Linux/lib/

8.) Verify with ldd that all of the libraries in the ../lib
subdirectory are linked and not missing. For any
missing shared libraries, you will need to install them.

If the shared libraries that are missing are the
bv-Control for UNIX shared libraries, then you only
have to update your LD_LIBRARY_PATH environment
variable to include the /opt/BindView/bvcontrol/Linux/lib/
subdirectory, log out, then log back in, & try ldd again
to verify they are found.

Once the shared libraries are in place, remove the
target RHEL agent on the RMS/bv-Control for UNIX
side, then rerun setup.sh to configure the RHEL
agent. Then rerun Configuration on the RMS/bv-Control
for UNIX on the windows side to add the target agent back
into the system.

Let me know how it goes.

Thanks,

-Syed Hussain

 

If a post solves your problem, please flag it as solved. If you like an item, please give it a thumbs up vote.
Syed Hussain -Compliance Devil's picture

Hi,

Let me know if you were able to resovle the issue.

Thanks,

-Syed Hussain

 

If a post solves your problem, please flag it as solved. If you like an item, please give it a thumbs up vote.
pholaris's picture

I've executed the steps you suggested,

I think the main trouble is in libpam.so.0 as you can see
 
[root@localhost bvcontrol]# ldd Linux/bin/CredentialVerifier:/usr/local/BindView/bvcontrol/Linux/bin/CredentialVerifier:
 linux-gate.so.1 =>  (0xf77c7000)
 libcrypt.so.1 => /lib/libcrypt.so.1 (0xf7784000)
 libpam.so.0 => not found
 libc.so.6 => /lib/libc.so.6 (0x00385000)
 libdl.so.2 => /lib/libdl.so.2 (0x002a5000)
 libfreebl3.so => /lib/libfreebl3.so (0xf7736000)
 /lib/ld-linux.so.2 (0x00363000)
 
However, the libpam.so.0 is already installed in the path:
/lib64/libpam.so.0
 
By other hand, I watched into the bvcontrol.log file and the next error is related with libpam.so.0 too.

    6447|2012/01/24|17:36:55|BvUnixQueryExecutionControl|  425|Warning: - Peer Machine name is blank
    6447|2012/01/24|17:36:55|BvUnixAuthenticationProtoco|  240|Error: - 0xf0000002/usr/local/BindView/bvcontrol/Linux/bin/CredentialVerifier: error while loading shared libraries: libpam.so.0: wrong ELF class: ELFCLASS64
    6447|2012/01/24|17:36:55|BvUnixQueryExecutionControl|  662|Critical Failure: - 0xF0000002  -- Expecting handshake request from CredentialVerifier.
    6447|2012/01/24|17:36:55|BvUnixQueryExecutionControl| 1082|Error: - 0xf0000002 -- Failure during interaction with the Credential Verifier.
    6447|2012/01/24|17:36:55|BvUnixQueryExecutionControl|  173|Error: - 0x0
    6447|2012/01/24|17:36:55|BvUnixQueryExecutionControl|  175|Error: - 0xf0000002
    6447|2012/01/24|17:36:55| BvUnixAgentApplication.cpp|  296|Error: - 0xf0000002
    6450|2012/01/24|17:37:03|   ReSSLSocketValidator.cpp|  567|Error: - 0xf00000ca
    6450|2012/01/24|17:37:08|            ReTcpSocket.cpp|  114|Error: - 0xf0000002

What should I do in order to find the library installed?
 

 
thanks a lot

cmccoy2's picture

What version of the agent are you using?   Is it FIPS compliant or not?  (see the pcu 2011-3 readme for more information on that)  If you are installing the base 10.5 agent for RHEL and your RMS Console has been updated to PCU 2011-3 or PCU 2011-4 your console may be in FIPS mode and the agent may not be yet.  

Another option would be that PCU 2011-4 just started supporting RHEL 6.1.   Is that the version of your agent?

Hope this helps

Kawaljeet's picture

Where you able to get it work again ? If yes, Please share the solution for the same. I have a similar case

CCS Version : 10.5

Agent Version : Gold Agent

ERROR :

error while loading shared libraries: libpam.so.0: wrong ELF class: ELFCLASS64

 

Syed Hussain -Compliance Devil's picture

Hi,

Could you please also check whether you have latest Rapid fire updates applied

Thanks,

-Syed Hussain

 

If a post solves your problem, please flag it as solved. If you like an item, please give it a thumbs up vote.
pholaris's picture

 

I've installed bvControl-10.50-16.i386.rpm

If I try to install the lastest RF is imposible and the next message appears: Could not determine the Operating System of the remote host

 

Syed Hussain -Compliance Devil's picture

Did you have any sucess in resolving this issue?

Thanks,

-Syed Hussain

 

If a post solves your problem, please flag it as solved. If you like an item, please give it a thumbs up vote.
cmccoy2's picture

If you have installed the RF and get that message, you will need to enable "FIPS" mode.  look through the release notes of the PCU on how to accomplish this on page 12 or 13:

ftp://ftp.symantec.com/public/english_us_canada/products/symantec_control_compliance_suite/10.5.1/Updates/Data_Collectors/ReadMe_CCS_DataCollection_PCU_2011-3.pdf

Once you get the FIPS enabled, I believe that you should be able to contact your RHEL Server.  If you server is RHEL 6.1, that has only been supported with PCU 2011-4.

Hope that helps

pholaris's picture

Despite the FIPS mode is enabled I can not get returned data
 

 

Actually is it not possible to run agent properly

This agent supports 64bit arquitecture for RHEL server 6.0,?

Syed Hussain -Compliance Devil's picture

Did you tried in test environment to confirm it? or do we have any documentation which talks about it

Thanks,

-Syed Hussain

 

If a post solves your problem, please flag it as solved. If you like an item, please give it a thumbs up vote.
pholaris's picture

I have tested on 8 RHEL servers with 64bit architecture, in all of them I got the same behaviour