Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

No EV-Archiving after Exchange Update Rollup 5 v2

Created: 09 Feb 2013 • Updated: 01 Mar 2013 | 11 comments
HolgerMu's picture
This issue has been solved. See solution.

Hi Folks,

one of my Customer was complaining that his EV-Server would not archive any more. I was digging around and found out that it seems to be the Installation of Update Rollup 4 V2 or Update Rollup 5 V2 since the installation Date of these 2 Rollups correspond with the stopping of the archiving.

I get MAPI Errors when EV tries to connect to the Exchange.

I reapplied both Powershell Scripts for Throttling and EV-Permissions. I reinstalled Outlook on the EV-Server and reapplied all Office Hotfixes.

I ran fixmapi.exe on the EV-Server. 

EV Version is 10.0.2

Has anyone had this issue already and can give me a Hint on where else to look for

Thanks,

Holger

Comments 11 CommentsJump to latest comment

captain jack sparrow's picture

Best to PM or Rob Wilcox or JW

Or hold your patience, they would be on the way to this post

 Cheers !!!

CJS

TonySterling's picture

Can you post your event id's you are seeing and also a dtrace would be helpful.  You can zip the dtrace and attach it to your post.

AndrewB's picture

i have UR5-v2 installed in my lab with EV 10.0.2 and do not have any issues like this. maybe a dtrace will give you some more insight into the errors. wouldn't hurt to post whatever event logs you have right now too.

Andy Becker | Authorized Symantec Consultant | Trace3 | Symantec National Partner | www.trace3.com

HolgerMu's picture

Hi All,

Event ID Errors are pretty generic:

Event ID: 2256 The Archiving Task 'Exchange Mailbox Archiving Task for DE-RZ1EXC022' could not be started due to startup errors.

In the DTRACE I think this might be the Hint:

{CAgentTask::Initialise:#1325} Failed to open privileged MAPI session: [0x8004011d]. Aborting agent startup.

I can't even connect to Exchange via Outlook using the EVSA or the System_Mailbox

So I am focusing on getting Outlook to work and then I think EV will work. 

I was just hoping someone had ran into this Problem before and it might save me some time digging around the Customer's environment.

DTRACE attached, Customer's name is XXXXed out

Thanks,

Holger

AttachmentSize
EX_ROLLUP5.zip 79.4 KB
EVSERVER_EVENTLOG.zip 1.71 KB

------

Holger Mundt | I.Tresor GmbH & Co. KG | Germany | http://www.i-tresor.de

TonySterling's picture

I think you are on a good path, you need to figure out why you can't open the system mailbox via the outlook profile.  Re-verify all the permissions for the EV service account.

Also, do you have a host file entry for your CAS servers?  Wouldn't hurt to double check that.

captain jack sparrow's picture

Tony i feel EV is waiting for replication topology to get sync (not sure but a guess, As Exchange heavily relies on AD site)

Could be a reason updated permissions are not reflecting

 Cheers !!!

CJS

Rob.Wilcox's picture

I'd say you have 'something' going on from the AD side of things:

1510 18:29:01.965 [6052] (JournalTask) <7004> EV:L {ConfigureMsgServiceAttempt:#107} Trying ConfigureMsgService using PR_PROFILE_UNRESOLVED_SERVER [DE-RZ1EXC022], attempt [1] of [5]
1511 18:29:02.012 [6052] (JournalTask) <7004> EV:M {ConfigureMsgServiceAttempt:#119} ConfigureMsgService failed: [0x80040115]
1514 18:29:02.512 [6052] (JournalTask) <7004> EV:L {ConfigureMsgServiceAttempt:#82} Using provided Global Catalog Server [de-rz1ads003]
1515 18:29:02.512 [6052] (JournalTask) <7004> EV:L {ConfigureMsgServiceAttempt:#107} Trying ConfigureMsgService using PR_PROFILE_UNRESOLVED_SERVER [de-rz1ads003], attempt [2] of [5]
1516 18:29:02.559 [6052] (JournalTask) <7004> EV:L {ConfigureMsgServiceAttempt:#114} ConfigureMsgService successful
 
It says in that trace that the GC was specified.. so did you configure that in the VAC?  Is it a 'known good' Global Catalog?
 
This is the rub of the problem:
 
<snip>
I can't even connect to Exchange via Outlook using the EVSA or the System_Mailbox
</snip>
 
Have you tried logging in as the Vault Service Account on a regular workstation, and seeing if you can login and view the mailbox for the VSA or for the System Mailbox?
 
And of course, compare that with the server.
 
Until that's working, then you're stuck.
 
 
HolgerMu's picture

Hi Rob,

thanks for your input. I am able to log in from my "Customer's VM" with Outlook 2010. I even was able to attach the 2 System Mailboxes for the Exchange Servers.

I will now try to Download the Office 2007 Installation Media of the EV Server to test this on my workstation.

The GC specified (de-rz1ads003) is listed as GC in the Active Directory Sites and Services.

I also checked with no CG entered to let EV find the GC based on the Domain Info.

Thanks,

Holger

------

Holger Mundt | I.Tresor GmbH & Co. KG | Germany | http://www.i-tresor.de

JesusWept3's picture

If you use exchange 2010 in a single domain environment, you should look at using DS Server key under HKCU to point at a CAS server (not a GC) whilst logged in to the ev server with the evadmin account

After that make sure you can log in to the system mailbox for a targeted exchange 2010 server, also making sure that the exchange mailbox is located on that server and doesn't resolve to a different server

You may also wish to update the ExchangeServerEntry table and update the ExchangeGCOverride column pointing at GC://CASServer.yourdomain.com

Again making sure you can log in to the system mailbox without being prompted for credentials and try again

Also make sure that the sysmailbox is visible to the GAL and not disabled

SOLUTION
Rob.Wilcox's picture

So what version of Outlook do you have on the EV Server?

HolgerMu's picture

Outlook 2007 SP3

The system has been archiving for quite some time now. I installed the System about 4 yrs ago, updated it a few times inbetween and last year we moved to new Hardware and Windows Server 2008 R2. The system stopped archiving on january 8th .2013 with no action taken on the EV-Side. As I said, I have been diggin' around and found quite a lot Windows Security Patches and the Exchange Update Rollups installed on that date.

I will follow Alex's hints and then let you know more.

------

Holger Mundt | I.Tresor GmbH & Co. KG | Germany | http://www.i-tresor.de