Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

No logs under bpbkar

Created: 26 Feb 2013 • Updated: 01 Mar 2013 | 9 comments
kat1234's picture
This issue has been solved. See solution.

Hi all,

I got status 1 when doing catalog backup which store in a media server's staging. When I look into the bpbkar directory in master server, I find it didn't generate any log. I have enable the logging to 5 and also try with "bpbkar32 -nocont c:\ > nul 2>temp.f" on windows(master) but it return to command prompt immediate and still nothing under bpbkar.

Can someone help me resolve it....

Operating Systems:

Comments 9 CommentsJump to latest comment

Marianne's picture

Please show us where exactly you have created bpbkar folder? Post screenshot.

It is either in the wrong place or typo error in the name.

Please also double-check your bpbkar command. It should be as follows to test backup of C:\ (You may want to add sub-directory to only include catalog folders):

bpbkar32 -nocont C:\ 1> nul 2> nul 

This command will immediately return to the prompt. Check Task Manager for running bpbkar32 process. Wait till process completes/terminates.

Now check bpbkar folder. See http://www.symantec.com/docs/TECH17541

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

kat1234's picture

I have take the screen shot:

bpbkar32.exe need time to start? I have waited for several minutes but can't find bpbkar32.exe and there is not backup job now. Do I need to start some job on NBU?

CRZ's picture

According to your second screen shot, it has already run and completed, so you shouldn't expect to see it in the Task Manager.

I think Nagalla is on the right track - check the bpbkar32.exe file itself on the client - make sure it isn't empty or corrupted.


bit.ly/76LBN | APPLBN | 75LBN

ankmah's picture

please share output of below command.

 

vssadmin list writers.

this may cause bpbkar process.

 

 

Thanks

Ankit

RamNagalla's picture

what is the size of bpbkar32.exe.

there is a possilbity that bpbkar got corrupted and not working fine..

please compare the bpbkar32.exe, from the other working server4 which is having the same netbackup version.

if you find the difference just replace it with the working server bpbkar32.exe and try again.

Mark_Solutions's picture

D:\alternate_db ?

Have your catalogs been moved?

If so did they also move your logs directory somewhere else?

Take a look at two places:

\program files\veritas\netbackup\nblog.conf (looking for the Default.LogDirectory=C:\Program Files\Veritas\NetBackup\logs entry)

HKLM\Software\Veritas\NetBackup\CurrentVersion\ where there is a string value named Log Directory - this shows the logs directory path

Depending on the settings of these depends where the bpbkar log folder will produce its logs

Hope this helps

Authorised Symantec Consultant

Don't forget to "Mark as Solution" if someones advice has solved your issue - and please bring back the Thumbs Up!!.

watsons's picture

Windows 2008? The command prompt you open to run the bpbkar32 test, did you "run as administrator"? 

It might not be able to write to the bpbkar log folder if permission is denied... 

kat1234's picture

I found out what's happen. In the regedit, the entry of "Log Directory" defined as D drive, while the BP_LOGS_NAME define as C drive. It makes some logs (e.g. bpdbm) generate in C: but bpbkar log generate in D:

Thanks guys :)

Marianne's picture

Since Mark has pointed you in the right direction, I have moved the solution to his post.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links