Video Screencast Help

No mailbox sync in a long time, A5/6 not clearing

Created: 26 Aug 2013 • Updated: 25 Nov 2013 | 2 comments
This issue has been solved. See solution.

Good day,

I've been observing this issue for a while now and need to take action. Our EV setup handles two Exchange farms, a 2007 farm and a 2010 farm. EV is version 10.0.3 RU2, on a 2008R2 with 16 CPUs and 32GB RAM. There are separate archiving task for each of the four mailbox servers and each of the two journal mailboxes.

Everything is fine on 2010, but we've been processing through a large backlog on 2007, due to recently having added a lot of users to archiving. I haven't seen a mailbox synchronisation on the 2007 server in a long time, the status monitor is showing a 41447 for the server, and if I look in the event log, I see the 3197 events for all the other mailbox servers and the journals, but not this server. There are no error messages in the event log pertaining to the 2007 archiving task.

Another thing that I noticed, is that the A5 and A6 queues for the 2007 mailbox server haven't cleared in a long time. They are processing, albeit slowly, but keep filling back up before they hit 0. I understand that A5 is the mailboxes that need to be processed, and A6 is moved items inside a mailbox. I've once been given to understand that all other queues have to clear for A7 to process, can someone confirm that?

Task schedule (since this question always comes up): at the moment, I am running the archiving task at all times, to try and deal with the backlog. There is a 1 hour break in the schedule to allow for the synchronisation. I previously had the archiving suspended during business hours, but that didn't seem to make a difference.

Long story short, I need this sync to happen because we recently changed a few policies. What can I look at, what can be changed or improved?

Your advice is greatly appreciated.

 

Operating Systems:

Comments 2 CommentsJump to latest comment

JesusWept3's picture

OK so first off...Your best best is to do 4 hours with 15 minute breaks....plus take time for backup mode etc

but you should do like

00:00 -> 03:45
04:00 -> 07:45
08:00 -> 10:45
11:00 -> 14:45
15:00 -> 18:45
19:00 -> 22:45
23:00 -> 00:00

That will give you a total running time of 22 hours and 30 minutes and stop the tasks from going idle and refreshing caches etc, also make sure to stop and restart the services when you can to clear out any mapi leaks and monitoring leaks

Troubleshooting steps i'd perform are
1. Manually synchronize a mailbox or two on the Exchange 2007 Server, ensure that it works
2. Turn the schedule off so that EV isn't performing anything
3. Set scheduled synchronization to occur at the next nearest hour and restart the task
4. DTrace ArchiveTask and start it when the synchronization starts
5. Monitor the Exchange Management Console and look at the last logins to see if the EVAdmin is hitting them
6. Look at the dtrace to see if the synchronizations are actually occuring or whether any errors are being thrown in the background

You may also want to look at MSMQ to make sure it hasn't breached its quota (default is 1GB)
Also make sure that you have your Tasks appropriately configured, 1000 messages per pass and five threads, if you are breaching 32 threads per EV server, you can possibly causing other connectivity issues

Another thing you may want to look at as well, is setting the GC override as it could be more GC connecitivty than anything, but you'll see that in the dtrace

Other things can be like ensuring the system mailbox is located on the correct Exchange server
ensuring that you can log on to the system mailbox , using the EV Admin logon without being prompted for credentials etc

 

SOLUTION
racq_qld's picture

Thanks for your suggestions. I've implemented the modified schedule and will be looking at the other suggestions in the coming days, as EV is dealing with another 200k+ backlog on the A1 queue right now.

Will give feedback as to how things went soon.