Video Screencast Help
Symantec to Separate Into Two Focused, Industry-Leading Technology Companies. Learn more.

No mailboxes appear to be restored from tape backup

Created: 02 Feb 2010 • Updated: 01 Dec 2010 | 12 comments
Ahmad Matar's picture
This issue has been solved. See solution.

We have the following:
1. Symantec Backup Exec 12.5 SP3 with Hotfix 337202
2. Exchange Server 2007 SP1 with Roll update 8

We have backup job for mailbox server to tape and it is finishing successfully, but when going to restore from this backup we see only Logs folder and can't see any mailbox database or mailboxes.

This problem does not appear when backing mailbox databases to Backup to disk folder.

Here the picture which shows the restore view when trying to restore from tape bakup:

BE125Exch2007Restore.jpg

Comments 12 CommentsJump to latest comment

Caroline Kiel's picture

Hi Ahmad,
with Backup Exec 12.5 and Exchange 2007 you do usually make a GRT-enabled Backup. Means, you can restore singe mailboxes or even single Items from within a mailbox.
The only point to do so is, that you have to make a backup to disk to be able to make differential or incremental backups. From tapes only full backups can be restored.
So the most common way ist to make a B2D2T (Backup to disk to tape) by duplicatiing the backup made to disk by a policy.

Hope this helps,
Oliver

If this post is the answer to your question, please mark it as a solution.

If you can dream it, you can do it. (Walt Disney)

Ahmad Matar's picture

Hi,

Thanks for you.

But GRT is enabled and this issue appeared after upgrading from Backup Exec 12 to Backup Exec 12.5 and appeared suddenly.

All backup jobs are full backup jobs, we do not use incremental or differential backups for mailbox databases.

We want solution, B2D2T is not a solution.

Luke Cassar's picture

Hi Ahmad,
Make sure your service account still matches a mailbox on the server you are backing up with GRT (remember you need a mailbox that BE can use to be able to do GRT restores).

The mailbox also must have a unique name (first 5 characters are meant to be unique).

Normally no mailboxes for restore means GRT is not selected OR backup exec cant find its special mailbox (cant be hidden and must be on the Exchange server being backed up).

Hope that helps!

Mandar's picture

Hi Ahmed

            please make sure that the account used for backups has appropriate rigts as per document

http://seer.entsupport.symantec.com/docs/288777.htm

if its so then duplicate the data to disk and then run the restore it should work fine. 99% of the times its the access or permissions issue.

SOLUTION
Deepak W's picture

 Create the duplicate backup job for Tape-to-Disk and then restore from the disk based copy.

This is because BE does not support GRT restoration of exchange mailbox direct from tape based backup. If you are directly restoring from tape it will mount the information store in staging area (temp location on backup server) which will consume almost double the disk space than actual backup size i.e. if backup size is 100GB then staging area will require almost 200GB free space.


Now in your situation create duplicate backup job (tape-to-disk) and restore it from disk. It should show the mailboxes.

Recommendation for backing up exchange DB with GRT is first backup on disk and then duplicate job to tape. i.e. B2D2T

Hope this helps you... 

-- Deepak W (Kindly close the thread if your query is resolved)

Ahmad Matar's picture

I appreciate all your replies.

But all these settings are configured correctly and it was working perfectly and no changes in permissions or required settings for backup exec.

Backup Exec 12.5 will show mailbox databases and mailboxes if backup is stored on tape or on disk.

the temp folder will be used in the restoration process from tape backup and can't be used in restoration process from backup to disk folder.

I have now open case with Symantec and still waiting their replies.

CraigV's picture

Hi,

Have you looked at restarting your services and checking for any alerts in the Alerts tab?
Restarting services can refresh an environment that might have gotten into a tangle for some reason, and the Alerts will prompt you to any possible problems!
I would have also suggested unticking AOFO if you were using it, but if it worked before the issue started, then that is not it.

Laters!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

sirtay's picture

Hi Ahmad, I have the same problem.

have you came up with anysolution from symantec...

m.roed's picture

Hi everyone,
I have the exact same issue here. When i try to make a restore job from tape i'm only able to see the logs. User rights and all other settings i ok. When i make a job with the same settings but B2D instead every thing is ok. It worked previosly.

Does anyone have a solution to this problem?

/The desperate...

CraigV's picture

Hi m.roed,

Should actually be a new forum query...when you duplicate to disk, it restores everything (edb, .chk file, logs etc) to disk.
If you were doing a straight restore of user data in Exchange, you shouldn't see those logs.
Not quite sure what your exact issue is...?

Laters!

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...

m.roed's picture

Hi CraigV,

It's the exact the same problem as Ahmad had. When you take a look at the scrdmp Ahmad attached you are able to see the Logs only, not the mailsbox database.
When i do a duplicate backup (T2D) it contains the mailbox database. But I'm still not able to se the mailstore from within the BU exec restore job and select a single mailbox to redirect?

Thanks for your fast reply

/M

CraigV's picture

OK, so when it is duplicated to disk, you don't find the IS to restore from when you go to the Restore tab? Does it at least show up the media?
Following onto that, is your installation fully patched?

Alternative ways to access Backup Exec Technical Support:

https://www-secure.symantec.com/connect/blogs/alte...