Video Screencast Help

No package could be found for the selected Agent installation policy" when clicking on an Deployment Solution Installation policy

Created: 08 May 2012 | 10 comments
nickbromley's picture

Deployment site server componants task blank....

When you navigate to Settings -> All Settings -> Agents/Plug-ings -> Deployment and Migration and client on any of the policies under this path you are presented with an error message, which states that the corrosponding package for the selected policy could not be found. As a result you are unable to deploy any of the plug-ins associated with Deployment Solutions

tried the published fix (TECH187100) but the file'ThisFolder.xml' is missing in the zip file provided, and so the Fix fails

have uninstalled and resinstalled

Comments 10 CommentsJump to latest comment

nickbromley's picture

repair, uninstall, and published fix applied

same issue for x64 and x86 platform policies


fabio.sanches's picture

Hi Nick,

Please try using this command line (change the E:\ for your NS drive) with administrative rights:

E:\Program Files\Altiris\Notification Server\Bin>AeXConfig.exe /configure "E:\Program Files\Altiris\Deployment\Config\Altiris.Deployment.config"


carlsson's picture

Hi we currently have the same issue, we have a call logged with support, it's been two weeks now with numerous support sessions and running the config command with different config files and still no resolution.

was told yesterday that "Other users are experiencing the same issue and they are working on it"angry

This is really holding us back

Sorry for the rant not helpful to you but I'll post if we ever get a fix for this



fabio.sanches's picture

Hi Carlson,

Thanks for your feedback. I would like to continue trying help you with your issue.

Please could you verify if have some error message log when go to that page?


carlsson's picture

Hi Fabio

to confirm yes it's exactly the same error/issue

The x86 install/upgrade was returning the same error for us but running the config update/import resolved this, but not for the x64 .

The problem is 90% of our site servers are 2008 R2 x64

Regards  C


Saeed's picture

Can you attached the log viewer log.. That might give the background of it.

If a forum post solves your problem, please flag it as a solution. If you like an article, blog post or download vote it up.

ConfusedplzHelp's picture

I am getting the same error trying to install the Preboot Automation Folder.  Argh!  I have been tryiing for a week and a half to get this server working and I am having nothing but problems.  This is after a third rebuild the the server and client.  Haven't even been able to push or pull an image yet.  Here is my screen shot.

Pascal KOTTE's picture

We got same problem, one of the upgraded MP1 platform our customers: but with the "Software Management Upgrade" package/policy.

No way, no repair was working. And Symantec support told us all existing package/component will disappear if we remove and reinstall the software manage solution (and not sure will work better than the repair)

Also not possible to export packages/components, (export possible, not import) for restoring them after removing the "soft manage solution" for a reinstall.


Why repairs are not able to solve this kind of problem ? Looks like a bug, a big one.

~Pascal @ Do you speak French? Et utilisez Altiris: venez nous rejoindre sur le GUASF