This issue has been solved.

NO Volumes to select when creating PureDisk disk pool on Media Server - 7.5.0.1

Created: 27 Sep 2012 • Updated: 04 Oct 2012
Login to vote
0 1 Vote

My setup is:

1. Master/Media - On linux Pointed to tape robot

2. Media Server - Windows 2008 R2, pointed to SAN PureDisk dedup pool over fiber (works great).

3. Media Server - One with the issue. Windows 2008, pointed to SAN PureDisk dedup pool over iSCSI.

 

I set up the first media server, numer 2, without any problems then recently built out a new media server, number 3, to use as a place to make an iSCSI PureDisk pool. The iscsi volume is presented, formatted and can be writter to without issues. We have it mounted as the E: drive. I installed the netbackup 7.5 software and configured the server as a media server. Then patched to 7.5.0.1. Under credentials I was able to set up the Storage Server to my new Media server with the iSCSI host.

 

Problem is, when I go to make the disk pool the wizard says that there is not a volume available to select. After poking around doing comparisons with our working media dedup pool server I noticed my new server was lacking the dedup services. It was missing the Deduplication Engine and Deduplication Manager services. I then noticed that C:\Program Files\VERITAS\pdde on the working media server had much more files and folders than number 3.

I reinstalled, and made sure when selecting additional licenses that I chose the pure disk option, this this was prior to the install the dedup files and services still did not show up.

Im stumped and not sure what I might be doing wrong, the first go around was simple. Only thing I can think is that we are only licensed to have ONE dedup pool from ONE media server...Any help appreciated.

 

-Mike

Quick Look Solution

Since you already have MSDP

Since you already have MSDP in your environment, we assumed that you are aware of the very first requirement for MSDP. (Well, we all know what assume did, don't we?)

Please review the Deduplication server minimum requirements in NBU Dedupe manual.

1st in the list is CPU requirement: 
Symantec recommends at least a 2.2-GHz clock rate. A 64-bit processor is required.
At least four cores are required. Symantec recommends eight cores.  
For 64 TBs of storage, Intel x86-64 architecture requires eight cores.

 

Operating system is 3rd in the list:
The operating system must be a supported 64-bit operating system.
See the operating system compatibility list for your NetBackup release on the NetBackup
Enterprise Server landing page on the Symantec Support Web site.

 

Filed Under

Comments

Yasuhisa Ishikawa
Partner
Accredited
Certified
27
Sep
2012

I assume you are configureing

I assume you are configureing Media Server Deduplication Pool but you selected "PureDisk Deduplication Pool" on storage server configuration wizard. PureDisk Deduplication Pool requires PureDisk storage pool machines which consist from PureDisk OS(PDOS) and PureDisk application. PureDisk storage pool can not be accessed via iSCSI. So I believe what you want is Media Server Deduplication Pool(MSDP).

If you select "Media Server Deduplication Pool" correclty, this wizard does not show volumes - you need to enter storage path in text box when creating MSDP.

Once remove credential, and run wizard again. Be sure to select "Media Server Deduplication Pool".

Authorized Symantec Consultant(ASC) Data Protection in Tokyo, Japan

28
Sep
2012

You would be 100% correct.

You would be 100% correct. Though, im suprised you cannot use iSCSI for PureDisk.  So, I retraced my steps and went throught the "storage servers" wizard in credentials. This time while selecting Storage Path: (E:Deduplication) I get an error:

system call failed. RDSM has encountered an STS error: updatedStorageServerCoinfig

I then found this article...according to it 32bit is NOT supported. Well, this server is a 32bit server.

http://www.symantec.com/business/support/index?page=content&id=TECH124898

Am I SOL until I can get a 64bit server up?

Marianne
Trusted Advisor
Accredited
Certified
28
Sep
2012

Have you added Dedupe license

Have you added Dedupe license (NetBackup Data Protection Optimization Option) on the media server?

Have you reviewed the iSCSI support section of NBU Dedupe manual?

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

Marianne
Trusted Advisor
Accredited
Certified
28
Sep
2012
SOLUTION

Since you already have MSDP

Since you already have MSDP in your environment, we assumed that you are aware of the very first requirement for MSDP. (Well, we all know what assume did, don't we?)

Please review the Deduplication server minimum requirements in NBU Dedupe manual.

1st in the list is CPU requirement: 
Symantec recommends at least a 2.2-GHz clock rate. A 64-bit processor is required.
At least four cores are required. Symantec recommends eight cores.  
For 64 TBs of storage, Intel x86-64 architecture requires eight cores.

 

Operating system is 3rd in the list:
The operating system must be a supported 64-bit operating system.
See the operating system compatibility list for your NetBackup release on the NetBackup
Enterprise Server landing page on the Symantec Support Web site.

 

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links

04
Oct
2012

Reinstalling the OS to 64bit

Reinstalling the OS to 64bit did indeed allow me to set up the media server deduplication pool. So that worked :) thank you all for the help.

However, now I am getting a new error "EMM status: Server is not licensed for Remote Client Option
Server is not licensed for the Remote Client Option  (2063)" So, im digging in to this,

Marianne
Trusted Advisor
Accredited
Certified
04
Oct
2012

Check license keys on the

Check license keys on the media server.
You need Enterprise Server and dedupe license.

Supporting Storage Foundation and VCS on Unix and Windows as well as NetBackup on Unix and Windows
Handy NBU Links